summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-20 14:01:04 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-20 14:01:04 +0000
commitec75d84ecaed1f550a3a99ccd8394fa9b2afaf74 (patch)
treee377d96d1edf436420b82e41857233393b1ede39 /net-im/linphone
parentcleaned up majorly (diff)
downloadhistorical-ec75d84ecaed1f550a3a99ccd8394fa9b2afaf74.tar.gz
historical-ec75d84ecaed1f550a3a99ccd8394fa9b2afaf74.tar.bz2
historical-ec75d84ecaed1f550a3a99ccd8394fa9b2afaf74.zip
removed pic nonsense
Diffstat (limited to 'net-im/linphone')
-rw-r--r--net-im/linphone/ChangeLog7
-rw-r--r--net-im/linphone/files/digest-linphone-0.9.0-r11
-rw-r--r--net-im/linphone/linphone-0.9.0-r1.ebuild45
3 files changed, 52 insertions, 1 deletions
diff --git a/net-im/linphone/ChangeLog b/net-im/linphone/ChangeLog
index b1c5614465d3..a7f083f9af97 100644
--- a/net-im/linphone/ChangeLog
+++ b/net-im/linphone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/linphone
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.2 2003/02/12 08:02:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.3 2003/03/20 14:01:04 seemant Exp $
+
+*linphone-0.9.0-r1 (20 Mar 2003)
+
+ 20 Mar 2003; Seemant Kulleen <seemant@gentoo.org> linphone-0.9.0-r1.ebuild:
+ removed pic stuff
*linphone-0.9.0 (05 Sep 2002)
diff --git a/net-im/linphone/files/digest-linphone-0.9.0-r1 b/net-im/linphone/files/digest-linphone-0.9.0-r1
new file mode 100644
index 000000000000..0a9d56343a92
--- /dev/null
+++ b/net-im/linphone/files/digest-linphone-0.9.0-r1
@@ -0,0 +1 @@
+MD5 696986d6fd133efda2cee98fe7230513 linphone-0.9.0.tar.gz 1845011
diff --git a/net-im/linphone/linphone-0.9.0-r1.ebuild b/net-im/linphone/linphone-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..7f5eeaf73a3b
--- /dev/null
+++ b/net-im/linphone/linphone-0.9.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/linphone-0.9.0-r1.ebuild,v 1.1 2003/03/20 14:01:04 seemant Exp $
+
+IUSE="doc gtk nls xv alsa"
+
+# AUTHOR: Paul Belt <gaarde@gentoo.org>
+
+DESCRIPTION="Linphone is a Web phone with a GNOME interface. It let you make two-party calls over IP networks such as the Internet. It uses the IETF protocols SIP (Session Initiation Protocol) and RTP (Realtime Transport Protocol) to make calls, so it should be able to communicate with other SIP-based Web phones. With several codecs available, it can be used with high speed connections as well as 28k modems."
+HOMEPAGE="http://www.linphone.org/?lang=us"
+SRC_URI="http://www.linphone.org/download/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="dev-libs/glib
+ =net-libs/libosip-0.8.8
+ =gnome-base/gnome-panel-1.4.1
+ xv? ( dev-lang/nasm )
+ gtk? ( =x11-libs/gtk-1.2* )
+ alsa? ( >media-sound/alsa-driver-0.5 )"
+
+src_compile() {
+
+ local myconf
+
+ if use gtk && use doc
+ then
+ myconf="--enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ econf \
+ `use_enable alsa` \
+ `use_enable nls` \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ dodoc ABOUT-NLS COPYING README AUTHORS BUGS INSTALL NEWS ChangeLog TODO
+ einstall PIXDESTDIR=${D} || die
+}