summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-04-06 03:44:54 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-04-06 03:44:54 +0000
commitecfd82add33d987bdca8167dd4b21598df2834e6 (patch)
treebe92cf6feaa90c4d5117db2c2bef586d4b929fbb /net-im/magnesium/magnesium-1.0.1c.ebuild
parentfix digest (diff)
downloadhistorical-ecfd82add33d987bdca8167dd4b21598df2834e6.tar.gz
historical-ecfd82add33d987bdca8167dd4b21598df2834e6.tar.bz2
historical-ecfd82add33d987bdca8167dd4b21598df2834e6.zip
*** empty log message ***
Diffstat (limited to 'net-im/magnesium/magnesium-1.0.1c.ebuild')
-rw-r--r--net-im/magnesium/magnesium-1.0.1c.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/magnesium/magnesium-1.0.1c.ebuild b/net-im/magnesium/magnesium-1.0.1c.ebuild
new file mode 100644
index 000000000000..6b5d914dd2d6
--- /dev/null
+++ b/net-im/magnesium/magnesium-1.0.1c.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/magnesium/magnesium-1.0.1c.ebuild,v 1.1 2004/04/06 03:44:54 mkennedy Exp $
+
+MY_P=${PN}-${PV/1.0_/}
+DESCRIPTION="Magnesium (also known as Curphoo X)) is a Yahoo! Chat client"
+HOMEPAGE="http://magnesium.kicks-ass.net/ http://members.iinet.net.au/~texascm/mg/"
+SRC_URI="http://magnesium.kicks-ass.net/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="=gnome-base/libglade-2*
+ =dev-python/pygtk-2*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s,magnesium.glade,/usr/lib/${P}/magnesium.glade,g" ui.py
+}
+
+src_install() {
+ insinto /usr/lib/${P}
+ doins *.py *.glade
+ chmod +x ${D}/usr/lib/${P}/mg.py
+ sed "s,@MAGNESIUMPATH@,${P},g" <${FILESDIR}/magnesium >magnesium || die
+ dobin magnesium
+ dodoc AUTHORS CHANGELOG CREDITS INSTALL LICENSE README requests NEWS
+}