summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-02-19 20:54:58 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-02-19 20:54:58 +0000
commit18ce2b2b0e8a99ef2f787480f7142cdc1b3b43e8 (patch)
treeb751aa4d5fca2e2dc33e391052626625e4fc6738 /net-im
parentLicq depends on QT regardless whether or not 'kde' (or even 'qt') is (diff)
downloadhistorical-18ce2b2b0e8a99ef2f787480f7142cdc1b3b43e8.tar.gz
historical-18ce2b2b0e8a99ef2f787480f7142cdc1b3b43e8.tar.bz2
historical-18ce2b2b0e8a99ef2f787480f7142cdc1b3b43e8.zip
On a second look, I see that Licq should be able to build without the
QT plugin. Added "qt? ( >=x11-libs/qt-2.2.0 )" to dependencies. Also, added a hack to compile with any version of QT, including 3. Until now, the .ebuild had QTDIR=/usr/qt/2 hard-coded, which was breaking the compilation for users with only QT 3 installed.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/licq-1.0.4-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-im/licq/licq-1.0.4-r1.ebuild b/net-im/licq/licq-1.0.4-r1.ebuild
index 99596e9598ff..9c372d65b566 100644
--- a/net-im/licq/licq-1.0.4-r1.ebuild
+++ b/net-im/licq/licq-1.0.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.0.4-r1.ebuild,v 1.4 2002/02/19 20:34:39 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.0.4-r1.ebuild,v 1.5 2002/02/19 20:54:58 agenkin Exp $
. /usr/portage/eclass/inherit.eclass || die
use kde && inherit kde-base
@@ -12,7 +12,7 @@ DESCRIPTION="KDE/QT ICQ Client with v6 support only (UDP)"
SLOT="0"
DEPEND="$DEPEND
ssl? ( >=dev-libs/openssl-0.9.6 )
- x11-libs/qt"
+ qt? ( >=x11-libs/qt-2.2.0 )"
use kde && need-kde 2.1
@@ -35,7 +35,12 @@ src_compile() {
if [ "`use qt`" ]
then
- export QTDIR=/usr/qt/3
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
cd plugins/qt-gui-1.0.4
make -f Makefile.cvs || die
use kde && kde_src_compile myconf