summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-03-13 21:20:36 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-03-13 21:20:36 +0000
commit0f2723997ace74d0b46ffe82ed9769db63056e59 (patch)
tree5296c0e3afef915b27e3cdc3377b6f2d530ac3c3 /net-irc/tirc/tirc-1.2.ebuild
parentBump for non bash scripts. (diff)
downloadhistorical-0f2723997ace74d0b46ffe82ed9769db63056e59.tar.gz
historical-0f2723997ace74d0b46ffe82ed9769db63056e59.tar.bz2
historical-0f2723997ace74d0b46ffe82ed9769db63056e59.zip
Version bump
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'net-irc/tirc/tirc-1.2.ebuild')
-rw-r--r--net-irc/tirc/tirc-1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-irc/tirc/tirc-1.2.ebuild b/net-irc/tirc/tirc-1.2.ebuild
new file mode 100644
index 000000000000..5213312c5cec
--- /dev/null
+++ b/net-irc/tirc/tirc-1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/tirc/tirc-1.2.ebuild,v 1.1 2007/03/13 21:20:36 armin76 Exp $
+
+DESCRIPTION="Tolken's IRC client"
+HOMEPAGE="http://home.mayn.de/jean-luc/alt/tirc/"
+SRC_URI="mirror://debian/pool/main/t/tirc/${PN}_${PV}.orig.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="debug"
+
+DEPEND="sys-libs/ncurses"
+
+src_compile() {
+ if use debug; then
+ myconf="--enable-debug"
+ fi
+
+ econf ${myconf} || die "econf failed"
+
+ emake depend || die "emake depend failed"
+ emake tirc || die "emake tirc failed"
+}
+
+src_install() {
+ dobin tirc || die "dobin failed"
+ doman tirc.1 || die "doman failed"
+ dodoc Changelog FAQ Notes README doc/* || die "dodoc failed"
+}