summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-10-05 17:40:32 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-10-05 17:40:32 +0000
commit447a60dbf3956dc41dea304fe0272805054ca6b2 (patch)
tree56297ade385b8cb9e286bd9fdc93bc1b39f78cfe /net-irc/vyqchat/vyqchat-0.1.1.ebuild
parentInitial Release. (diff)
downloadhistorical-447a60dbf3956dc41dea304fe0272805054ca6b2.tar.gz
historical-447a60dbf3956dc41dea304fe0272805054ca6b2.tar.bz2
historical-447a60dbf3956dc41dea304fe0272805054ca6b2.zip
Initial Release.
Diffstat (limited to 'net-irc/vyqchat/vyqchat-0.1.1.ebuild')
-rw-r--r--net-irc/vyqchat/vyqchat-0.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-irc/vyqchat/vyqchat-0.1.1.ebuild b/net-irc/vyqchat/vyqchat-0.1.1.ebuild
new file mode 100644
index 000000000000..32ceb93be130
--- /dev/null
+++ b/net-irc/vyqchat/vyqchat-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.1.1.ebuild,v 1.1 2003/10/05 17:40:22 gregf Exp $
+
+DESCRIPTION="QT based Vypress Chat clone for X."
+HOMEPAGE="http://linux.bydg.org/~yogin/"
+SRC_URI="http://linux.bydg.org/~yogin/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="arts"
+
+DEPEND=">=qt-3.0
+ arts? ( kde-base/arts )"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+ use arts && myconf="--with-arts"
+ ./configure --host=${CHOST} \
+ --prefix=/usr --infodir=/usr/share/info \
+ --mandir=/usr/share/man --with-x \
+ --with-Qt-dir=/usr/qt/3 ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc README THANKS NEWS
+}