summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-07 18:47:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-07 18:47:14 +0000
commit8adf24e27c9412badefce4d81181b300c875576d (patch)
tree9607cc4c9f89b2eb8d13dd8efb2a02b43271a100 /net-irc
parenta python module (diff)
downloadhistorical-8adf24e27c9412badefce4d81181b300c875576d.tar.gz
historical-8adf24e27c9412badefce4d81181b300c875576d.tar.bz2
historical-8adf24e27c9412badefce4d81181b300c875576d.zip
Changed python config
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.0-r11
-rw-r--r--net-irc/xchat/xchat-1.8.0-r1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-1.8.0-r1 b/net-irc/xchat/files/digest-xchat-1.8.0-r1
new file mode 100644
index 000000000000..a331f8e1ad0a
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.0-r1
@@ -0,0 +1 @@
+MD5 2d040e1b156b8fed91e7ac3cf83f309a xchat-1.8.0.tar.bz2
diff --git a/net-irc/xchat/xchat-1.8.0-r1.ebuild b/net-irc/xchat/xchat-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..7662ba9e5f0b
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.0-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.0-r1.ebuild,v 1.1 2001/07/07 18:47:14 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xchat"
+SRC_URI="http://www.xchat.org/files/source/${PV}/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+DEPEND="perl? ( sys-devel/perl )
+ python? ( >=dev-lang/python-2.0-r4 )
+ nls? ( >=sys-devel/gettext-0.10.38 )
+ gnome? ( >=gnome-base/gdk-pixbuf-0.11.0
+ >=gnome-base/gnome-core-1.2.2.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+RDEPEND="gnome? ( >=gnome-base/gdk-pixbuf-0.11.0
+ >=gnome-base/gnome-core-1.2.2.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_compile() {
+
+ local myopts
+ local myflags
+
+ if [ "`use gnome`" ]
+ then
+ myopts="--enable-gnome --enable-panel --prefix=/opt/gnome"
+ else
+ myopts="--enable-gtkfe --disable-gnome --prefix=/usr/X11R6 --disable-gdk-pixbuf"
+ fi
+ if [ "`use ssl`" ] ; then
+ myopts="$myopts --enable-openssl"
+ fi
+ if [ -z "`use perl`" ] ; then
+ myopts="$myopts --disable-perl"
+ fi
+ if [ "`use python`" ] ; then
+ myflags="`python-config --libs`"
+ else
+ myopts="$myopts --disable-python"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myopts="$myopts --disable-nls"
+ fi
+ try ./configure --host=${CHOST} ${myopts} --enable-ipv6
+ if [ "$myflags" ] ; then
+ for i in src/fe-gtk src/fe-text
+ do
+ if [ -e $i/Makefile ] ; then
+ cp $i/Makefile $i/Makefile.orig
+ sed -e "s:-lpython2.0:$myflags:" \
+ $i/Makefile.orig > $i/Makefile
+ fi
+ done
+ fi
+ try pmake
+}
+
+src_install() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr/X11R6 install
+ fi
+ dodoc AUTHORS COPYING ChangeLog README
+}
+
+
+
+
+
+