summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-31 02:39:01 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-31 02:39:01 +0000
commitfa6fe1b70a22ac3afc8b34afa8d941a30a9843c3 (patch)
tree5a6a80d1fa21d8c34584cbd45c933c9697e0c988 /net-libs/c-client
parentnew version (diff)
downloadhistorical-fa6fe1b70a22ac3afc8b34afa8d941a30a9843c3.tar.gz
historical-fa6fe1b70a22ac3afc8b34afa8d941a30a9843c3.tar.bz2
historical-fa6fe1b70a22ac3afc8b34afa8d941a30a9843c3.zip
Version bump.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-libs/c-client')
-rw-r--r--net-libs/c-client/ChangeLog7
-rw-r--r--net-libs/c-client/Manifest4
-rw-r--r--net-libs/c-client/c-client-2004c.ebuild92
-rw-r--r--net-libs/c-client/files/digest-c-client-2004c1
4 files changed, 102 insertions, 2 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index 8cd2ef14a2d1..5bd839a324bd 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/c-client
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.23 2005/03/31 02:25:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.24 2005/03/31 02:39:01 robbat2 Exp $
+
+*c-client-2004c (30 Mar 2005)
+
+ 30 Mar 2005; Robin H. Johnson <robbat2@gentoo.org> +c-client-2004c.ebuild:
+ Version bump.
30 Mar 2005; Robin H. Johnson <robbat2@gentoo.org>
c-client-2004a-r1.ebuild:
diff --git a/net-libs/c-client/Manifest b/net-libs/c-client/Manifest
index 4f270323aa93..775223f33340 100644
--- a/net-libs/c-client/Manifest
+++ b/net-libs/c-client/Manifest
@@ -1,10 +1,11 @@
MD5 e7bce4b8478b1128e86efb8bf43a7d08 c-client-2002e-r2.ebuild 2039
MD5 ecdbce3ee2598f6cf9d5f037333c9766 c-client-2004a.ebuild 2183
MD5 81f0f9656a107854fa3ddf25217525a6 c-client-2002e-r1.ebuild 1974
+MD5 6d40d56dec0a2c40e801393e6511e83b c-client-2004c.ebuild 2534
MD5 5fb5acd5c2e0b78dbaca4aa75cb36b74 c-client-2002e.ebuild 1893
MD5 47ac744573c05e8e5c5dc6b471bde3fa c-client-2002d-r1.ebuild 1869
MD5 82bbcf5790294052fe4819b7cc3fd2d3 c-client-2004a-r1.ebuild 2599
-MD5 0fd1d3d3901bf374ac08cbf74471ba01 ChangeLog 3185
+MD5 f6d1ed6e8d34315d458fbe234f214ea7 ChangeLog 3310
MD5 6b964abdc013cf2bb64040e8e33215ae metadata.xml 242
MD5 cc926ec2e710759c314acd92cd84b770 c-client-2002d.ebuild 1853
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-c-client-2002d-r1 62
@@ -14,5 +15,6 @@ MD5 86da98c03bc68723a437d2cf135b0775 files/digest-c-client-2004a-r1 62
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-c-client-2002d 62
MD5 27b9eec6a66d66ef07109f82da8f10ce files/digest-c-client-2002e 62
MD5 86da98c03bc68723a437d2cf135b0775 files/digest-c-client-2004a 62
+MD5 464e6baf7e9bdb0bebb80f0810515962 files/digest-c-client-2004c 63
MD5 cde23dc2375a8c33998202c8f0c9ae0e files/c-client-2004a-amd64-so-fix.patch 675
MD5 c8cf618ac210e06a1641871b30550e8f files/2002d-Makefile.patch 2174
diff --git a/net-libs/c-client/c-client-2004c.ebuild b/net-libs/c-client/c-client-2004c.ebuild
new file mode 100644
index 000000000000..6d888f391c00
--- /dev/null
+++ b/net-libs/c-client/c-client-2004c.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004c.ebuild,v 1.1 2005/03/31 02:39:01 robbat2 Exp $
+
+inherit flag-o-matic eutils libtool
+
+MY_PN=imap
+MY_P="${MY_PN}-${PV}1"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW IMAP c-client library"
+HOMEPAGE="http://www.washington.edu/imap/"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64 ~mips"
+IUSE="ssl pam"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ !virtual/imap-c-client"
+DEPEND="${RDEPEND}
+ pam? ( >=sys-libs/pam-0.72 )"
+PROVIDE="virtual/imap-c-client"
+
+src_unpack() {
+ unpack ${A}
+
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ # lots of things need -fPIC, including various platforms, and this library
+ # generally should be built with it anyway.
+ append-flags -fPIC
+
+ cd ${S}
+
+ # Modifications so we can build it optimally and correctly
+ sed \
+ -e "s:BASECFLAGS=\".*\":BASECFLAGS=:g" \
+ -e 's:SSLDIR=/usr/local/ssl:SSLDIR=/usr:g' \
+ -e 's:SSLCERTS=$(SSLDIR)/certs:SSLCERTS=/etc/ssl/certs:g' \
+ -i src/osdep/unix/Makefile || die "Makefile sed fixing failed"
+
+ # Apply a patch to only build the stuff we need for c-client
+ epatch ${FILESDIR}/2002d-Makefile.patch || die "epatch failed"
+
+ # Apply patch to add the compilation of a .so for PHP
+ # This was previously conditional, but is more widely useful.
+ epatch ${FILESDIR}/${PN}-2004a-amd64-so-fix.patch
+
+ # Remove the pesky checks about SSL stuff
+ sed -e '/read.*exit/d' -i Makefile
+ elibtoolize
+ uclibctoolize
+}
+
+src_compile() {
+ local ssltype target
+ use ssl && ssltype="unix" || ssltype="none"
+ use pam && target=lnp || target=lnx
+ # no parallel builds supported!
+ make $target SSLTYPE=${ssltype} EXTRACFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ into /usr
+
+ # Library binary
+ dolib.a c-client/c-client.a
+ dosym /usr/$(get_libdir)/c-client.a /usr/$(get_libdir)/libc-client.a
+
+ # Now the shared library
+ dolib.so c-client/libc-client.so.1.0.0
+ # these are created by ldconfig!
+ #cd ${D}/usr/$(get_libdir)
+ #ln -s libc-client.so.1.0.0 libc-client.so.1
+ #ln -s libc-client.so.1.0.0 libc-client.so
+
+ # Headers
+ insinto /usr/include/imap
+ doins c-client/*.h
+ doins c-client/linkage.c
+ #exclude these dupes (can't do it before now due to symlink hell)
+ rm ${D}/usr/include/imap/os_*.h
+
+ # Docs
+ dodoc README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+}
diff --git a/net-libs/c-client/files/digest-c-client-2004c b/net-libs/c-client/files/digest-c-client-2004c
new file mode 100644
index 000000000000..3e0d89c32ffc
--- /dev/null
+++ b/net-libs/c-client/files/digest-c-client-2004c
@@ -0,0 +1 @@
+MD5 f0a1a2abfa4b1ed8074ce023724416f3 imap-2004c1.tar.Z 2227092