summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-06-28 17:24:23 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-06-28 17:24:23 +0000
commit46a53048ac8f09636534d5bc420b8621549f4f80 (patch)
tree29de3092e00595a3c57305e08f20c7a055ed82d9 /net-libs
parentVersion bump. (diff)
downloadhistorical-46a53048ac8f09636534d5bc420b8621549f4f80.tar.gz
historical-46a53048ac8f09636534d5bc420b8621549f4f80.tar.bz2
historical-46a53048ac8f09636534d5bc420b8621549f4f80.zip
alpha needs -fPIC
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/c-client/ChangeLog5
-rw-r--r--net-libs/c-client/Manifest6
-rw-r--r--net-libs/c-client/c-client-2002d.ebuild7
3 files changed, 13 insertions, 5 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index a0a9fc39bfd1..54cc76d54292 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/c-client
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.2 2003/06/21 11:50:03 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.3 2003/06/28 17:24:15 taviso Exp $
+
+ 28 Jun 2003; Tavis Ormandy <taviso@gentoo.org> c-client-2002d.ebuild:
+ alpha needs -fPIC
*c-client-2002d (07 Jun 2003)
diff --git a/net-libs/c-client/Manifest b/net-libs/c-client/Manifest
index 2fd79f04294e..2b90069d0050 100644
--- a/net-libs/c-client/Manifest
+++ b/net-libs/c-client/Manifest
@@ -1,4 +1,4 @@
-MD5 315261c3fa434730e0c6533e0705a3cd ChangeLog 657
-MD5 907ce9c2dddc9a8530b6ba8f519ccb3e c-client-2002d.ebuild 1820
-MD5 c8cf618ac210e06a1641871b30550e8f files/2002d-Makefile.patch 2174
+MD5 b2668baafed2a08a20574404e2c6b322 ChangeLog 750
+MD5 0948178b065613ea007f25be6704330f c-client-2002d.ebuild 1899
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-c-client-2002d 62
+MD5 c8cf618ac210e06a1641871b30550e8f files/2002d-Makefile.patch 2174
diff --git a/net-libs/c-client/c-client-2002d.ebuild b/net-libs/c-client/c-client-2002d.ebuild
index 7d94a8752d97..a3806b58263c 100644
--- a/net-libs/c-client/c-client-2002d.ebuild
+++ b/net-libs/c-client/c-client-2002d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2002d.ebuild,v 1.2 2003/06/21 11:50:04 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2002d.ebuild,v 1.3 2003/06/28 17:24:15 taviso Exp $
MY_PN=imap
MY_P=${MY_PN}-${PV}
@@ -21,12 +21,17 @@ RDEPEND="ssl? ( dev-libs/openssl )
DEPEND="${RDEPEND}
>=sys-libs/pam-0.72"
+inherit flag-o-matic
+
src_unpack() {
unpack ${A}
# Tarball packed with bad file perms
chmod -R ug+w ${S}
+ # alpha needs -fPIC
+ use alpha && append-flags -fPIC
+
# Modifications so we can build it optimially and correctly
cd ${S}/src/osdep/unix/
cp Makefile Makefile.orig