summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-04-25 13:26:45 +0000
committerMarinus Schraal <foser@gentoo.org>2003-04-25 13:26:45 +0000
commit5f15efdbcd6a2fc658a807e1e1b673bf0894da13 (patch)
treeab656d21cdaf54c08f8f2ea83763304b18bce16e /net-mail/balsa
parenttouchups (diff)
downloadhistorical-5f15efdbcd6a2fc658a807e1e1b673bf0894da13.tar.gz
historical-5f15efdbcd6a2fc658a807e1e1b673bf0894da13.tar.bz2
historical-5f15efdbcd6a2fc658a807e1e1b673bf0894da13.zip
New versions and bugfixes
Diffstat (limited to 'net-mail/balsa')
-rw-r--r--net-mail/balsa/ChangeLog14
-rw-r--r--net-mail/balsa/balsa-1.4.3.ebuild63
-rw-r--r--net-mail/balsa/balsa-2.0.10.ebuild64
-rw-r--r--net-mail/balsa/balsa-2.0.9-r1.ebuild6
-rw-r--r--net-mail/balsa/files/digest-balsa-1.4.31
-rw-r--r--net-mail/balsa/files/digest-balsa-2.0.101
6 files changed, 145 insertions, 4 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index da931847d904..75de333f7903 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-mail/balsa
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.34 2003/04/23 00:28:54 vladimir Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.35 2003/04/25 13:26:45 foser Exp $
+
+*balsa-2.0.10 (25 Apr 2003)
+
+ 25 Apr 2003; foser <foser@gentoo.org> balsa-2.0.10.ebuild :
+ New version (#18142)
+ Fix gtkhtml switch (#19880)
+ Make more use of gnome2 eclass, set SLOT to 0
+
+*balsa-1.4.3 (25 Apr 2003) <foser@gentoo.org> balsa-1.4.3.ebuild :
+
+ 25 Apr 2003; foser <foser@gentoo.org> balsa-1.4.3.ebuild :
+ New version (#18142), set SLOT to 0, balsa isn't slotted
*balsa-2.0.9-r1 (08 Mar 2003)
diff --git a/net-mail/balsa/balsa-1.4.3.ebuild b/net-mail/balsa/balsa-1.4.3.ebuild
new file mode 100644
index 000000000000..6a06df995a64
--- /dev/null
+++ b/net-mail/balsa/balsa-1.4.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-1.4.3.ebuild,v 1.1 2003/04/25 13:26:45 foser Exp $
+
+IUSE="ssl nls cups gtkhtml spell perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Balsa: email client for GNOME"
+SRC_URI="http://www.theochem.kth.se/~pawsa/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.balsa.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=media-libs/imlib-1.9.10-r1
+ >=gnome-base/gnome-libs-1.4.1.4
+ >=gnome-base/ORBit-0.5.10-r1
+ >=media-libs/gdk-pixbuf-0.13.0
+ >=net-libs/libesmtp-0.8.11
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ cups? ( >=gnome-base/gnome-print-0.30 )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ spell? ( virtual/aspell-dict )
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Patch to use the new aspell instead of the old, crusty pspell modules
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.4.0-gentoo.diff
+}
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use gtkhtml && myconf="${myconf} --enable-gtkhtml"
+ use perl && myconf="${myconf} --enable-pcre"
+ use spell && myconf="${myconf} --with-aspell=yes"
+
+ myconf="${myconf} --with-mailpath=/var/mail --enable-threads"
+
+ autoconf || die
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ local myinst
+ myinst="gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share"
+
+ einstall ${myinst} || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/net-mail/balsa/balsa-2.0.10.ebuild b/net-mail/balsa/balsa-2.0.10.ebuild
new file mode 100644
index 000000000000..27bb431bc5e8
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.10.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.10.ebuild,v 1.1 2003/04/25 13:26:45 foser Exp $
+
+inherit gnome2 eutils
+
+IUSE="ssl gtkhtml perl ldap"
+DESCRIPTION="Email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+RDEPEND="net-mail/mailbase
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=net-libs/libesmtp-0.8.11
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeprint-2.1.4
+ >=gnome-base/libgnomeprintui-2.1.4
+ virtual/aspell-dict
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( >=gnome-extra/libgtkhtml-2 )
+ ldap? ( net-nds/openldap )"
+
+DEPEND="dev-util/pkgconfig
+ sys-devel/gettext
+ >=app-text/scrollkeeper-0.1.4
+ ${RDEPEND}"
+
+src_compile() {
+ local myconf
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+ use gtkhtml \
+ && myconf="${myconf} --enable-gtkhtml" \
+ || myconf="${myconf} --disable-gtkhtml"
+ use perl \
+ && myconf="${myconf} --enable-pcre" \
+ || myconf="${myconf} --disable-pcre"
+ use ldap \
+ && myconf="${myconf} --enable-ldap" \
+ || myconf="${myconf} --disable-ldap"
+
+ libmutt/configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ # threads diabled because of 17079
+ #myconf="${myconf} --enable-threads"
+ myconf="${myconf} --disable-threads"
+
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+DOCS="AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO docs/*"
diff --git a/net-mail/balsa/balsa-2.0.9-r1.ebuild b/net-mail/balsa/balsa-2.0.9-r1.ebuild
index d7632db46d7b..fbdfe01aefef 100644
--- a/net-mail/balsa/balsa-2.0.9-r1.ebuild
+++ b/net-mail/balsa/balsa-2.0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.9-r1.ebuild,v 1.2 2003/04/23 00:28:54 vladimir Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.9-r1.ebuild,v 1.3 2003/04/25 13:26:45 foser Exp $
inherit gnome2 eutils
@@ -39,8 +39,8 @@ src_compile() {
&& myconf="${myconf} --with-ssl" \
|| myconf="${myconf} --without-ssl"
use gtkhtml \
- && myconf="${myconf} --with-gtkhtml" \
- || myconf="${myconf} --without-gtkhtml"
+ && myconf="${myconf} --enable-gtkhtml" \
+ || myconf="${myconf} --disable-gtkhtml"
use perl \
&& myconf="${myconf} --enable-pcre" \
|| myconf="${myconf} --disable-pcre"
diff --git a/net-mail/balsa/files/digest-balsa-1.4.3 b/net-mail/balsa/files/digest-balsa-1.4.3
new file mode 100644
index 000000000000..ce117b498676
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-1.4.3
@@ -0,0 +1 @@
+MD5 26ac08c059d2aaa73bd76d21150a6d24 balsa-1.4.3.tar.bz2 2385240
diff --git a/net-mail/balsa/files/digest-balsa-2.0.10 b/net-mail/balsa/files/digest-balsa-2.0.10
new file mode 100644
index 000000000000..fa5256481918
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-2.0.10
@@ -0,0 +1 @@
+MD5 c4e5325df8b9ddbf62778094568a6814 balsa-2.0.10.tar.bz2 2574787