summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-09 00:18:32 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-09 00:18:32 +0000
commitb70926019de33dc0b96e460a205391eb4ef4da41 (patch)
tree3340831cf78580cf8f22e7094f01c6602cbfd1fa /net-mail/ezmlm-idx-pgsql
parentadded ppc keyword (diff)
downloadhistorical-b70926019de33dc0b96e460a205391eb4ef4da41.tar.gz
historical-b70926019de33dc0b96e460a205391eb4ef4da41.tar.bz2
historical-b70926019de33dc0b96e460a205391eb4ef4da41.zip
syncing with other ezmlm-idx*
Diffstat (limited to 'net-mail/ezmlm-idx-pgsql')
-rw-r--r--net-mail/ezmlm-idx-pgsql/ChangeLog9
-rw-r--r--net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40-r2.ebuild80
-rw-r--r--net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.40-r27
3 files changed, 95 insertions, 1 deletions
diff --git a/net-mail/ezmlm-idx-pgsql/ChangeLog b/net-mail/ezmlm-idx-pgsql/ChangeLog
index 4c0bbbbd6b0a..ff5681c30f73 100644
--- a/net-mail/ezmlm-idx-pgsql/ChangeLog
+++ b/net-mail/ezmlm-idx-pgsql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/ezmlm-idx-pgsql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx-pgsql/ChangeLog,v 1.2 2003/02/12 08:10:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx-pgsql/ChangeLog,v 1.3 2003/04/09 00:18:32 liquidx Exp $
+
+*ezmlm-idx-pgsql-0.40-r2 (09 Apr 2003)
+
+ 09 Apr 2003; Alastair Tse <liquidx@gentoo.org>
+ ezmlm-idx-pgsql-0.40-r2.ebuild, files/ezmlm-0.53-errno.patch,
+ files/from-header.patch, files/get_header.c, files/get_header.h:
+ syncing with ezmlm-idx*
*ezmlm-idx-pgsql-0.40 (16 Oct 2002)
diff --git a/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40-r2.ebuild b/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40-r2.ebuild
new file mode 100644
index 000000000000..89ae188fb31d
--- /dev/null
+++ b/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40-r2.ebuild,v 1.1 2003/04/09 00:18:32 liquidx Exp $
+
+# NOTE: ezmlm-idx, ezmlm-idx-mysql and ezmlm-idx-pgsql all supported by this single ebuild
+# (Please keep them in sync)
+
+inherit eutils
+
+PB=ezmlm-idx
+EZMLM_P=ezmlm-0.53
+
+S2=${WORKDIR}/${PB}-${PV}
+S=${WORKDIR}/${EZMLM_P}
+DESCRIPTION="Simple yet powerful mailing list manager for qmail."
+SRC_URI="http://gd.tuwien.ac.at/infosys/mail/qmail/ezmlm-patches/${PB}-${PV}.tar.gz http://cr.yp.to/software/${EZMLM_P}.tar.gz"
+HOMEPAGE="http://www.ezmlm.org"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+DEPEND="sys-apps/grep sys-apps/groff"
+RDEPEND="net-mail/qmail"
+PROVIDE="net-mail/ezmlm"
+
+if [ "$PN" = "${PB}-pgsql" ]
+then
+ DEPEND="$DEPEND dev-db/postgresql"
+ RDEPEND="$RDEPEND dev-db/postgresql"
+elif [ "$PN" = "${PB}-mysql" ]
+then
+ DEPEND="$DEPEND dev-db/mysql"
+ RDEPEND="$RDEPEND dev-db/mysql"
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd ${S2}
+ mv ${S2}/* ${S} || die
+
+ cd ${S}
+ patch < idx.patch || die
+ #remove cat-man pages
+ cp MAN MAN.orig
+ cat MAN.orig | grep -v cat > MAN
+ echo "/usr/bin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ #tweak the install to go to ${D}
+ cp Makefile Makefile.orig
+ sed -e "s:/install.*conf-bin\`\":/install ${D}usr/bin:" \
+ -e "s:/install.*conf-man\`\":/install ${D}usr/share/man:" Makefile.orig > Makefile
+ #apply patch from Ed Korthof (edk@collab.net) that allows ezmlm-issub and ezmlm-gate
+ #to check against the From: header as well as qmail's SENDER variable, which is set
+ #from the envelope sender and often reflects the local MTA rather than the user's
+ #"official" email address... enable this option by using "-f" with ezmlm-issub and/or
+ #ezmlm-gate.
+ cp ${FILESDIR}/get_header.[ch] . || die
+ patch < ${FILESDIR}/from-header.patch || die
+ echo ">>> Successfully applied Ed Korthof's From: header patch."
+ epatch ${FILESDIR}/${EZMLM_P}-errno.patch
+}
+
+src_compile() {
+ cd ${S}
+ if [ "$PN" = "${PB}-pgsql" ]
+ then
+ make pgsql
+ elif [ "$PN" = "${PB}-mysql" ]
+ then
+ make mysql
+ fi
+ emake || die
+}
+
+src_install () {
+ install -d ${D}/usr/bin ${D}/usr/share/man ${D}/etc/ezmlm
+ make setup || die
+ mv ${D}/usr/bin/ez*rc ${D}/etc/ezmlm
+}
diff --git a/net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.40-r2 b/net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.40-r2
new file mode 100644
index 000000000000..1bfb348b572a
--- /dev/null
+++ b/net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.40-r2
@@ -0,0 +1,7 @@
+MD5 31baef31f2ce0c9343530c3467220a60 /files/from-header.patch 6165
+MD5 b82b4c09c356dc91fcbe907a24326b52 /files/ezmlm-0.53-errno.patch 270
+MD5 add751ca5856300f8e2a349fb944257c /files/get_header.c 3486
+MD5 faac5e3fb54753c4a9f6475bb1a5b20a /files/get_header.h 101
+MD5 e7ebd30b3d6f45544e85f82d49f386f6 /ezmlm-idx-pgsql-0.40-r2.ebuild 2368
+MD5 c6137114060cff19301a956e73d46fc0 ezmlm-idx-0.40.tar.gz 553974
+MD5 108c632caaa8cdbfd3041e6c449191b2 ezmlm-0.53.tar.gz 62693