summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-01-25 21:10:17 +0000
committerThilo Bangert <bangert@gentoo.org>2008-01-25 21:10:17 +0000
commitd192ae64c6b8c8f0fd9177723ca5aecb6c677a6a (patch)
tree750b162668144b5085257fedb8fdc5a1bb72f9a1 /net-mail/mailfront/mailfront-0.98.ebuild
parentadd a few more to the apache-2 mask (diff)
downloadhistorical-d192ae64c6b8c8f0fd9177723ca5aecb6c677a6a.tar.gz
historical-d192ae64c6b8c8f0fd9177723ca5aecb6c677a6a.tar.bz2
historical-d192ae64c6b8c8f0fd9177723ca5aecb6c677a6a.zip
fix quoting, honor ROOT, use emake, einfo -> elog
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'net-mail/mailfront/mailfront-0.98.ebuild')
-rw-r--r--net-mail/mailfront/mailfront-0.98.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-mail/mailfront/mailfront-0.98.ebuild b/net-mail/mailfront/mailfront-0.98.ebuild
index 39201c56ac15..abda0b580081 100644
--- a/net-mail/mailfront/mailfront-0.98.ebuild
+++ b/net-mail/mailfront/mailfront-0.98.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.98.ebuild,v 1.4 2007/02/22 15:56:41 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.98.ebuild,v 1.5 2008/01/25 21:10:17 bangert Exp $
inherit toolchain-funcs
@@ -32,7 +32,7 @@ src_compile() {
echo "${D}/var/qmail/bin" > conf-bin
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
echo "$(tc-getCC) -s" > conf-ld
- make || die
+ emake || die
}
src_install() {
@@ -40,18 +40,18 @@ src_install() {
emake install || die
exeinto /var/qmail/supervise/qmail-smtpd
- newexe ${FILESDIR}/run-smtpfront run.mailfront
+ newexe "${FILESDIR}"/run-smtpfront run.mailfront
exeinto /var/qmail/supervise/qmail-pop3d
- newexe ${FILESDIR}/run-pop3front run.mailfront
+ newexe "${FILESDIR}"/run-pop3front run.mailfront
- dodoc ANNOUNCEMENT COPYING ChangeLog NEWS README VERSION
+ dodoc ANNOUNCEMENT ChangeLog NEWS README VERSION
dohtml *.html
}
pkg_config() {
- cd /var/qmail/supervise/qmail-smtpd/
+ cd "${ROOT}"/var/qmail/supervise/qmail-smtpd/
cp run run.qmail-smtpd.`date +%Y%m%d%H%M%S` && cp run.mailfront run
- cd /var/qmail/supervise/qmail-pop3d/
+ cd "${ROOT}"/var/qmail/supervise/qmail-pop3d/
cp run run.qmail-pop3d.`date +%Y%m%d%H%M%S` && cp run.mailfront run
}
@@ -59,7 +59,7 @@ pkg_postinst() {
echo
elog "Run"
elog "emerge --config =${CATEGORY}/${PF}"
- elgo "to update your run files (backups are created) in"
+ elog "to update your run files (backups are created) in"
elog " /var/qmail/supervise/qmail-pop3d and"
elog " /var/qmail/supervise/qmail-smtpd"
echo