summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-13 10:35:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-13 10:35:01 +0000
commit1241566c140d495cf6a01ff95c7e256e6f0f8878 (patch)
tree2e8a2bb6daf2e4f7d69aad681ca27bee161fec37 /net-mail/postfix
parentput .11 back in (diff)
downloadhistorical-1241566c140d495cf6a01ff95c7e256e6f0f8878.tar.gz
historical-1241566c140d495cf6a01ff95c7e256e6f0f8878.tar.bz2
historical-1241566c140d495cf6a01ff95c7e256e6f0f8878.zip
put .11 back in
Diffstat (limited to 'net-mail/postfix')
-rw-r--r--net-mail/postfix/Manifest2
-rw-r--r--net-mail/postfix/files/digest-postfix-2.0.114
-rw-r--r--net-mail/postfix/postfix-2.0.11.ebuild202
3 files changed, 207 insertions, 1 deletions
diff --git a/net-mail/postfix/Manifest b/net-mail/postfix/Manifest
index 275c49fe264b..4a027eb711d0 100644
--- a/net-mail/postfix/Manifest
+++ b/net-mail/postfix/Manifest
@@ -2,7 +2,7 @@ MD5 e6a3d41964c3f27d3fc79b241df1b13d postfix-2.0.10-r1.ebuild 5394
MD5 ead334460917ae4879673b31d59f46e8 postfix-2.0.9.ebuild 5471
MD5 76726846989c0b6a5fc643d06b804e45 postfix-1.1.11.20020917-r1.ebuild 4945
MD5 f3e72049a5b5ec1fdd817597590c8592 ChangeLog 14422
-MD5 a2784ba26e4e136e4ac75c895b9af0fa postfix-2.0.11.ebuild 5398
+MD5 d1fa505f59e6346338242d8cf01b6276 postfix-2.0.11.ebuild 5391
MD5 c79b19f95cb38b8802966d7efb54bc60 postfix-1.1.11.20020917.ebuild 4924
MD5 a3eadfcfa0bf6f88ccff41e2d065745b files/postfix-2.0.8_patch.patch 552
MD5 6775371821db3139dd2470c794a1e01f files/digest-postfix-1.1.11.20020917-r1 166
diff --git a/net-mail/postfix/files/digest-postfix-2.0.11 b/net-mail/postfix/files/digest-postfix-2.0.11
new file mode 100644
index 000000000000..d7c0b57edce0
--- /dev/null
+++ b/net-mail/postfix/files/digest-postfix-2.0.11
@@ -0,0 +1,4 @@
+MD5 a6bb9809a29c7e00a576491e1b57b79a postfix-2.0.11.tar.gz 1349765
+MD5 31f1e830882025957f735e5e9b7dd2fd pfixtls-0.8.13-2.0.10-0.9.7b.tar.gz 226122
+MD5 f338521aaccd7a15deaf606c1bab4d16 ipv6-1.14-pf-2.0.11.patch.gz 36029
+MD5 c33700d22bd1bc612413a48899bd7896 tls+ipv6-1.14-pf-2.0.11.patch.gz 99562
diff --git a/net-mail/postfix/postfix-2.0.11.ebuild b/net-mail/postfix/postfix-2.0.11.ebuild
new file mode 100644
index 000000000000..e245d5fcb59d
--- /dev/null
+++ b/net-mail/postfix/postfix-2.0.11.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.11.ebuild,v 1.3 2003/06/13 10:34:58 seemant Exp $
+
+inherit eutils
+
+TLS_P="pfixtls-0.8.13-2.0.10-0.9.7b"
+IPV6="1.14"
+IPV6_P="ipv6-${IPV6}-pf-${PV}"
+IPV6_TLS_P="tls+${IPV6_P}"
+IUSE="ssl mysql sasl ldap ipv6 maildir mbox"
+DESCRIPTION="A fast and secure drop-in replacement for sendmail"
+HOMEPAGE="http://www.postfix.org"
+SRC_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/official/${P}.tar.gz
+ ssl? ( ftp://ftp.aet.tu-cottbus.de/pub/postfix_tls/${TLS_P}.tar.gz )
+ ipv6? ( ftp://ftp.stack.nl/pub/postfix/tls+ipv6/${IPV6}/${IPV6_P}.patch.gz )
+ ipv6? ( ftp://ftp.stack.nl/pub/postfix/tls+ipv6/${IPV6}/${IPV6_TLS_P}.patch.gz )"
+LICENSE="IPL-1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+PROVIDE="virtual/mta
+ virtual/mda"
+DEPEND=">=sys-libs/db-3.2
+ >=sys-apps/sed-4
+ >=dev-libs/libpcre-3.4
+ ldap? ( >=net-nds/openldap-1.2 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00
+ !virtual/mta"
+
+is_postfix_installed() {
+ if [ -d /etc/postfix ] ; then
+ return 1
+ fi
+
+ return 0
+}
+
+pkg_setup() {
+ if ! grep -q ^postdrop: /etc/group ; then
+ groupadd postdrop || die "problem adding group postdrop"
+ fi
+
+ if ! grep -q ^mail:.*postfix /etc/group ; then
+ usermod -G mail postfix || die "problem adding user postfix to group mail"
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ if [ "`use ssl`" ]; then
+ if [ "`use ipv6`" ]; then
+ epatch ${DISTDIR}/${IPV6_TLS_P}.patch.gz || die "ipv6/tls patch died"
+ else
+ unpack ${TLS_P}.tar.gz
+ epatch ${WORKDIR}/${P}/${TLS_P}/pfixtls.diff || die "tls patch died"
+ fi
+ CCARGS="${CCARGS} -DHAS_SSL"
+ AUXLIBS="${AUXLIBS} -lssl -lcrypto"
+ elif [ "`use ipv6`" ]; then
+ epatch ${DISTDIR}/${IPV6_P}.patch.gz || die "ipv6 patch died"
+ fi
+ cd ${S}/conf
+ sed -i -e "s:/usr/libexec/postfix:/usr/lib/postfix:" main.cf
+
+ if [ "`use sasl`" ] ; then
+ # sasl 2
+ if [ -f /usr/include/sasl/sasl.h ]; then
+ AUXLIBS="${AUXLIBS} -lsasl2"
+ CCARGS="${CCARGS} -I/usr/include/sasl -DUSE_SASL_AUTH"
+ # sasl 1
+ elif [ -f /usr/include/sasl.h ]; then
+ AUXLIBS="${AUXLIBS} -lsasl"
+ CCARGS="${CCARGS} -DUSE_SASL_AUTH"
+ fi
+ fi
+
+ cd ${S}/src/global
+ sed -i -e "s:/usr/libexec/postfix:/usr/lib/postfix:" mail_params.h
+
+ if [ "`use mysql`" ] ; then
+ CCARGS="${CCARGS} -DHAS_MYSQL -I/usr/include/mysql"
+ AUXLIBS="${AUXLIBS} -lmysqlclient -lm -lz"
+ fi
+
+ if [ "`use ldap`" ] ; then
+ CCARGS="${CCARGS} -DHAS_LDAP"
+ AUXLIBS="${AUXLIBS} -lldap -llber"
+ fi
+
+ if [ "`use pam`" ] ; then
+ AUXLIBS="${AUXLIBS} -lpam"
+ fi
+
+ CCARGS="${CCARGS} -DHAS_PCRE"
+ AUXLIBS="${AUXLIBS} -L/usr/lib -lpcre -ldl -lcrypt"
+
+ DEBUG=""
+
+ cd ${S}
+ make makefiles CC="${CC}" OPT="${CFLAGS}" DEBUG="${DEBUG}" \
+ CCARGS="${CCARGS}" AUXLIBS="${AUXLIBS}" \
+ || die "creating makefiles failed"
+
+ # Postfix do not get the FQDN if no hostname is configured
+ epatch ${FILESDIR}/${PN}-2.0.9-get-FQDN.patch
+}
+
+src_compile() {
+ #this is a bug fix for gcc-2.95.3-r5 (bug 16547)
+ export CC=gcc
+ emake || die "compile problem"
+}
+
+src_install () {
+ dodir /usr/bin /usr/sbin /usr/lib/postfix /etc/postfix/sample \
+ /var/spool/postfix/tmp
+ touch ${D}/var/spool/postfix/.keep
+
+ cd ${S}/bin
+ dosbin post* sendmail
+ chown root:postdrop ${D}/usr/sbin/{postdrop,postqueue}
+ chmod 2755 ${D}/usr/sbin/{postdrop,postqueue}
+
+ dosym /usr/sbin/sendmail /usr/bin/mailq
+ dosym /usr/sbin/sendmail /usr/bin/newaliases
+ dosym /usr/sbin/sendmail /usr/lib/sendmail
+
+ cd ${S}/libexec
+ exeinto /usr/lib/postfix
+ doexe *
+
+ cd ${S}/man
+ doman man*/*
+
+ cd ${S}
+ dodoc *README COMPATIBILITY HISTORY INSTALL LICENSE PORTING RELEASE_NOTES*
+ cd README_FILES
+ find . -type l |xargs rm
+ dodoc *
+
+ cd ${S}
+ dohtml html/*
+
+ cd ${S}/conf
+ insinto /etc/postfix/sample
+ doins access aliases canonical pcre_table regexp_table \
+ relocated transport virtual *.cf
+
+ exeinto /etc/postfix
+ doexe postfix-script post-install postfix-files
+
+ insinto /etc/postfix
+ doins ${S}/conf/{main,master}.cf ${FILESDIR}/saslpass
+ cd ${D}/etc/postfix
+ epatch ${FILESDIR}/postfix-2.0.0/main.cf.diff
+ sed -i -e "s|/usr/share/doc/POSTFIX|/usr/share/doc/${PF}|" main.cf
+ chmod 644 main.cf
+ rm -f main.cf~
+ fperms 600 /etc/postfix/saslpass
+
+ exeinto /etc/init.d ; doexe ${FILESDIR}/postfix
+ insinto /etc/pam.d ; newins ${FILESDIR}/smtp.pam smtp
+
+ if [ "`use sasl`" ] ; then
+ # sasl 2
+ if [ -f /usr/include/sasl/sasl.h ] ; then
+ insinto /usr/lib/sasl2
+ doins ${FILESDIR}/smtpd.conf
+ else
+ insinto /etc/sasl
+ doins ${FILESDIR}/smtpd.conf
+ fi
+ fi
+ cd ${D}/etc/postfix
+ if [ "`use maildir`" ]; then
+ sed -i -e "s:^#\(home_mailbox = \)Maildir/:\1.maildir/:" main.cf
+ elif [ "`use mbox`" ]; then
+ sed -i -e "s:^#\(mail_spool_directory = /var/spool/mail\):\1:" main.cf
+ fi
+
+ #install an rmail for UUCP, closing bug #19127
+ cd ${S}/auxiliary/rmail
+ dobin rmail
+}
+
+pkg_postinst() {
+ install -d -m 0755 ${ROOT}/var/spool/postfix
+
+ ewarn "If you upgraded from <postfix-2, you must revisit your configuration files."
+ ewarn "See /usr/share/doc/${PF}/RELEASE_NOTES for a list of changes."
+
+ if [ ! -e /etc/mail/aliases.db ] ; then
+ echo
+ ewarn "You must edit /etc/mail/aliases to suit your needs and then run"
+ ewarn "/usr/bin/newaliases. Postfix will not work correctly without it."
+ fi
+}