summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-02-14 19:55:55 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-02-14 19:55:55 +0000
commit483c82913249f5effe7363f51ecd801bb879204a (patch)
tree0928ea1fdd4b54aa1b996338aa5d6b01edf152a3 /net-mail
parentFix README installation for bug #258990. (diff)
downloadhistorical-483c82913249f5effe7363f51ecd801bb879204a.tar.gz
historical-483c82913249f5effe7363f51ecd801bb879204a.tar.bz2
historical-483c82913249f5effe7363f51ecd801bb879204a.zip
initial ebuild
Package-Manager: portage-2.2_rc23/cvs/Linux i686
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/vchkuser/ChangeLog10
-rw-r--r--net-mail/vchkuser/Manifest4
-rw-r--r--net-mail/vchkuser/metadata.xml12
-rw-r--r--net-mail/vchkuser/vchkuser-0.3.1.ebuild37
4 files changed, 63 insertions, 0 deletions
diff --git a/net-mail/vchkuser/ChangeLog b/net-mail/vchkuser/ChangeLog
new file mode 100644
index 000000000000..990443c9ed22
--- /dev/null
+++ b/net-mail/vchkuser/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-mail/vchkuser
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vchkuser/ChangeLog,v 1.1 2009/02/14 19:55:55 hollow Exp $
+
+*vchkuser-0.3.1 (14 Feb 2009)
+
+ 14 Feb 2009; Benedikt Böhm <hollow@gentoo.org> +metadata.xml,
+ +vchkuser-0.3.1.ebuild:
+ initial ebuild
+
diff --git a/net-mail/vchkuser/Manifest b/net-mail/vchkuser/Manifest
new file mode 100644
index 000000000000..b69c48e9548c
--- /dev/null
+++ b/net-mail/vchkuser/Manifest
@@ -0,0 +1,4 @@
+DIST vchkuser-0.3.1.tar.bz2 5929 RMD160 2cc385e9c7f6544fa8ae43954f2e5f99d9021a83 SHA1 19add10eb2b75b007463ec4f38acb881b004082a SHA256 692048f2574c259dbf204cddc2ea41ff76c7376270f4af1e0940bfcb146c7960
+EBUILD vchkuser-0.3.1.ebuild 897 RMD160 7119a51fa233e0750755315912154097f254721c SHA1 98aa854562424b4fb629688726b2c957a1b1dd26 SHA256 d0b9c9e32a37c9a0526e27b0d34c2a8db49ec97781a4c57331cc176a84896380
+MISC ChangeLog 347 RMD160 7cbfb4e5cf6c9235a071821b252f488add782bf4 SHA1 2a03cb3a3b3f617bf22ccb06250603e095d21dab SHA256 0d93b0a38e12d56ae1a765e246908eb8360d83ef6f168f04f646cc5ce10fcb90
+MISC metadata.xml 329 RMD160 6a8bce80c677d71bfdbc1789faedaa35ea0e24be SHA1 e1a0dc8036a7c0251e8a1d32c07f16087a15948d SHA256 07ba05785d56889ce9257e692b3942ca2da5530e63a897e9a3f138ea64a46ef0
diff --git a/net-mail/vchkuser/metadata.xml b/net-mail/vchkuser/metadata.xml
new file mode 100644
index 000000000000..f0c241515b61
--- /dev/null
+++ b/net-mail/vchkuser/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qmail</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Böhm</name>
+ </maintainer>
+ <use>
+ <flag name='debug'>Enables debug messages to syslog</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-mail/vchkuser/vchkuser-0.3.1.ebuild b/net-mail/vchkuser/vchkuser-0.3.1.ebuild
new file mode 100644
index 000000000000..0dbbf1202c48
--- /dev/null
+++ b/net-mail/vchkuser/vchkuser-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vchkuser/vchkuser-0.3.1.ebuild,v 1.1 2009/02/14 19:55:55 hollow Exp $
+
+EAPI="2"
+
+inherit autotools qmail
+
+DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
+HOMEPAGE="http://bb.xnull.de/projects/vchkuser/"
+SRC_URI="http://bb.xnull.de/projects/vchkuser/dist/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="net-mail/vpopmail
+ || ( mail-mta/netqmail[qmail-spp] mail-mta/qmail-ldap[qmail-spp] )"
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-vpopuser=vpopmail \
+ --with-qmailgroup=nofiles \
+ --with-vpopmaildir=/var/vpopmail \
+ --with-qmaildir=${QMAIL_HOME}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+}