summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-04 20:37:09 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-04 20:37:09 +0000
commitd3c81beeaa7f3fac8090c0bd122943f98e0f8575 (patch)
tree5e1b56152753d4b91e1016a7c23ed8ea4c7cf1e1 /net-mail
parentAdd libs for evo 0.15 (diff)
downloadhistorical-d3c81beeaa7f3fac8090c0bd122943f98e0f8575.tar.gz
historical-d3c81beeaa7f3fac8090c0bd122943f98e0f8575.tar.bz2
historical-d3c81beeaa7f3fac8090c0bd122943f98e0f8575.zip
updated to 0.15, will look at palm support for this one
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/evolution-0.15.ebuild76
-rw-r--r--net-mail/evolution/files/digest-evolution-0.152
2 files changed, 78 insertions, 0 deletions
diff --git a/net-mail/evolution/evolution-0.15.ebuild b/net-mail/evolution/evolution-0.15.ebuild
new file mode 100644
index 000000000000..53d9cbf31296
--- /dev/null
+++ b/net-mail/evolution/evolution-0.15.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <hallski@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-0.15.ebuild,v 1.1 2001/10/04 20:37:09 hallski Exp $
+
+DB3=db-3.1.17
+A="${P}.tar.gz ${DB3}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.ximian.com/pub/source/${PN}/${A}
+ ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+# Fixed bonobo-conf, gal, gtkhtml order as specified in Evolution README
+# (really needed?)
+DEPEND=">=gnome-libs/bonobo-conf-0.11
+ >=gnome-base/bonobo-1.0.8
+ >=gnome-base/gal-0.13
+ >=gnome-base/gconf-1.0.4
+ >=gnome-base/gtkhtml-0.14
+ >=gnome-base/oaf-0.6.6
+ >=gnome-base/ORBit-0.5.8
+ >=gnome-base/libglade-0.14
+ >=media-libs/gdk-pixbuf-0.9.0
+ >=gnome-base/libxml-1.8.15
+ >=gnome-base/gnome-vfs-1.0
+ >=gnome-base/gnome-print-0.25
+ >=gnome-base/scrollkeeper-0.2
+ >=dev-util/xml-i18n-tools-0.8.4
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ mozilla? ( net-www/mozilla )"
+
+src_compile() {
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+ make || die # make -j 4 doesn't work, use make
+ make prefix=${WORKDIR}/db3 install || die
+
+ cd ${S}
+
+ local myconf
+
+ MOZILLA=$MOZILLA_FIVE_HOME
+
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --enable-ssl"
+ else
+ myconf="$myconf --disable-ssl"
+ fi
+
+ if [ "`use mozilla`" ] ; then
+ myconf="$myconf --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nss-includes=${MOZILLA}/include \
+ --with-nspr-libs=${MOZILLA}"
+ fi
+
+ ./configure --prefix=/opt/gnome --host=${CHOST} \
+ --sysconfdir=/etc/opt/gnome \
+ --enable-file-locking=no \
+ --with-db3=${WORKDIR}/db3 \
+ --without-movemail \
+ --enable-nntp $myconf || die
+
+ make || die # emake didn't work.
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+
diff --git a/net-mail/evolution/files/digest-evolution-0.15 b/net-mail/evolution/files/digest-evolution-0.15
new file mode 100644
index 000000000000..12e0f7747008
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-0.15
@@ -0,0 +1,2 @@
+MD5 3297446afe4b4a4615b3ca130e1bd3af evolution-0.15.tar.gz
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz