summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-10 09:06:46 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-10 09:06:46 +0000
commita55128cde8f1aefa442ac3b5aa93845535709e8c (patch)
tree47045541478569b374765e78c2fa84369d6f447b /net-misc/autossh
parentAdded -r2 with utf-8 support, masked ~ (diff)
downloadhistorical-a55128cde8f1aefa442ac3b5aa93845535709e8c.tar.gz
historical-a55128cde8f1aefa442ac3b5aa93845535709e8c.tar.bz2
historical-a55128cde8f1aefa442ac3b5aa93845535709e8c.zip
Version bump
Diffstat (limited to 'net-misc/autossh')
-rw-r--r--net-misc/autossh/ChangeLog7
-rw-r--r--net-misc/autossh/autossh-1.2d.ebuild36
-rw-r--r--net-misc/autossh/files/autossh-1.2d-reuse.patch22
-rw-r--r--net-misc/autossh/files/digest-autossh-1.2d1
4 files changed, 65 insertions, 1 deletions
diff --git a/net-misc/autossh/ChangeLog b/net-misc/autossh/ChangeLog
index 3b5f63e3d9ba..e29a6ab3f116 100644
--- a/net-misc/autossh/ChangeLog
+++ b/net-misc/autossh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/autossh
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/ChangeLog,v 1.1 2003/02/13 10:19:02 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/ChangeLog,v 1.2 2003/03/10 09:06:46 aliz Exp $
+
+*autossh-1.2d (10 Mar 2003)
+
+ 10 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump. Ebuild contributed by Jedi/Sector One <gentoo@pureftpd.org> in #16560.
*autossh-1.2c (13 Feb 2003)
diff --git a/net-misc/autossh/autossh-1.2d.ebuild b/net-misc/autossh/autossh-1.2d.ebuild
new file mode 100644
index 000000000000..8f4551a5064e
--- /dev/null
+++ b/net-misc/autossh/autossh-1.2d.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.2d.ebuild,v 1.1 2003/03/10 09:06:46 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Automatically restart SSH sessions and tunnels"
+HOMEPAGE="http://www.harding.motd.ca/autossh/"
+LICENSE="BSD"
+KEYWORDS="~x86"
+SRC_URI="http://www.harding.motd.ca/autossh/${P}.tgz"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-apps/sed"
+RDEPEND="virtual/glibc
+ net-misc/openssh"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ patch -p0 -l < ${FILESDIR}/${P}-reuse.patch
+ mv Makefile.linux Makefile.linux.orig
+ sed "s/CFLAGS=/CFLAGS=${CFLAGS}/g" Makefile.linux.orig >Makefile.linux
+}
+
+src_compile() {
+ emake -f Makefile.linux || die "make failed"
+}
+
+src_install() {
+ dobin autossh
+ dodoc CHANGES README autossh.host rscreen
+ doman autossh.1
+}
+
diff --git a/net-misc/autossh/files/autossh-1.2d-reuse.patch b/net-misc/autossh/files/autossh-1.2d-reuse.patch
new file mode 100644
index 000000000000..202a788fece4
--- /dev/null
+++ b/net-misc/autossh/files/autossh-1.2d-reuse.patch
@@ -0,0 +1,22 @@
+diff -u autossh.c autossh.c-jedi
+--- autossh.c 2003-02-14 00:47:46.000000000 +0100
++++ autossh.c-jedi 2003-03-01 14:42:03.000000000 +0100
+@@ -955,6 +955,7 @@
+ {
+ int sock;
+ struct addrinfo *res;
++ int on = 1;
+
+ /*
+ * Unlike conn_remote, we don't need to cache the
+@@ -967,6 +968,10 @@
+ res->ai_protocol)) == -1)
+ xerrlog(LOG_ERR, "socket: %s", strerror(errno));
+
++ if (setsockopt(sock, SOL_SOCKET, SO_REUSEADDR,
++ (char *) &on, sizeof on) != 0) {
++ xerrlog(LOG_ERR, "socket: %s", strerror(errno));
++ }
+ if (bind(sock, (struct sockaddr *)res->ai_addr,
+ res->ai_addrlen) == -1)
+ xerrlog(LOG_ERR, "bind: %s", strerror(errno));
diff --git a/net-misc/autossh/files/digest-autossh-1.2d b/net-misc/autossh/files/digest-autossh-1.2d
new file mode 100644
index 000000000000..6dc0026bee9d
--- /dev/null
+++ b/net-misc/autossh/files/digest-autossh-1.2d
@@ -0,0 +1 @@
+MD5 6e73d325a8286ac3d8eddf63f2043d0d autossh-1.2d.tgz 15548