summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Lieber <klieber@gentoo.org>2003-11-05 19:52:50 +0000
committerKurt Lieber <klieber@gentoo.org>2003-11-05 19:52:50 +0000
commitb20a502d5b9b6f5d4e6a678b5f6d6ad50b697d83 (patch)
tree16467d3af227ed699b4bfca1080a46e166c359ad /net-misc/cfengine
parent2.1.0p1 ebuild (diff)
downloadhistorical-b20a502d5b9b6f5d4e6a678b5f6d6ad50b697d83.tar.gz
historical-b20a502d5b9b6f5d4e6a678b5f6d6ad50b697d83.tar.bz2
historical-b20a502d5b9b6f5d4e6a678b5f6d6ad50b697d83.zip
2.1.0p1 ebuild
Diffstat (limited to 'net-misc/cfengine')
-rw-r--r--net-misc/cfengine/Manifest2
-rw-r--r--net-misc/cfengine/cfengine-2.1.0_p1.ebuild63
-rw-r--r--net-misc/cfengine/files/digest-cfengine-2.1.0_p11
3 files changed, 65 insertions, 1 deletions
diff --git a/net-misc/cfengine/Manifest b/net-misc/cfengine/Manifest
index eb9795af5eaf..dadadf8ecda6 100644
--- a/net-misc/cfengine/Manifest
+++ b/net-misc/cfengine/Manifest
@@ -1,4 +1,4 @@
-MD5 c7ece845e5dae45bee17d9516e9028ce ChangeLog 3395
+MD5 4e9776e108f6d05e6e9c3f32a7771f9d ChangeLog 3523
MD5 a2be03b6731823dbd298d4f35758f9b6 cfengine-1.6.3.ebuild 723
MD5 e35c3445cb81576250f15893c893b290 cfengine-2.1.0_p1.ebuild 1570
MD5 e97f5f512d0ece4b0dd0100dc9f70d6c cfengine-2.0.6-r1.ebuild 991
diff --git a/net-misc/cfengine/cfengine-2.1.0_p1.ebuild b/net-misc/cfengine/cfengine-2.1.0_p1.ebuild
new file mode 100644
index 000000000000..4133635da2fe
--- /dev/null
+++ b/net-misc/cfengine/cfengine-2.1.0_p1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+PARCH=${P/_/}
+DESCRIPTION="An agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks"
+HOMEPAGE="http://www.iu.hio.no/cfengine/"
+SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${PARCH}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+
+DEPEND="virtual/glibc
+ >=sys-libs/db-3.2
+ >=dev-libs/openssl-0.9.6k"
+
+S="${WORKDIR}/${PARCH}"
+
+src_compile() {
+
+ # Enforce /var/cfengine for historical compatibility
+ econf \
+ --with-workdir=/var/cfengine \
+ --with-berkeleydb=/usr || die
+
+ # Fix Makefile to skip doc & inputs install to wrong locations
+ sed -i -e 's/\(SUBDIRS.*\) inputs doc/\1/' Makefile
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING DOCUMENTATION README TODO
+
+ # Manually install doc and inputs
+ doinfo doc/*.info*
+ dohtml doc/*.html
+ dodoc inputs/*.example
+
+ # Create cfengine working directory
+ mkdir -p ${D}/var/cfengine
+ fperms 700 /var/cfengine
+ keepdir /var/cfengine/bin
+ keepdir /var/cfengine/inputs
+}
+
+pkg_postinst() {
+ if [ ! -f "/var/cfengine/ppkeys/localhost.priv" ]
+ then
+ einfo "Generating keys for localhost."
+ /usr/sbin/cfkey
+ fi
+
+
+ # Copy cfagent into the cfengine tree otherwise cfexecd won't
+ # find it. Most hosts cache their copy of the cfengine
+ # binaries here. This is the default search location for the
+ # binaries.
+
+ cp /usr/sbin/cf{agent,servd,execd} /var/cfengine/bin/
+}
diff --git a/net-misc/cfengine/files/digest-cfengine-2.1.0_p1 b/net-misc/cfengine/files/digest-cfengine-2.1.0_p1
new file mode 100644
index 000000000000..344f102985c2
--- /dev/null
+++ b/net-misc/cfengine/files/digest-cfengine-2.1.0_p1
@@ -0,0 +1 @@
+MD5 3b2b132cb7d15f10818c0a05877d86da cfengine-2.1.0p1.tar.gz 1288995