summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-11-06 09:11:27 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-11-06 09:11:27 +0000
commit0305157abd28118196774e608d9a86e38743641f (patch)
tree5a60acf596e780bf213b7ac792059326ee30904b /net-misc/freeswan/freeswan-1.98b-r2.ebuild
parentBumped to version 3.7.2 with ~arch keywords. (diff)
downloadhistorical-0305157abd28118196774e608d9a86e38743641f.tar.gz
historical-0305157abd28118196774e608d9a86e38743641f.tar.bz2
historical-0305157abd28118196774e608d9a86e38743641f.zip
Fixed bug #5045
Diffstat (limited to 'net-misc/freeswan/freeswan-1.98b-r2.ebuild')
-rw-r--r--net-misc/freeswan/freeswan-1.98b-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/freeswan/freeswan-1.98b-r2.ebuild b/net-misc/freeswan/freeswan-1.98b-r2.ebuild
new file mode 100644
index 000000000000..37d107384ef9
--- /dev/null
+++ b/net-misc/freeswan/freeswan-1.98b-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freeswan/freeswan-1.98b-r2.ebuild,v 1.1 2002/11/06 09:11:27 jhhudso Exp $
+
+X509_PATCH=0.9.15
+S=${WORKDIR}/${P}
+DESCRIPTION="FreeS/WAN IPSec Userspace Utilities with X.509 Patches"
+SRC_URI="ftp://ftp.xs4all.nl/pub/crypto/freeswan/${P}.tar.gz
+ http://www.strongsec.com/freeswan/x509patch-${X509_PATCH}-${P}.tar.gz"
+
+HOMEPAGE="http://www.freeswan.org"
+DEPEND="virtual/glibc
+ virtual/linux-sources
+ >=dev-libs/gmp-3.1.1"
+LICENSE="GPL-2"
+RDEPEND=""
+SLOT="0"
+KEYWORDS="~x86"
+
+pkg_setup() {
+ [ -d /usr/src/linux/net/ipsec ] || {
+ echo You need to have the crypto-enabled version of Gentoo Sources
+ echo with a symlink to it in /usr/src/linux in order to have IPSec
+ echo kernel compatibility. Please emerge sys-kernel/crypto-sources,
+ echo compile an IPSec-enabled kernel and attempt this ebuild again.
+ exit 1
+ }
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/freeswan-gentoo-cflags.patch || die
+ sed 's:/etc/ipsec.d:/etc/ipsec/ipsec.d:g' ${WORKDIR}/x509patch-${X509_PATCH}-${P}/freeswan.diff | patch -p1 || die
+}
+
+src_compile() {
+
+ make \
+ DESTDIR=${D} \
+ USERCOMPILE="${CFLAGS}" \
+ FINALCONFDIR=/etc/ipsec \
+ INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ INC_MANDIR=share/man \
+ confcheck programs || die
+}
+
+src_install () {
+
+ # try make prefix=${D}/usr install
+
+ make \
+ DESTDIR=${D} \
+ USERCOMPILE="${CFLAGS}" \
+ FINALCONFDIR=/etc/ipsec \
+ INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ INC_MANDIR=share/man \
+ install || die
+
+ newdoc ${WORKDIR}/x509patch-${X509_PATCH}-${P}/README README.x509
+ newdoc ${WORKDIR}/x509patch-${X509_PATCH}-${P}/CHANGES CHANGES.x509
+ newdoc ${WORKDIR}/x509patch-${X509_PATCH}-${P}/ipsec.secrets.template ipsec.secrets.x509
+ dodoc INSTALL COPYING CREDITS BUGS CHANGES README doc/*
+ dosym /etc/ipsec/ipsec.d /etc/ipsec.d
+}
+