summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-16 21:39:23 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-16 21:39:23 +0000
commit9039334c8b0d0773f701894e072d29fc4ba04f55 (patch)
tree8aa127bbbc832a1d805e23c897948b4a0d7cea31 /net-misc/neon/neon-0.21.3.ebuild
parentsandbox violation fix0rs (diff)
downloadhistorical-9039334c8b0d0773f701894e072d29fc4ba04f55.tar.gz
historical-9039334c8b0d0773f701894e072d29fc4ba04f55.tar.bz2
historical-9039334c8b0d0773f701894e072d29fc4ba04f55.zip
Fixes #5102.
Diffstat (limited to 'net-misc/neon/neon-0.21.3.ebuild')
-rw-r--r--net-misc/neon/neon-0.21.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/neon/neon-0.21.3.ebuild b/net-misc/neon/neon-0.21.3.ebuild
new file mode 100644
index 000000000000..aa79024221b9
--- /dev/null
+++ b/net-misc/neon/neon-0.21.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.21.3.ebuild,v 1.1 2002/07/16 21:37:24 karltk Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="HTTP and WebDAV client library"
+
+SRC_URI="http://www.webdav.org/${PN}/${P}.tar.gz"
+
+HOMEPAGE="http://www.webdav.org/neon"
+LICENSE="GPL-2"
+DEPEND="dev-libs/libxml2
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="${DEPEND}"
+SLOT="0"
+
+
+src_compile() {
+ local myconf
+
+ myconf='--enable-shared'
+
+ use ssl && myconf="$myconf --with-ssl"
+
+ econf $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
+}
+