summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-10-29 20:06:51 +0000
committerKeri Harris <keri@gentoo.org>2010-10-29 20:06:51 +0000
commitcb30465668394aa14f88fbd1f73c796389ea27a8 (patch)
treea7a13499c967420a727618af0546f8969d74be9a /net-misc/pedro/pedro-1.5.ebuild
parentClean up old revisions. (diff)
downloadhistorical-cb30465668394aa14f88fbd1f73c796389ea27a8.tar.gz
historical-cb30465668394aa14f88fbd1f73c796389ea27a8.tar.bz2
historical-cb30465668394aa14f88fbd1f73c796389ea27a8.zip
QA - tidy up examples installation, add die to doins calls
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'net-misc/pedro/pedro-1.5.ebuild')
-rw-r--r--net-misc/pedro/pedro-1.5.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/net-misc/pedro/pedro-1.5.ebuild b/net-misc/pedro/pedro-1.5.ebuild
index 5eeb797cd3d5..2f3566f57fa5 100644
--- a/net-misc/pedro/pedro-1.5.ebuild
+++ b/net-misc/pedro/pedro-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pedro/pedro-1.5.ebuild,v 1.6 2010/10/24 15:10:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pedro/pedro-1.5.ebuild,v 1.7 2010/10/29 20:06:51 keri Exp $
EAPI=1
@@ -29,16 +29,18 @@ src_unpack() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README
+ dodoc AUTHORS README || die
if use doc ; then
- dodoc "${WORKDIR}"/${PN}.pdf
+ dodoc "${WORKDIR}"/${PN}.pdf || die
fi
if use examples ; then
insinto /usr/share/doc/${PF}/examples
- doins src/examples/*.{c,tcl}
- doins src/java_api/*.java
- doins src/python_api/*.py
+ doins src/examples/*.{c,tcl} || die
+ insinto /usr/share/doc/${PF}/examples/java_api
+ doins src/java_api/*.java || die
+ insinto /usr/share/doc/${PF}/examples/python_api
+ doins src/python_api/*.py || die
fi
}