summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-15 17:33:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-15 17:33:15 +0000
commit0e8a872a852e4bfaf093087ef9b30fc5d108e3d5 (patch)
tree6d0c4e37feb60810720eab8946ad59ed1a92bd7c /net-misc/pmsvn/pmsvn-1.0.6.ebuild
parentAdd missing ncurses dep, #406087 by Bertrand Jacquin (diff)
downloadhistorical-0e8a872a852e4bfaf093087ef9b30fc5d108e3d5.tar.gz
historical-0e8a872a852e4bfaf093087ef9b30fc5d108e3d5.tar.bz2
historical-0e8a872a852e4bfaf093087ef9b30fc5d108e3d5.zip
Version bump
Package-Manager: portage-2.1.11.34/cvs/Linux x86_64 Manifest-Sign-Key: 0xB4AFF2C2
Diffstat (limited to 'net-misc/pmsvn/pmsvn-1.0.6.ebuild')
-rw-r--r--net-misc/pmsvn/pmsvn-1.0.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/pmsvn/pmsvn-1.0.6.ebuild b/net-misc/pmsvn/pmsvn-1.0.6.ebuild
new file mode 100644
index 000000000000..9d89639534b4
--- /dev/null
+++ b/net-misc/pmsvn/pmsvn-1.0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pmsvn/pmsvn-1.0.6.ebuild,v 1.1 2012/12/15 17:33:13 hwoarang Exp $
+
+EAPI=5
+
+DESCRIPTION="Server's configuration management and monitoring tool"
+HOMEPAGE="http://sourceforge.net/projects/pmsvn/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-analyzer/nrpe
+ >=app-shells/bash-4.0_p37
+ >=sys-apps/sed-4.2
+ >=dev-vcs/subversion-1.6.9"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ # move configuration file from /etc/${PN}.conf to /etc/${PN}/${PN}.conf
+ sed -i "/etc\/${PN}.conf/s:etc/${PN}.conf:etc/${PN}/${PN}.conf:" ${PN} \
+ || die "failed to fix path for configuration file"
+}
+
+src_install() {
+ dosbin "${PN}"
+ dodoc README
+ # No sample file anymore. Autogenerated on first execution
+ # insinto /etc/${PN}/
+ # doins pmsvn.conf.sample
+}