summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2014-03-11 09:50:55 +0000
committerJoshua Kinard <kumba@gentoo.org>2014-03-11 09:50:55 +0000
commit66941599cde92da6512c74c529e9cf5cfc264dab (patch)
tree988b870b6e77cde634318dae02107158ed721301 /net-misc/spread/spread-4.1.0-r1.ebuild
parentFix some compiler warnings. Inherit readme.gentoo.eclass. (diff)
downloadhistorical-66941599cde92da6512c74c529e9cf5cfc264dab.tar.gz
historical-66941599cde92da6512c74c529e9cf5cfc264dab.tar.bz2
historical-66941599cde92da6512c74c529e9cf5cfc264dab.zip
Add 4.3.0 ebuild, fix init script to create /var/run/spread at startup to resolve #449242.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xD25D95E3
Diffstat (limited to 'net-misc/spread/spread-4.1.0-r1.ebuild')
-rw-r--r--net-misc/spread/spread-4.1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/spread/spread-4.1.0-r1.ebuild b/net-misc/spread/spread-4.1.0-r1.ebuild
new file mode 100644
index 000000000000..62290b4f03bb
--- /dev/null
+++ b/net-misc/spread/spread-4.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spread/spread-4.1.0-r1.ebuild,v 1.1 2014/03/11 09:50:44 kumba Exp $
+
+EAPI="4"
+inherit eutils user
+
+MY_PN="spread-src"
+
+DESCRIPTION="Distributed network messaging system"
+HOMEPAGE="http://www.spread.org"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Spread-1.0 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ enewuser spread
+ enewgroup spread
+}
+
+src_prepare() {
+ # don't strip binaries
+ sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+}