summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2002-06-12 03:23:50 +0000
committerBen Lutgens <blutgens@gentoo.org>2002-06-12 03:23:50 +0000
commit484d0e7bbbc1e8aacc8b0b6304ab8c9334a81ba8 (patch)
tree51882a3014534af1952752776379a6cd681f3d75 /net-misc/tsocks
parentCleaned out some old crusty package versions, updated my email addresses, (diff)
downloadhistorical-484d0e7bbbc1e8aacc8b0b6304ab8c9334a81ba8.tar.gz
historical-484d0e7bbbc1e8aacc8b0b6304ab8c9334a81ba8.tar.bz2
historical-484d0e7bbbc1e8aacc8b0b6304ab8c9334a81ba8.zip
Cleaned out some old crusty package versions, updated my email addresses,
and am comitting tsocks and an updated portagemaster
Diffstat (limited to 'net-misc/tsocks')
-rw-r--r--net-misc/tsocks/ChangeLog12
-rw-r--r--net-misc/tsocks/files/digest-tsocks-1.8_beta41
-rw-r--r--net-misc/tsocks/tsocks-1.8_beta4.ebuild39
3 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/tsocks/ChangeLog b/net-misc/tsocks/ChangeLog
new file mode 100644
index 000000000000..c8ea7cb7289e
--- /dev/null
+++ b/net-misc/tsocks/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-misc/tsocks
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tsocks/ChangeLog,v 1.1 2002/06/12 03:23:50 lamer Exp $
+
+*tsocks-1.8beta4 (10 Jun 2002)
+
+ 10 Jun 2002; Ben Lutgens <lamer@gentoo.org> tsocks-1.8_beta4: Ebuild for
+ tsocks submitted to bugs.gentoo.org by a gentoo user *THANKS*
+ bardur-gta@odense.kollegienet.dk. It should be noted that as per the
+ install docs, this stuff gets installed to /lib. Mainly due to the fact
+ that it's often needed before /usr gets mounted. So the old
+ /etc/ld.so.preload trick won't work!
diff --git a/net-misc/tsocks/files/digest-tsocks-1.8_beta4 b/net-misc/tsocks/files/digest-tsocks-1.8_beta4
new file mode 100644
index 000000000000..9f6086e74091
--- /dev/null
+++ b/net-misc/tsocks/files/digest-tsocks-1.8_beta4
@@ -0,0 +1 @@
+MD5 8e8bd8ddf13047f9b9651304bb2ecc54 tsocks-1.8beta4.tar.gz 82206
diff --git a/net-misc/tsocks/tsocks-1.8_beta4.ebuild b/net-misc/tsocks/tsocks-1.8_beta4.ebuild
new file mode 100644
index 000000000000..0776b3fe5b19
--- /dev/null
+++ b/net-misc/tsocks/tsocks-1.8_beta4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Ben Lutgens <lamer@gentoo.org>
+# Author: Bardur Arantsson <bardur-gta@odense.kollegienet.dk>
+
+DESCRIPTION="Transparent SOCKS v4 proxying library."
+HOMEPAGE="http://tsocks.sourceforge.net/"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+SRC_URI="http://ftp1.sourceforge.net/${PN}/${PN}-1.8beta4.tar.gz"
+
+S=${WORKDIR}/tsocks-1.8
+
+src_compile() {
+ # NOTE: the docs say to install it into /lib. If you put it into
+ # /usr/lib and add it to /etc/ld.so.preload on many systems /usr isn't
+ # mounted in time :-( (Ben Lutgens) <lamer@gentoo.org>
+ try ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-conf=/etc/socks/tsocks.conf \
+ --mandir=/usr/share/man
+ try emake
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ insinto /etc/socks
+ doins tsocks.conf.*.example
+ dodoc INSTALL
+ # tsocks script is buggy so we need this symlink
+ dodir /usr/lib
+ dosym /lib/libtsocks.so /usr/lib/libtsocks.so
+}
+
+pkg_postinst () {
+ einfo "Make sure you create /etc/socks/socks.conf from on of the
+ examples in that directory"
+}