summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-04-21 17:51:45 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-04-21 17:51:45 +0000
commit2756c04feb85932997950c6df2fc1cc8509849e9 (patch)
tree17fe92df9a5e9ea0021753700f31c9ac531d095e /net-misc/vncsnapshot/vncsnapshot-1.1.ebuild
parentAdded hppa to KEYWORDS. (diff)
downloadhistorical-2756c04feb85932997950c6df2fc1cc8509849e9.tar.gz
historical-2756c04feb85932997950c6df2fc1cc8509849e9.tar.bz2
historical-2756c04feb85932997950c6df2fc1cc8509849e9.zip
New import
Diffstat (limited to 'net-misc/vncsnapshot/vncsnapshot-1.1.ebuild')
-rw-r--r--net-misc/vncsnapshot/vncsnapshot-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/vncsnapshot/vncsnapshot-1.1.ebuild b/net-misc/vncsnapshot/vncsnapshot-1.1.ebuild
new file mode 100644
index 000000000000..c56c2e3c870b
--- /dev/null
+++ b/net-misc/vncsnapshot/vncsnapshot-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vncsnapshot/vncsnapshot-1.1.ebuild,v 1.1 2003/04/21 17:51:45 g2boojum Exp $
+
+LICENSE="GPL-2"
+DESCRIPTION="A command-line tool for taking JPEG snapshots of VNC servers"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+HOMEPAGE="http://vncsnapshot.sourceforge.net/"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+DEPEND=">=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.4"
+
+# no configure for this puppy
+src_compile() {
+ #note: We override CDEBUGFLAGS instead of CFLAGS because otherwise
+ # we lost the INCLUDES in the makefile.
+ make CDEBUGFLAGS="${CFLAGS}" || die "make failed"
+}
+
+
+# likewise, no make install (we're real Unix hackers, we are)
+src_install() {
+ dobin vncsnapshot || die
+ cp vncsnapshot.man1 vncsnapshot.1
+ doman vncsnapshot.1
+}
+