summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-14 01:50:01 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-14 01:50:01 +0000
commit57482203dafaf9bae81bb32fb36bbb93430b169b (patch)
treead064d4b395228df7d6bf26f816f0b3aef727639 /net-misc
parentx86 stable wrt bug #334881 (diff)
downloadhistorical-57482203dafaf9bae81bb32fb36bbb93430b169b.tar.gz
historical-57482203dafaf9bae81bb32fb36bbb93430b169b.tar.bz2
historical-57482203dafaf9bae81bb32fb36bbb93430b169b.zip
old
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/iputils/files/iputils-021109-gcc34.patch134
-rw-r--r--net-misc/iputils/files/iputils-20060512-kernel-ifaddr.patch85
-rw-r--r--net-misc/iputils/iputils-20070202.ebuild77
-rw-r--r--net-misc/iputils/iputils-20071127-r1.ebuild78
-rw-r--r--net-misc/iputils/iputils-20071127.ebuild75
5 files changed, 0 insertions, 449 deletions
diff --git a/net-misc/iputils/files/iputils-021109-gcc34.patch b/net-misc/iputils/files/iputils-021109-gcc34.patch
deleted file mode 100644
index 98e1c6eb960f..000000000000
--- a/net-misc/iputils/files/iputils-021109-gcc34.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-iputils has a lot of ugly goto's that break when using
-large gcc inline-limits.
-
-Fixes by Robert Moss and Dave Stahl
-http://bugs.gentoo.org/49241
-http://bugs.gentoo.org/80969
-
---- iputils/tracepath.c
-+++ iputils/tracepath.c
-@@ -76,7 +76,7 @@
- int progress = -1;
- int broken_router;
-
--restart:
-+ while (1) {
- memset(&rcvbuf, -1, sizeof(rcvbuf));
- iov.iov_base = &rcvbuf;
- iov.iov_len = sizeof(rcvbuf);
-@@ -93,7 +93,7 @@
- if (res < 0) {
- if (errno == EAGAIN)
- return progress;
-- goto restart;
-+ continue;
- }
-
- progress = mtu;
-@@ -216,7 +216,7 @@
- perror("NET ERROR");
- return 0;
- }
-- goto restart;
-+ }
- }
-
- int probe_ttl(int fd, int ttl)
-@@ -227,7 +227,6 @@
-
- memset(sndbuf,0,mtu);
-
--restart:
- for (i=0; i<10; i++) {
- int res;
-
-@@ -243,7 +242,8 @@
- if (res==0)
- return 0;
- if (res > 0)
-- goto restart;
-+ i = 0;
-+ continue;
- }
- hisptr = (hisptr + 1)&63;
-
---- iputils/tracepath6.c
-+++ iputils/tracepath6.c
-@@ -66,7 +66,7 @@
- int progress = -1;
- int broken_router;
-
--restart:
-+ while (1) {
- memset(&rcvbuf, -1, sizeof(rcvbuf));
- iov.iov_base = &rcvbuf;
- iov.iov_len = sizeof(rcvbuf);
-@@ -83,7 +83,7 @@
- if (res < 0) {
- if (errno == EAGAIN)
- return progress;
-- goto restart;
-+ continue;
- }
-
- progress = 2;
-@@ -222,34 +222,29 @@
- perror("NET ERROR");
- return 0;
- }
-- goto restart;
-+ }
- }
-
- int probe_ttl(int fd, int ttl)
- {
-- int i;
-+ int i=0, res;
- char sndbuf[mtu];
- struct probehdr *hdr = (struct probehdr*)sndbuf;
-
--restart:
--
-- for (i=0; i<10; i++) {
-- int res;
--
-- hdr->ttl = ttl;
-- gettimeofday(&hdr->tv, NULL);
-- if (send(fd, sndbuf, mtu-overhead, 0) > 0)
-- break;
-- res = recverr(fd, ttl);
-- if (res==0)
-- return 0;
-- if (res > 0)
-- goto restart;
-- }
--
-- if (i<10) {
-- int res;
--
-+ while (i<10) {
-+ for (i=0; i<10; i++) {
-+ hdr->ttl = ttl;
-+ gettimeofday(&hdr->tv, NULL);
-+ if (send(fd, sndbuf, mtu-overhead, 0) > 0)
-+ break;
-+ res = recverr(fd, ttl);
-+ if (res==0)
-+ return 0;
-+ if (res > 0) {
-+ i = 0;
-+ continue;
-+ }
-+ }
- data_wait(fd);
- if (recv(fd, sndbuf, sizeof(sndbuf), MSG_DONTWAIT) > 0) {
- printf("%2d?: reply received 8)\n", ttl);
-@@ -257,7 +252,7 @@
- }
- res = recverr(fd, ttl);
- if (res == 1)
-- goto restart;
-+ continue;
- return res;
- }
-
diff --git a/net-misc/iputils/files/iputils-20060512-kernel-ifaddr.patch b/net-misc/iputils/files/iputils-20060512-kernel-ifaddr.patch
deleted file mode 100644
index de90efea2642..000000000000
--- a/net-misc/iputils/files/iputils-20060512-kernel-ifaddr.patch
+++ /dev/null
@@ -1,85 +0,0 @@
---- rarpd.c.orig
-+++ rarpd.c
-@@ -47,6 +47,14 @@
- #endif
- void usage(void) __attribute__((noreturn));
-
-+struct kern_ifaddr
-+{
-+ struct kern_ifaddr *next;
-+ __u32 prefix;
-+ __u32 mask;
-+ __u32 local;
-+};
-+
- struct iflink
- {
- struct iflink *next;
-@@ -54,17 +62,9 @@
- int hatype;
- unsigned char lladdr[16];
- unsigned char name[IFNAMSIZ];
-- struct ifaddr *ifa_list;
-+ struct kern_ifaddr *ifa_list;
- } *ifl_list;
-
--struct ifaddr
--{
-- struct ifaddr *next;
-- __u32 prefix;
-- __u32 mask;
-- __u32 local;
--};
--
- struct rarp_map
- {
- struct rarp_map *next;
-@@ -91,7 +91,7 @@
- int fd;
- struct ifreq *ifrp, *ifend;
- struct iflink *ifl;
-- struct ifaddr *ifa;
-+ struct kern_ifaddr *ifa;
- struct ifconf ifc;
- struct ifreq ibuf[256];
-
-@@ -182,7 +182,7 @@
- if (ifa == NULL) {
- if (mask == 0 || prefix == 0)
- continue;
-- ifa = (struct ifaddr*)malloc(sizeof(*ifa));
-+ ifa = (struct kern_ifaddr*)malloc(sizeof(*ifa));
- memset(ifa, 0, sizeof(*ifa));
- ifa->local = addr;
- ifa->prefix = prefix;
-@@ -238,10 +238,10 @@
- return dent != NULL;
- }
-
--struct ifaddr *select_ipaddr(int ifindex, __u32 *sel_addr, __u32 **alist)
-+struct kern_ifaddr *select_ipaddr(int ifindex, __u32 *sel_addr, __u32 **alist)
- {
- struct iflink *ifl;
-- struct ifaddr *ifa;
-+ struct kern_ifaddr *ifa;
- int retry = 0;
- int i;
-
-@@ -297,7 +297,7 @@
-
- if (r == NULL) {
- if (hatype == ARPHRD_ETHER && halen == 6) {
-- struct ifaddr *ifa;
-+ struct kern_ifaddr *ifa;
- struct hostent *hp;
- char ename[256];
- static struct rarp_map emap = {
-@@ -370,7 +370,7 @@
- {
- __u32 laddr = 0;
- struct iflink *ifl;
-- struct ifaddr *ifa;
-+ struct kern_ifaddr *ifa;
-
- for (ifl=ifl_list; ifl; ifl = ifl->next)
- if (ifl->index == ifindex)
diff --git a/net-misc/iputils/iputils-20070202.ebuild b/net-misc/iputils/iputils-20070202.ebuild
deleted file mode 100644
index 02f7fec1bbef..000000000000
--- a/net-misc/iputils/iputils-20070202.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20070202.ebuild,v 1.14 2009/08/23 16:00:44 flameeyes Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="Network monitoring tools including ping and ping6"
-HOMEPAGE="http://www.linux-foundation.org/en/Net:Iputils"
-SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="static ipv6 doc"
-
-DEPEND="virtual/os-headers
- doc? (
- app-text/openjade
- dev-perl/SGMLSpm
- app-text/docbook-sgml-dtd
- app-text/docbook-sgml-utils
- )"
-RDEPEND="!net-misc/rarpd"
-
-S=${WORKDIR}/${PN}-s${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-021109-gcc34.patch
- epatch "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
- epatch "${FILESDIR}"/${PN}-20070202-makefile.patch
- epatch "${FILESDIR}"/${PN}-20060512-kernel-ifaddr.patch
- epatch "${FILESDIR}"/${PN}-20060512-linux-headers.patch
- epatch "${FILESDIR}"/${PN}-20070202-no-open-max.patch #195861
-
- use static && append-ldflags -static
- use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
-}
-
-src_compile() {
- tc-export CC
- emake || die "make main failed"
-
- # We include the extra check for docbook2html
- # because when we emerge from a stage1/stage2,
- # it may not exist #23156
- if use doc && type -p docbook2html ; then
- emake -j1 html man || die
- fi
-}
-
-src_install() {
- into /
- dobin ping || die "ping"
- use ipv6 && dobin ping6
- dosbin arping || die "arping"
- into /usr
- dosbin tracepath || die "tracepath"
- use ipv6 && dosbin trace{path,route}6
- dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
-
- fperms 4711 /bin/ping
- use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
-
- dodoc INSTALL RELNOTES
-
- if use doc ; then
- rm -f doc/setkey.8
- use ipv6 \
- && dosym ping.8 /usr/share/man/man8/ping6.8 \
- || rm -f doc/*6.8
- doman doc/*.8
-
- dohtml doc/*.html
- fi
-}
diff --git a/net-misc/iputils/iputils-20071127-r1.ebuild b/net-misc/iputils/iputils-20071127-r1.ebuild
deleted file mode 100644
index 8f8781fcb209..000000000000
--- a/net-misc/iputils/iputils-20071127-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20071127-r1.ebuild,v 1.1 2008/04/20 20:56:45 vapier Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="Network monitoring tools including ping and ping6"
-HOMEPAGE="http://www.linux-foundation.org/en/Net:Iputils"
-SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2
- mirror://gentoo/iputils-s${PV}-manpages.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc idn ipv6 static"
-
-DEPEND="virtual/os-headers
- doc? (
- app-text/openjade
- dev-perl/SGMLSpm
- app-text/docbook-sgml-dtd
- app-text/docbook-sgml-utils
- )"
-RDEPEND="!net-misc/rarpd
- idn? ( net-dns/libidn )"
-
-S=${WORKDIR}/${PN}-s${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc34.patch
- epatch "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
- epatch "${FILESDIR}"/${PN}-20070202-makefile.patch
- epatch "${FILESDIR}"/${P}-kernel-ifaddr.patch
- epatch "${FILESDIR}"/${PN}-20060512-linux-headers.patch
- epatch "${FILESDIR}"/${PN}-20070202-no-open-max.patch #195861
- epatch "${FILESDIR}"/${PN}-20070202-idn.patch #218638
-
- use static && append-ldflags -static
- use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
- export IDN=$(use idn && echo yes)
-}
-
-src_compile() {
- tc-export CC
- emake || die "make main failed"
-
- # We include the extra check for docbook2html
- # because when we emerge from a stage1/stage2,
- # it may not exist #23156
- if use doc && type -P docbook2html >/dev/null ; then
- emake -j1 html || die
- fi
-}
-
-src_install() {
- into /
- dobin ping || die "ping"
- use ipv6 && dobin ping6
- dosbin arping || die "arping"
- into /usr
- dosbin tracepath || die "tracepath"
- use ipv6 && dosbin trace{path,route}6
- dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
-
- fperms 4711 /bin/ping
- use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
-
- dodoc INSTALL RELNOTES
- use ipv6 \
- && dosym ping.8 /usr/share/man/man8/ping6.8 \
- || rm -f doc/*6.8
- rm -f doc/setkey.8
- doman doc/*.8
-
- use doc && dohtml doc/*.html
-}
diff --git a/net-misc/iputils/iputils-20071127.ebuild b/net-misc/iputils/iputils-20071127.ebuild
deleted file mode 100644
index 3073d6d19e56..000000000000
--- a/net-misc/iputils/iputils-20071127.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20071127.ebuild,v 1.10 2008/04/20 20:55:59 vapier Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="Network monitoring tools including ping and ping6"
-HOMEPAGE="http://www.linux-foundation.org/en/Net:Iputils"
-SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2
- mirror://gentoo/iputils-s${PV}-manpages.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="static ipv6 doc"
-
-DEPEND="virtual/os-headers
- doc? (
- app-text/openjade
- dev-perl/SGMLSpm
- app-text/docbook-sgml-dtd
- app-text/docbook-sgml-utils
- )"
-RDEPEND="!net-misc/rarpd"
-
-S=${WORKDIR}/${PN}-s${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc34.patch
- epatch "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
- epatch "${FILESDIR}"/${PN}-20070202-makefile.patch
- epatch "${FILESDIR}"/${P}-kernel-ifaddr.patch
- epatch "${FILESDIR}"/${PN}-20060512-linux-headers.patch
- epatch "${FILESDIR}"/${PN}-20070202-no-open-max.patch #195861
-
- use static && append-ldflags -static
- use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
-}
-
-src_compile() {
- tc-export CC
- emake || die "make main failed"
-
- # We include the extra check for docbook2html
- # because when we emerge from a stage1/stage2,
- # it may not exist #23156
- if use doc && type -P docbook2html >/dev/null ; then
- emake -j1 html || die
- fi
-}
-
-src_install() {
- into /
- dobin ping || die "ping"
- use ipv6 && dobin ping6
- dosbin arping || die "arping"
- into /usr
- dosbin tracepath || die "tracepath"
- use ipv6 && dosbin trace{path,route}6
- dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
-
- fperms 4711 /bin/ping
- use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
-
- dodoc INSTALL RELNOTES
- use ipv6 \
- && dosym ping.8 /usr/share/man/man8/ping6.8 \
- || rm -f doc/*6.8
- rm -f doc/setkey.8
- doman doc/*.8
-
- use doc && dohtml doc/*.html
-}