summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-07-23 15:15:53 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-07-23 15:15:53 +0000
commitff31b20a78ed8e402b9d9034ffb1657964393313 (patch)
treefd2ceb72d5ad43828d95f503cfa420d6325988b1 /net-nds
parentstable x86, security bug 329279 (diff)
downloadhistorical-ff31b20a78ed8e402b9d9034ffb1657964393313.tar.gz
historical-ff31b20a78ed8e402b9d9034ffb1657964393313.tar.bz2
historical-ff31b20a78ed8e402b9d9034ffb1657964393313.zip
provide 389-ds-base-1.2.5 (stable)
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/389-ds-base/389-ds-base-1.2.5.ebuild190
-rw-r--r--net-nds/389-ds-base/ChangeLog7
-rw-r--r--net-nds/389-ds-base/Manifest4
3 files changed, 199 insertions, 2 deletions
diff --git a/net-nds/389-ds-base/389-ds-base-1.2.5.ebuild b/net-nds/389-ds-base/389-ds-base-1.2.5.ebuild
new file mode 100644
index 000000000000..f04ba0c9cb42
--- /dev/null
+++ b/net-nds/389-ds-base/389-ds-base-1.2.5.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/389-ds-base-1.2.5.ebuild,v 1.1 2010/07/23 15:15:53 lxnay Exp $
+
+EAPI=2
+
+WANT_AUTOMAKE="1.9"
+MY_P=${P/_alpha/.a}
+MY_P=${MY_P/_rc/.rc}
+inherit eutils multilib flag-o-matic autotools
+
+DESCRIPTION="389 Directory Server (core librares and daemons )"
+HOMEPAGE="http://port389.org/"
+SRC_URI="http://directory.fedoraproject.org/sources/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2-with-exceptions"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="autobind auto-dn-suffix debug doc +pam-passthru +dna +ldapi +bitwise +presence kerberos selinux"
+
+ALL_DEPEND="dev-libs/nss[utils]
+ dev-libs/nspr
+ dev-libs/svrcore
+ dev-libs/mozldap
+ >=dev-libs/cyrus-sasl-2.1.19
+ >=dev-libs/icu-3.4
+ >=sys-libs/db-4.5
+ >=net-analyzer/net-snmp-5.1.2
+ dev-libs/openssl
+ sys-apps/tcp-wrappers
+ sys-libs/pam
+ sys-libs/zlib
+ dev-perl/perl-mozldap
+ dev-libs/libpcre:3
+ kerberos? ( net-nds/openldap
+ >=app-crypt/mit-krb5-1.7-r100[ldap] )
+ selinux? ( >=sys-apps/policycoreutils-1.30.30
+ sec-policy/selinux-base-policy )"
+
+DEPEND="${ALL_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/libtool:1.5
+ doc? ( app-doc/doxygen )
+ selinux? ( sys-devel/m4 >=sys-apps/checkpolicy-1.30.12 )
+ sys-apps/sed"
+RDEPEND="${ALL_DEPEND}
+ virtual/perl-Time-Local
+ virtual/perl-MIME-Base64"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup dirsrv
+ enewuser dirsrv -1 -1 -1 dirsrv
+}
+
+src_prepare() {
+
+ # as per 389 documentation, when 64bit, export USE_64
+ use amd64 && export USE_64=1
+
+ sed -i -e 's/nobody/dirsrv/g' configure.ac || die "sed failed on configure.ac"
+ use selinux && epatch "${FILESDIR}/1.2.6"/*selinux*.patch
+ eautoreconf
+
+ # enable nsslapd-allow-unauthenticated-binds by default
+ sed -i '/^nsslapd-allow-unauthenticated-binds/ s/off/on/' "${S}"/ldap/ldif/template-dse.ldif.in || \
+ die "cannot tweak default setting: nsslapd-allow-unauthenticated-binds"
+
+}
+
+src_configure() {
+ local myconf=""
+
+ use auto-dn-suffix && myconf="${myconf} --enable-auto-dn-suffix"
+ use selinux && myconf="${myconf} --with-selinux"
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable pam-passthru) \
+ $(use_enable ldapi) \
+ $(use_enable autobind) \
+ $(use_enable dna) \
+ $(use_enable bitwise) \
+ $(use_enable presence) \
+ $(use_with kerberos) \
+ --enable-maintainer-mode \
+ --enable-autobind \
+ --with-fhs \
+ $myconf || die "econf failed"
+}
+
+src_compile() {
+ append-lfs-flags
+
+ # Use -j1 otherwise libacl-plugin.so could fail to install properly
+ emake -j1 || die "compile failed"
+ if use selinux; then
+ emake -f selinux/Makefile || die " build selinux policy failed"
+ fi
+}
+
+src_install () {
+ # Use -j1 otherwise libacl-plugin.so could fail to install properly
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ if use selinux;then
+ emake -f selinux/Makefile DESTDIR="${D}" install || die "Install selinux policy failed"
+ fi
+
+ # install not installed header
+ insinto /usr/include/dirsrv
+ doins ldap/servers/slapd/slapi-plugin.h
+
+ # for build free-ipa require winsync-plugin
+ doins ldap/servers/plugins/replication/winsync-plugin.h
+
+ # make sure perl scripts have a proper shebang
+ cd "${D}"/usr/share/dirsrv/script-templates/
+
+ for i in $(find ./ -iname '*.pl') ;do
+ sed -i -e 's/#{{PERL-EXEC}}/#\!\/usr\/bin\/perl/' $i || die
+ done
+
+ # remove redhat style init script
+ rm -rf "${D}"/etc/rc.d || die
+ rm -rf "${D}"/etc/default || die
+
+ # and install gentoo style init script
+ newinitd "${FILESDIR}"/389-ds.initd 389-ds
+ newinitd "${FILESDIR}"/389-ds-snmp.initd 389-ds-snmp
+
+ # install Gentoo-specific start/stop scripts
+ rm -f "${D}"/usr/sbin/{re,}start-dirsrv || die "cannot remove 389 start/stop executables"
+ exeinto /usr/sbin
+ doexe "${FILESDIR}"/{re,}start-dirsrv
+
+ # cope with libraries being in /usr/lib/dirsrv
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/dirsrv" > "${D}"/etc/env.d/08dirsrv
+
+ # create the directory where our log file and database
+ diropts -m 0750 -o dirsrv -g dirsrv
+ keepdir /var/lib/dirsrv
+ dodir /var/lock/dirsrv
+
+ # snmp agent, required directory
+ keepdir /var/agentx
+ dodir /var/agentx
+
+ if use doc; then
+ cd "${S}"
+ doxygen slapi.doxy || die "cannot run doxygen"
+ dohtml -r docs/html
+ fi
+}
+
+pkg_postinst() {
+ if use selinux; then
+ if has "loadpolicy" $FEATURES; then
+ einfo "Inserting the following modules into the module store"
+ cd /usr/share/selinux/targeted # struct policy not supported
+ semodule -s dirsrv -i dirsrv.pp
+ else
+ elog
+ elog "Policy has not been loaded. It is strongly suggested"
+ elog "that the policy be loaded before continuing!!"
+ elog
+ elog "Automatic policy loading can be enabled by adding"
+ elog "\"loadpolicy\" to the FEATURES in make.conf."
+ elog
+ ebeep 4
+ fi
+ fi
+
+ elog
+ elog "If you are planning to use 389-ds-snmp (ldap-agent),"
+ elog "make sure to properly configure: /etc/dirsrv/config/ldap-agent.conf"
+ elog "adding proper 'server' entries, and adding the lines below to"
+ elog " => /etc/snmp/snmpd.conf"
+ elog
+ elog "master agentx"
+ elog "agentXSocket /var/agentx/master"
+ elog
+ elog
+ elog "To start 389 Directory Server (LDAP service) at boot:"
+ elog
+ elog " rc-update add 389-ds default"
+ elog
+}
diff --git a/net-nds/389-ds-base/ChangeLog b/net-nds/389-ds-base/ChangeLog
index db9e55347ed0..ec52e650c507 100644
--- a/net-nds/389-ds-base/ChangeLog
+++ b/net-nds/389-ds-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/389-ds-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/ChangeLog,v 1.3 2010/07/23 14:27:13 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/ChangeLog,v 1.4 2010/07/23 15:15:53 lxnay Exp $
+
+*389-ds-base-1.2.5 (23 Jul 2010)
+
+ 23 Jul 2010; Fabio Erculiani <lxnay@gentoo.org> +389-ds-base-1.2.5.ebuild:
+ provide 389-ds-base-1.2.5 (stable)
23 Jul 2010; Fabio Erculiani <lxnay@gentoo.org> files/start-dirsrv:
silently add trivial change to start-dirsrv to always exit with a valid
diff --git a/net-nds/389-ds-base/Manifest b/net-nds/389-ds-base/Manifest
index 85604b8dd7c5..b7e728a33438 100644
--- a/net-nds/389-ds-base/Manifest
+++ b/net-nds/389-ds-base/Manifest
@@ -4,7 +4,9 @@ AUX 389-ds-snmp.initd 1076 RMD160 7a3be7745e7e7a6de675b40b56556bfacef76a9a SHA1
AUX 389-ds.initd 1872 RMD160 807455864decce2bc832072d2d4daf034fe22e7a SHA1 ba6f806e23e3c71ad84241e4ef66af1e79241340 SHA256 018d392bcd8ba363ce2ee3b02c81a02b90fed10599d24dab5327d864518a79be
AUX restart-dirsrv 577 RMD160 438df6a53eb0253a25371265ccb85662d0df408b SHA1 2ae8467499b821db040906fd80fe891a8ecefebe SHA256 40b4a28517a2c77ded2d71183a35e6bbf22eec24860282a08ef0033220bf9a98
AUX start-dirsrv 299 RMD160 d09bf782fb2e926c36c380fb68b21677a88e27fc SHA1 a1337b080d1498a6ecf86fd602cfc9f5c4a18702 SHA256 38c03319a1fc44255e0a658a30a009b577e012fb67626b9c4fc497df8b98aeff
+DIST 389-ds-base-1.2.5.tar.bz2 2791116 RMD160 7bc4af77a66f19f1ee5ea2dfe6678e0d4b09993f SHA1 40340cdf1d1816c5a6b97acfb770c1f5ad6f7f4a SHA256 564fa7fb368d6b0dacd9b237aa515a48f57ae7395f191ba17867a5506cdc0a43
DIST 389-ds-base-1.2.6.rc3.tar.bz2 2867964 RMD160 9d69aa27c8cd762eb3f483e6b10faa8c70239ae7 SHA1 9a13db5b890514172a0283d4225eea62ef20c5e3 SHA256 4aff1db07b111a2e650b25e48835a927b2e46d78c233f06ea8854a35f4979330
+EBUILD 389-ds-base-1.2.5.ebuild 5200 RMD160 76ed3bf5f7a02d623690b8bbe514b53cfad5ae1e SHA1 6bba5c26a44cc0633bcf89bd28f7796f7466243d SHA256 dcb40219408d6a42940bc6a8a61f77a5bc67370d1182227e91489ecf03714dfc
EBUILD 389-ds-base-1.2.6_rc3.ebuild 5204 RMD160 3f340066482050303f9960c3cdc13b63f3ec1b58 SHA1 4e4853b1186ffff5e77d483482c4c7fab43a38f2 SHA256 dd73c029c71b225cc2b95e7ca7cc01dc5b956e5cffe8fff262dba153f1b650c1
-MISC ChangeLog 832 RMD160 410507dce6a0a55c50c25c934a7ccf4420adc86f SHA1 33566bf9211ae34ae3fbc3846fe822618316d13d SHA256 f1fa3d438b0ccd54b6dc62a58281d8a9ea57e202bb98395225e9595f82279d1e
+MISC ChangeLog 981 RMD160 4f490e695c5d8387d82adf90e314950072508ac5 SHA1 427bb3f6dafa1cffbd5515e6c083b7d303e8f6bd SHA256 58a5e02f0f134d79b52a9ac0902c91522f0ffd7b30168082df9ddf27321ea738
MISC metadata.xml 1070 RMD160 f31a4089eb70f9228378f1fb6dd69ae2942bc9a3 SHA1 5b58beab1b9e2a63c7378bdf9836683a888600de SHA256 b7bd4cba6afb6af7418c4c6467ef998cdcd381765de671462f15872d29fa4066