summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-03-04 00:12:00 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-03-04 00:12:00 +0000
commitb535de02190c98dc19943d2d853aee15663e661f (patch)
tree6be19c0f919028364568ee0414f1ce413d792ff1 /net-p2p/bitcoind/bitcoind-0.10.0.ebuild
parentDependency on leveldb and libsecp256k1 is now handled by the eclass. (diff)
downloadhistorical-b535de02190c98dc19943d2d853aee15663e661f.tar.gz
historical-b535de02190c98dc19943d2d853aee15663e661f.tar.bz2
historical-b535de02190c98dc19943d2d853aee15663e661f.zip
Dependency on leveldb and libsecp256k1 is now handled by the eclass. Fix logrotate, bug #541510.
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0xF52D4BBA
Diffstat (limited to 'net-p2p/bitcoind/bitcoind-0.10.0.ebuild')
-rw-r--r--net-p2p/bitcoind/bitcoind-0.10.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/net-p2p/bitcoind/bitcoind-0.10.0.ebuild b/net-p2p/bitcoind/bitcoind-0.10.0.ebuild
deleted file mode 100644
index 6ba032d3ee9b..000000000000
--- a/net-p2p/bitcoind/bitcoind-0.10.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2010-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.10.0.ebuild,v 1.5 2015/02/27 14:27:20 dilfridge Exp $
-
-EAPI=5
-
-BITCOINCORE_COMMITHASH="047a89831760ff124740fe9f58411d57ee087078"
-BITCOINCORE_LJR_DATE="20150220"
-BITCOINCORE_IUSE="examples ljr logrotate test upnp +wallet xt zeromq"
-BITCOINCORE_POLICY_PATCHES="cpfp dcmp rbf spamfilter"
-inherit bash-completion-r1 bitcoincore user systemd
-
-DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-RDEPEND="
- dev-libs/libsecp256k1
- virtual/bitcoin-leveldb
- logrotate? (
- app-admin/logrotate
- )
-"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- local UG='bitcoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
-}
-
-src_configure() {
- # NOTE: --enable-zmq actually disables it
- bitcoincore_conf \
- --with-daemon
-}
-
-src_install() {
- bitcoincore_src_install
-
- insinto /etc/bitcoin
- newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
- fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
- fperms 600 /etc/bitcoin/bitcoin.conf
-
- newconfd "${FILESDIR}/bitcoin.confd" ${PN}
- newinitd "${FILESDIR}/bitcoin.initd-r1" ${PN}
- systemd_dounit "${FILESDIR}/bitcoind.service"
-
- keepdir /var/lib/bitcoin/.bitcoin
- fperms 700 /var/lib/bitcoin
- fowners bitcoin:bitcoin /var/lib/bitcoin/
- fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
- dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
-
- dodoc doc/assets-attribution.md doc/tor.md
- doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
-
- newbashcomp contrib/${PN}.bash-completion ${PN}
-
- if use examples; then
- docinto examples
- dodoc -r contrib/{bitrpc,pyminer,qos,spendfrom,tidy_datadir.sh}
- fi
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/bitcoind.logrotate" bitcoind
- fi
-}