summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-07-13 18:03:07 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-07-13 18:03:07 +0000
commit9d51a797cbde865c6308da999d5738daa98d9d1d (patch)
tree6a80f24bcb257ab7fe6847704720f7a13ea71200 /net-p2p/dc-qt
parent#98736: version bump (diff)
downloadhistorical-9d51a797cbde865c6308da999d5738daa98d9d1d.tar.gz
historical-9d51a797cbde865c6308da999d5738daa98d9d1d.tar.bz2
historical-9d51a797cbde865c6308da999d5738daa98d9d1d.zip
Added xine as a optional dependency, bug #79766
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-p2p/dc-qt')
-rw-r--r--net-p2p/dc-qt/ChangeLog8
-rw-r--r--net-p2p/dc-qt/Manifest15
-rw-r--r--net-p2p/dc-qt/dc-qt-0.1.2.ebuild21
-rw-r--r--net-p2p/dc-qt/files/dc-qt-0.1.2-xine.patch25
4 files changed, 60 insertions, 9 deletions
diff --git a/net-p2p/dc-qt/ChangeLog b/net-p2p/dc-qt/ChangeLog
index 833ac097e985..976e434b60cc 100644
--- a/net-p2p/dc-qt/ChangeLog
+++ b/net-p2p/dc-qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/dc-qt
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-qt/ChangeLog,v 1.5 2004/10/18 12:34:02 weeve Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-qt/ChangeLog,v 1.6 2005/07/13 18:03:07 sekretarz Exp $
+
+ 13 Jul 2005; <sekretarz@gentoo.org> +files/dc-qt-0.1.2-xine.patch,
+ dc-qt-0.1.2.ebuild:
+ Added xine as a optional dependency, bug #79766
18 Oct 2004; Jason Wever <weeve@gentoo.org> dc-qt-0.1.2.ebuild:
Added ~sparc keyword.
diff --git a/net-p2p/dc-qt/Manifest b/net-p2p/dc-qt/Manifest
index ab6d87cf0681..0468e9e9bfaa 100644
--- a/net-p2p/dc-qt/Manifest
+++ b/net-p2p/dc-qt/Manifest
@@ -1,6 +1,17 @@
-MD5 1161858e3f3cb9a07107e0ef98c5cd2e ChangeLog 859
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 7d69f3181478521713750b1df501674d dc-qt-0.1.2.ebuild 749
MD5 041d3ffcca63a2487034d0f0d3ea7126 dc-qt-0.1.1.ebuild 592
+MD5 993414cafa80d167b7ba68584afcb701 ChangeLog 1005
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
-MD5 be233d4e0c2930cee1ffff45272439fa dc-qt-0.1.2.ebuild 603
MD5 fe34adba3eb30acbaad41e5a3810e43d files/digest-dc-qt-0.1.1 63
MD5 ef47fcbc65c62e42221344d25cbf0da4 files/digest-dc-qt-0.1.2 63
+MD5 09f64448af1ec94a4d7aa3681d61bd8d files/dc-qt-0.1.2-xine.patch 932
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC1XFRZ/iYVBmujdURAtbRAKDbq/X/B1vCvwa3ZN56o9E4Y6brdgCgkwFU
+WG0D6pCwtLB+rB9eKV6MJXI=
+=He7t
+-----END PGP SIGNATURE-----
diff --git a/net-p2p/dc-qt/dc-qt-0.1.2.ebuild b/net-p2p/dc-qt/dc-qt-0.1.2.ebuild
index cb33f7227333..60e5fb47cf3b 100644
--- a/net-p2p/dc-qt/dc-qt-0.1.2.ebuild
+++ b/net-p2p/dc-qt/dc-qt-0.1.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-qt/dc-qt-0.1.2.ebuild,v 1.3 2004/10/18 12:34:02 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-qt/dc-qt-0.1.2.ebuild,v 1.4 2005/07/13 18:03:07 sekretarz Exp $
-IUSE=""
+inherit eutils
+
+IUSE="xine"
DESCRIPTION="Direct Connect Text Client, QT Gui"
HOMEPAGE="http://dc-qt.sourceforge.net/"
@@ -14,10 +16,19 @@ KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
DEPEND=">=x11-libs/qt-3.2
>=net-p2p/dctc-0.85.9
- >=media-libs/xine-lib-1_rc5"
+ xine? ( >=media-libs/xine-lib-1_rc5 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-xine.patch
+ autoreconf
+}
src_compile() {
- econf || die
+ econf \
+ `use_with xine` || die
emake || die
}
diff --git a/net-p2p/dc-qt/files/dc-qt-0.1.2-xine.patch b/net-p2p/dc-qt/files/dc-qt-0.1.2-xine.patch
new file mode 100644
index 000000000000..c59fde70113f
--- /dev/null
+++ b/net-p2p/dc-qt/files/dc-qt-0.1.2-xine.patch
@@ -0,0 +1,25 @@
+diff -Naur dc-qt-0.1.2.orig/configure.ac dc-qt-0.1.2/configure.ac
+--- dc-qt-0.1.2.orig/configure.ac 2004-08-26 18:20:37.000000000 +0000
++++ dc-qt-0.1.2/configure.ac 2005-07-13 19:39:29.000000000 +0000
+@@ -145,6 +145,11 @@
+ AC_ARG_WITH(qt-libs, [ --with-qt-libs=DIR qt-libs in DIR])
+ AC_ARG_WITH(pthread-libs, [ --with-pthread-libs=DIR bz2-pthread in DIR])
+
++AC_ARG_WITH(xine, [ --with-xine xine support])
++if test -z "$with_xine"; then
++ with_xine="no"
++fi
++
+ AC_ARG_WITH(xine-prefix,
+ [ --with-xine-prefix=DIR xine installed in DIR],
+ xine_cfg_prefix="$withval", xine_cfg_prefix="")
+@@ -253,7 +258,8 @@
+ AC_PATH_PROG(XINE_CONFIG, xine-config, no)
+ AC_MSG_CHECKING([for XINE-LIB version >= $min_xine_version])
+ no_xine=""
+- if test "$XINE_CONFIG" = "no" ; then
++
++ if test "$with_xine" = "no" ; then
+ no_xine=yes
+ else
+ XINE_CFLAGS=`$XINE_CONFIG $xine_config_args --cflags`