summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 16:53:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 16:53:45 +0000
commit0fe65854ea3cb286d05f96a0951d49aa7e054c86 (patch)
tree3db61a187b959fc3f71db743468e739def4ccb4c /net-p2p/gnunet
parentchanged elisp.eclass to elisp-common.eclass as it was before. Thanks to ferd... (diff)
downloadhistorical-0fe65854ea3cb286d05f96a0951d49aa7e054c86.tar.gz
historical-0fe65854ea3cb286d05f96a0951d49aa7e054c86.tar.bz2
historical-0fe65854ea3cb286d05f96a0951d49aa7e054c86.zip
Fix broken autotools handling.
Package-Manager: portage-2.1.2_rc4-r5
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/ChangeLog8
-rw-r--r--net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild25
2 files changed, 20 insertions, 13 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index b5fb82b53aa7..4932c4b9a459 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/gnunet
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.48 2006/11/23 17:30:57 vivo Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.49 2007/01/04 16:48:57 flameeyes Exp $
+
+ 04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ gnunet-0.7.0d-r1.ebuild:
+ Fix broken autotools handling.
23 Nov 2006; Francesco Riosa <vivo@gentoo.org> gnunet-0.6.2b.ebuild,
gnunet-0.7.0d-r1.ebuild:
diff --git a/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild b/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild
index 821fa6a72bef..9616d555429c 100644
--- a/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild
+++ b/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild,v 1.4 2006/11/23 17:30:57 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild,v 1.5 2007/01/04 16:48:57 flameeyes Exp $
-inherit eutils libtool
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
S="${WORKDIR}/GNUnet-${PV}"
DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
@@ -49,18 +52,18 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-nulludp.patch
- # make mysql default sqstore if we do not compile sql support
+ # make mysql default sqstore if we do not compile sql support
# (bug #107330)
! use sqlite && \
sed -i 's:default "sqstore_sqlite":default "sqstore_mysql":' \
contrib/config-daemon.in
- # we do not want to built gtk support with USE=-gtk
+ # we do not want to built gtk support with USE=-gtk
if ! use gtk ; then
sed -i "s:AC_DEFINE_UNQUOTED..HAVE_GTK.*:true:" configure.ac
- autoconf || die "autoconf failed"
- libtoolize --copy --force
fi
+
+ AT_M4DIR="${S}/m4" eautoreconf
}
src_compile() {
@@ -107,10 +110,10 @@ pkg_postinst() {
use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bugs"
einfo
einfo "To configure"
- einfo " 1) Add user(s) to the gnunet group"
- einfo " 2) Run 'gnunet-setup' to generate your client config file"
- einfo " 3) Run gnunet-setup -d to generate a server config file"
- einfo " 4) Optionally copy the .gnunet/gnunetd.conf into /etc and"
+ einfo " 1) Add user(s) to the gnunet group"
+ einfo " 2) Run 'gnunet-setup' to generate your client config file"
+ einfo " 3) Run gnunet-setup -d to generate a server config file"
+ einfo " 4) Optionally copy the .gnunet/gnunetd.conf into /etc and"
einfo "\tuse as a global server config file:"
einfo "$ gnunet-setup -d"
einfo "# cp ~/.gnunet/gnunetd.conf /etc/"