summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-12-30 02:02:47 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-12-30 02:02:47 +0000
commit493cb35ce87762e215486ba8db10a97e26e74774 (patch)
tree4e467a68b90556148a2f13a9da6860bf13d3f652 /net-p2p/kmldonkey/kmldonkey-2.0.2-r2.ebuild
parentRestricting the version of the app-text/poppler dependency due to API changes... (diff)
downloadhistorical-493cb35ce87762e215486ba8db10a97e26e74774.tar.gz
historical-493cb35ce87762e215486ba8db10a97e26e74774.tar.bz2
historical-493cb35ce87762e215486ba8db10a97e26e74774.zip
Revision bump, it is based on new silently updated tarball, fixes bugs 310103 and 290448
Package-Manager: portage-2.2.0_alpha10/cvs/Linux x86_64
Diffstat (limited to 'net-p2p/kmldonkey/kmldonkey-2.0.2-r2.ebuild')
-rw-r--r--net-p2p/kmldonkey/kmldonkey-2.0.2-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-p2p/kmldonkey/kmldonkey-2.0.2-r2.ebuild b/net-p2p/kmldonkey/kmldonkey-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..31e1483946e8
--- /dev/null
+++ b/net-p2p/kmldonkey/kmldonkey-2.0.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/kmldonkey/kmldonkey-2.0.2-r2.ebuild,v 1.1 2010/12/30 02:02:46 tampakrap Exp $
+
+EAPI="3"
+
+KDE_PV="4.2.0"
+SLOT="4"
+KDE_LINGUAS="ca cs el es et fr ga gl it nb nl pt ru sv tr uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="Provides integration for the MLDonkey P2P software and KDE 4."
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/stable/${KDE_PV}/src/extragear/${P}-kde${KDE_PV}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug plasma"
+
+RDEPEND="plasma? ( >=kde-base/plasma-workspace-${KDE_MINIMAL} )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S=${WORKDIR}/${P}-kde${KDE_PV}
+
+PATCHES=( "${FILESDIR}/${P}-gcc44.patch" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with plasma Plasma)"
+
+ kde4-base_src_configure
+}