summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-12 20:39:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-12 20:39:09 +0000
commitf602c43f761505f0500be1b2f742c739417206f7 (patch)
tree03b9b208e929c29a6320948ea2eb63c953b630c9 /net-proxy/obfsproxy/obfsproxy-0.1.1.ebuild
parentBeta channel bump. (diff)
downloadhistorical-f602c43f761505f0500be1b2f742c739417206f7.tar.gz
historical-f602c43f761505f0500be1b2f742c739417206f7.tar.bz2
historical-f602c43f761505f0500be1b2f742c739417206f7.zip
Version bump
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'net-proxy/obfsproxy/obfsproxy-0.1.1.ebuild')
-rw-r--r--net-proxy/obfsproxy/obfsproxy-0.1.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-proxy/obfsproxy/obfsproxy-0.1.1.ebuild b/net-proxy/obfsproxy/obfsproxy-0.1.1.ebuild
new file mode 100644
index 000000000000..b7238ba5d03f
--- /dev/null
+++ b/net-proxy/obfsproxy/obfsproxy-0.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/obfsproxy/obfsproxy-0.1.1.ebuild,v 1.1 2012/03/12 20:39:09 blueness Exp $
+
+EAPI="4"
+
+DESCRIPTION="obfsproxy is a tor-compliant pluggable transports proxy"
+HOMEPAGE="https://www.torproject.org/projects/obfsproxy.html.en"
+SRC_URI="https://www.torproject.org/dist/obfsproxy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-2
+ >=net-misc/tor-0.2.3.12_alpha
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README ChangeLog
+ dodoc -r doc/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To run ${PN} with a tor bridge, add the following to your torrc file:"
+ einfo
+ einfo " ORPort 5001"
+ einfo " BridgeRelay 1"
+ einfo " ExitPolicy reject *:*"
+ einfo " ServerTransportPlugin obfs2 exec /usr/bin/${PN} --managed"
+ einfo
+ einfo "Change your ORPort to whatever value you use. When you start tor,"
+ einfo "you should see a message similar to the following in its logs:"
+ einfo
+ einfo " Registered server transport 'obfs2' at '0.0.0.0:33578'"
+ einfo
+ einfo "Note the port number, 33578 in this case, and report it, along with"
+ einfo "your IP address, to your bridge clients."
+ einfo
+ einfo
+ einfo "To run ${PN} with a tor client, add the following to your torrc file:"
+ einfo
+ einfo " SocksPort 5000"
+ einfo " UseBridges 1"
+ einfo " Bridge obfs2 <IP>:<port>"
+ einfo " ClientTransportPlugin obfs2 exec /usr/bin/${PN} --managed"
+ einfo
+ einfo "Change your SocksPort to whatever value you use. Also, replace the"
+ einfo "<IP>:<port> pair with the values you received from the tor obfs bridge."
+ einfo
+}