summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2004-08-18 06:01:39 +0000
committerDoug Goldstein <cardoe@gentoo.org>2004-08-18 06:01:39 +0000
commite6e53808cabc09766eb9467a44fab025a9939ced (patch)
tree6fd396aa81880db12a46dabef60bdef0d9a21143 /net-wireless/ndiswrapper
parentMarked 1.33 stable x86 and version bump, bug# 60664 (diff)
downloadhistorical-e6e53808cabc09766eb9467a44fab025a9939ced.tar.gz
historical-e6e53808cabc09766eb9467a44fab025a9939ced.tar.bz2
historical-e6e53808cabc09766eb9467a44fab025a9939ced.zip
Cleaned up the ebuild to make it more new user friendly.
Corrected a potential problem with 2.4.x kernels
Diffstat (limited to 'net-wireless/ndiswrapper')
-rw-r--r--net-wireless/ndiswrapper/ndiswrapper-0.9.ebuild43
1 files changed, 25 insertions, 18 deletions
diff --git a/net-wireless/ndiswrapper/ndiswrapper-0.9.ebuild b/net-wireless/ndiswrapper/ndiswrapper-0.9.ebuild
index 68724533f8c8..f579ea405720 100644
--- a/net-wireless/ndiswrapper/ndiswrapper-0.9.ebuild
+++ b/net-wireless/ndiswrapper/ndiswrapper-0.9.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ndiswrapper/ndiswrapper-0.9.ebuild,v 1.1 2004/08/16 14:34:21 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ndiswrapper/ndiswrapper-0.9.ebuild,v 1.2 2004/08/18 06:01:39 cardoe Exp $
inherit kernel-mod
-MY_P=${PN}-${PV}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="Wrapper for using Windows drivers for some wireless cards"
HOMEPAGE="http://ndiswrapper.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND=""
+DEPEND="sys-apps/pciutils"
+S=${WORKDIR}/${PN}-${PV}
src_unpack() {
check_KV
@@ -34,16 +33,19 @@ src_unpack() {
src_compile() {
# Unset ARCH for 2.5/2.6 kernel compiles
- unset ARCH
- emake || die
+ if [ ${KV_MINOR} -gt 4 ] ; then
+ unset ARCH
+ fi
+
+ emake || die "Compile Failed!"
}
src_install() {
if [ ${KV_MINOR} -gt 4 ]
then
- KV_OBJ="ko"
+ MOD_SUFFIX="ko"
else
- KV_OBJ="o"
+ MOD_SUFFIX="o"
fi
dosbin ${S}/utils/ndiswrapper
@@ -52,42 +54,47 @@ src_install() {
dodoc ${S}/README ${S}/INSTALL ${S}/AUTHORS ${S}/ChangeLog
insinto /lib/modules/${KV}/misc
- doins ${S}/driver/ndiswrapper.${KV_OBJ}
+ doins ${S}/driver/ndiswrapper.${MOD_SUFFIX}
into /
dosbin ${S}/utils/loadndisdriver
insinto /etc/modules.d
- newins ${FILESDIR}/${PN}-0.9-modules.d ndiswrapper
+ newins ${FILESDIR}/${PN}-${PV}-modules.d ndiswrapper
dodir /etc/ndiswrapper
}
pkg_postinst() {
- einfo "Checking kernel module dependancies"
+ einfo "Checking kernel module dependencies"
test -r "${ROOT}/usr/src/linux/System.map" && \
depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
einfo
einfo "ndiswrapper requires .inf and .sys files from a Windows(tm) driver"
- einfo "to function. Put these somewhere like /usr/local/lib/ndis,"
- einfo "run 'ndiswrapper -i /usr/local/ndis/foo.inf'."
+ einfo "to function. Download these to /root for example, then"
+ einfo "run 'ndiswrapper -i /root/foo.inf'. After that you can delete them."
+ einfo "They will be copied to the proper location."
einfo "One done, please run 'update-modules'."
einfo
einfo "As of release 0.9, you no longer have to call 'loadndiswrapper'"
einfo "explicitly. The module will handle it automatically."
einfo
+ einfo "check http://ndiswrapper.sf.net/supported_chipsets.html for drivers"
+ I=`lspci -n | egrep 'Class (0280|0200):' | cut -d' ' -f4`
+ einfo "Look for the following on that page for your driver:"
+ einfo ${I}
+ einfo
}
pkg_config() {
ewarn "New versions of ndiswrapper do not require you to run config"
- if [ ! -f "/etc/modules.d/ndiswrapper" ]
- then
+ if [ ! -f "/etc/modules.d/ndiswrapper" ] ; then
eerror "/etc/modules.d/ndiswrapper not found. Please re-emerge"
- eerror "${PN} to have this file installed, then re-run this script"
- die "Driver configuration file not found"
+ eerror "${PN} to have this file installed, then re-run this script."
+ die "Driver configuration file not found!"
fi
}