summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-05-21 16:10:44 +0000
committerChuck Short <zul@gentoo.org>2004-05-21 16:10:44 +0000
commitda0a76c9f180e089578327e5ed17ad806610e6fb (patch)
treed1bb4cbd6cb98c86b5f2964d73d6cea0eb053db4 /net-www/awstats
parentFixing BUG #44409 (again). (diff)
downloadhistorical-da0a76c9f180e089578327e5ed17ad806610e6fb.tar.gz
historical-da0a76c9f180e089578327e5ed17ad806610e6fb.tar.bz2
historical-da0a76c9f180e089578327e5ed17ad806610e6fb.zip
New ebuild.
Diffstat (limited to 'net-www/awstats')
-rw-r--r--net-www/awstats/ChangeLog19
-rw-r--r--net-www/awstats/Manifest5
-rw-r--r--net-www/awstats/awstats-6.1.ebuild133
-rw-r--r--net-www/awstats/files/awstats-6.1-r1.diff13
-rw-r--r--net-www/awstats/files/digest-awstats-6.11
-rw-r--r--net-www/awstats/metadata.xml5
6 files changed, 176 insertions, 0 deletions
diff --git a/net-www/awstats/ChangeLog b/net-www/awstats/ChangeLog
new file mode 100644
index 000000000000..294818063f0f
--- /dev/null
+++ b/net-www/awstats/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for net-www/awstats
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/awstats/ChangeLog,v 1.1 2004/05/21 16:10:44 zul Exp $
+
+*awstats-6.1 (22 May 2004)
+
+ 22 May 2004; Chuck Short <zul@gentoo.org> awstats-6.1.ebuild, metadata.xml,
+ files/awstats-6.1-r1.diff:
+ Initial version, ebuild written/modified by the following:
+ Brian Arledge < trogdor45 @ go.com >
+ Daniel Seyffer < gentoo-bugs @ seyffer.com >
+ Federico Moro < zayer @ frikis.org >
+ Markus Luisser < mluisser @ mail.zserv.tuwien.ac.at >
+ Richard Freeman < freemanrich @ yahoo.com >
+ Michael Schmid < meschmid @ gmx.net >
+ Perolo Silantico < per.sil @ gmx.it >
+ and me < zul @ gentoo.org >
+ Finally closes # 19382.
+
diff --git a/net-www/awstats/Manifest b/net-www/awstats/Manifest
new file mode 100644
index 000000000000..21368159a53d
--- /dev/null
+++ b/net-www/awstats/Manifest
@@ -0,0 +1,5 @@
+MD5 430b9583acf9d3cd9b996ae67f29b6ae ChangeLog 771
+MD5 d2da0e45d7e39184d1cb7abbe3879086 metadata.xml 159
+MD5 3423b223217d0f5ab9c2b238a4465ca7 awstats-6.1.ebuild 4034
+MD5 2e2bdf14564309eeb8366a8b6b65b54c files/digest-awstats-6.1 60
+MD5 10127a480be4fd2c2eb40cbe88f10ad0 files/awstats-6.1-r1.diff 564
diff --git a/net-www/awstats/awstats-6.1.ebuild b/net-www/awstats/awstats-6.1.ebuild
new file mode 100644
index 000000000000..311850a2156a
--- /dev/null
+++ b/net-www/awstats/awstats-6.1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/awstats/awstats-6.1.ebuild,v 1.1 2004/05/21 16:10:44 zul Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="AWStats is a short for Advanced Web Statistics."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://awstats.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~arm ~ppc ~hppa ~mips ~sparc ~x86 ~amd64"
+DEPEND=">=dev-lang/perl-5.6.1
+ >=media-libs/libpng-1.2
+ dev-perl/Time-Local
+ net-www/apache"
+RDEPEND=""
+IUSE=""
+
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/awstats-6.1-r1.diff
+ cd ${S}
+
+ # change AWStats default installation directory to installation directory of Gentoo
+ for file in tools/* wwwroot/cgi-bin/*; do
+ if [ -f "$file" ]; then
+ /bin/sed -i -e "s#/usr/local/awstats/wwwroot/cgi-bin#${MY_CGIBINDIR}#g" \
+ -e "s#/usr/local/awstats/wwwroot/icon#${MY_HTDOCSDIR}/icon#g" \
+ -e "s#/usr/local/awstats/wwwroot/plugins#${MY_HOSTROOTDIR}/plugins#g" \
+ -e "s#/usr/local/awstats/wwwroot/classes#${MY_HTDOCSDIR}/classes#g" \
+ -e "s#/usr/local/awstats/wwwroot#${MY_HTDOCSDIR}#g" \
+ $file
+ fi
+ done
+
+ # rename http-conf example file
+ mv tools/httpd_conf tools/httpd_conf.example
+
+ # Remove .cvs* files and CVS directories
+ find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+
+ # set default values for directories
+ /bin/sed -i -e "s#LogFile=.*#LogFile=\"/var/log/apache${APACHEVER}/access_log\"#" \
+ -e "s#SiteDomain=.*#SiteDomain=\"localhost\"#" \
+ -e "s#DirIcons=.*#DirIcons=\"/awstats/icons\"#" \
+ -e "s#DirCgi=.*#DirCgi=\"/cgi-bin/awstats\"#" \
+ -e "s#DataDir=.*#DataDir=\"${MY_HOSTROOTDIR}/awstats/datadir\"#" \
+ ${S}/wwwroot/cgi-bin/awstats.model.conf
+
+}
+
+
+
+src_install() {
+ webapp_src_preinst
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dohtml -r docs/*.html docs/*.xml docs/*.css docs/*.js docs/images
+ dodoc README.TXT docs/COPYING.TXT docs/LICENSE.TXT
+ newdoc wwwroot/cgi-bin/plugins/example/example.pm example_plugin.pm
+ docinto xslt
+ dodoc tools/xslt/*
+
+
+ # copy example http.conf installation file
+ webapp_postinst_txt en tools/httpd_conf.example
+
+ # Copy the app's main files
+ exeinto ${MY_CGIBINDIR}
+ doexe wwwroot/cgi-bin/*.pl
+
+ exeinto ${MY_HTDOCSDIR}/classes
+ doexe wwwroot/classes/*.jar
+
+ # install language files, libraries and plugins
+ mkdir -p ${D}${MY_CGIBINDIR}
+ for dir in lang lib plugins; do
+ /bin/cp -R ${S}/wwwroot/cgi-bin/${dir} ${D}${MY_CGIBINDIR}
+ chmod 0644 ${D}${MY_CGIBINDIR}/${dir}
+ done
+
+ # install the app's www files
+ mkdir -p ${D}${MY_HTDOCSDIR}
+ for dir in icon css js; do
+ /bin/cp -R ${S}/wwwroot/${dir} ${D}${MY_HTDOCSDIR}
+ chmod 0644 ${D}${MY_HTDOCSDIR}/${dir}
+ done
+
+ # copy configuration file
+ mkdir -p ${D}/etc/awstats
+ cp ${S}/wwwroot/cgi-bin/awstats.model.conf ${D}/etc/awstats/awstats.model.conf
+
+
+ # add the post-installation instructions
+ #webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+
+ # create the data directory for awstats
+ mkdir -p ${D}/${MY_HOSTROOTDIR}/datadir
+
+
+ # install command line tools
+ dobin tools/awstats_buildstaticpages.pl tools/awstats_exportlib.pl tools/awstats_updateall.pl tools/logresolvemerge.pl \
+ tools/maillogconvert.pl
+ newbin tools/urlaliasbuilder.pl awstats_urlaliasbuilder.pl
+ newbin tools/configure.pl awstats_configure.pl
+
+ # all done
+ #
+ # now we let the eclass strut its stuff ;-)
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The AWStats-Manual is available either inside"
+ einfo " the /usr/share/doc/${PF} - folder, or at"
+ einfo " http://awstats.sourceforge.net/docs/index.html ."
+ einfo
+ ewarn "Copy the /etc/awstats/awstats.model.conf to"
+ ewarn "/etc/awstats/awstats.<yourdomain>.conf and edit."
+ ewarn "use the command"
+ ewarn " webapp-config"
+ ewarn "to install awstats for each virtual host. See propert man page."
+}
+
diff --git a/net-www/awstats/files/awstats-6.1-r1.diff b/net-www/awstats/files/awstats-6.1-r1.diff
new file mode 100644
index 000000000000..86ca805fb66f
--- /dev/null
+++ b/net-www/awstats/files/awstats-6.1-r1.diff
@@ -0,0 +1,13 @@
+--- awstats-6.1.orig/tools/configure.pl.orig 2004-05-18 14:17:42.000000000 +0200
++++ awstats-6.1/tools/configure.pl 2004-05-18 14:19:29.000000000 +0200
+@@ -645,8 +645,8 @@
+ # ----------------------------------
+ if ($WebServerChanged) {
+ if ($OS eq 'linux') {
+- print "\n-----> Restart Web server with '/sbin/service httpd restart'\n";
+- my $ret=`/sbin/service httpd restart`;
++ print "\n-----> Restart Web server graceful with '/usr/sbin/apache2ctl graceful'\n";
++ my $ret=`/usr/sbin/apache2ctl graceful`;
+ print "$ret";
+ }
+ elsif ($OS eq 'macosx') {
diff --git a/net-www/awstats/files/digest-awstats-6.1 b/net-www/awstats/files/digest-awstats-6.1
new file mode 100644
index 000000000000..b93ff526b06c
--- /dev/null
+++ b/net-www/awstats/files/digest-awstats-6.1
@@ -0,0 +1 @@
+MD5 4f02c0fc4f1a0f946fcae3b3768bf113 awstats-6.1.tgz 800275
diff --git a/net-www/awstats/metadata.xml b/net-www/awstats/metadata.xml
new file mode 100644
index 000000000000..c054a8cd9b61
--- /dev/null
+++ b/net-www/awstats/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>apache</herd>
+</pkgmetadata>