summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-01-14 16:43:50 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-01-14 16:43:50 +0000
commitadc453417bd710664f1e21e43f15790c85ae3d3a (patch)
tree2bc373d7010c4d07286b229f8cf176891b91454f /net-www/mod_ftpd
parentMake this installable with sun-jdk-1.6. (diff)
downloadhistorical-adc453417bd710664f1e21e43f15790c85ae3d3a.tar.gz
historical-adc453417bd710664f1e21e43f15790c85ae3d3a.tar.bz2
historical-adc453417bd710664f1e21e43f15790c85ae3d3a.zip
Cleanup.
Package-Manager: portage-2.1.2_rc4-r8
Diffstat (limited to 'net-www/mod_ftpd')
-rw-r--r--net-www/mod_ftpd/ChangeLog9
-rw-r--r--net-www/mod_ftpd/mod_ftpd-0.13.0.ebuild23
2 files changed, 20 insertions, 12 deletions
diff --git a/net-www/mod_ftpd/ChangeLog b/net-www/mod_ftpd/ChangeLog
index c91d2bebff1b..f4fa79d6ce44 100644
--- a/net-www/mod_ftpd/ChangeLog
+++ b/net-www/mod_ftpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ftpd
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.9 2006/06/04 19:43:20 vericgar Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.10 2007/01/14 16:43:50 chtekk Exp $
+
+ 14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
+ -files/0.12.3-mod_ftpd-ipv6.patch, -files/mod_ftpd.conf,
+ mod_ftpd-0.13.0.ebuild:
+ Cleanup, fix deps.
04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
-mod_ftpd-0.12.3.ebuild:
diff --git a/net-www/mod_ftpd/mod_ftpd-0.13.0.ebuild b/net-www/mod_ftpd/mod_ftpd-0.13.0.ebuild
index 4c8f8c823e3a..1992e24009eb 100644
--- a/net-www/mod_ftpd/mod_ftpd-0.13.0.ebuild
+++ b/net-www/mod_ftpd/mod_ftpd-0.13.0.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/mod_ftpd-0.13.0.ebuild,v 1.5 2006/06/04 18:28:05 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/mod_ftpd-0.13.0.ebuild,v 1.6 2007/01/14 16:43:50 chtekk Exp $
-inherit eutils apache-module
+inherit apache-module
-DESCRIPTION="Apache2 protocol module which provides an FTP server"
+KEYWORDS="~ppc x86"
+
+DESCRIPTION="Apache2 module which provides an FTP server."
HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_ftpd/"
SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
-
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~ppc x86"
IUSE="dbi gdbm"
-DEPEND="gdbm? ( >=sys-libs/gdbm-1.8.0-r5 )"
+DEPEND="dbi? ( dev-db/libdbi )
+ gdbm? ( sys-libs/gdbm )"
RDEPEND="${DEPEND}"
APACHE2_EXECFILES="providers/*/.libs/*.so"
@@ -27,10 +28,12 @@ need_apache2
src_compile() {
local providers="default fail"
- use gdbm && providers="dbm ${providers}"
use dbi && providers="dbi ${providers}"
+ use gdbm && providers="dbm ${providers}"
- econf --with-apxs=${APXS2} \
- --enable-providers="${providers}" || die "econf failed"
+ econf \
+ --with-apxs=${APXS2} \
+ --enable-providers="${providers}" \
+ || die "econf failed"
emake || die "emake failed"
}