summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-01-22 04:12:47 +0000
committerChristian Parpart <trapni@gentoo.org>2005-01-22 04:12:47 +0000
commit78e286ad0207e75f8ac24cf0aa88b7ead3343290 (patch)
treeffd50d35d75f8ff1ee6e4655c26ac53a84c9b35c /net-www
parentAdded license needed by net-dialup/intel536ep. (diff)
downloadhistorical-78e286ad0207e75f8ac24cf0aa88b7ead3343290.tar.gz
historical-78e286ad0207e75f8ac24cf0aa88b7ead3343290.tar.bz2
historical-78e286ad0207e75f8ac24cf0aa88b7ead3343290.zip
apache herd package refresh
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_auth_mysql/Manifest13
-rw-r--r--net-www/mod_auth_mysql/files/2.8.1/12_mod_auth_mysql.conf129
-rw-r--r--net-www/mod_auth_mysql/files/digest-mod_auth_mysql-2.8.11
-rw-r--r--net-www/mod_auth_mysql/metadata.xml6
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild34
5 files changed, 175 insertions, 8 deletions
diff --git a/net-www/mod_auth_mysql/Manifest b/net-www/mod_auth_mysql/Manifest
index b866ceba4d00..cad5dec943ee 100644
--- a/net-www/mod_auth_mysql/Manifest
+++ b/net-www/mod_auth_mysql/Manifest
@@ -1,12 +1,15 @@
-MD5 178fcb7bd8d5bc79ea2875b655e709af mod_auth_mysql-20030510.ebuild 1152
-MD5 f59952b5c5b142b7dffbbdae45755494 mod_auth_mysql-20030510-r1.ebuild 1418
+MD5 04530b903758dae92712ffeee9e117b9 ChangeLog 1804
+MD5 0d18f0fe5d603b41b988373892caf195 metadata.xml 226
MD5 2b4fe18334264a0b6c7149e2a4b1ef29 mod_auth_mysql-1.11.ebuild 937
+MD5 f59952b5c5b142b7dffbbdae45755494 mod_auth_mysql-20030510-r1.ebuild 1418
MD5 a8002f702a1d8837523cde3cc9a076d7 mod_auth_mysql-20030510-r2.ebuild 1502
-MD5 04530b903758dae92712ffeee9e117b9 ChangeLog 1804
-MD5 5b6dd438f81019e56fa641841c0c13fe metadata.xml 501
+MD5 178fcb7bd8d5bc79ea2875b655e709af mod_auth_mysql-20030510.ebuild 1152
+MD5 4076be0aa9f53b1d5027d16662f21309 mod_auth_mysql-2.8.1.ebuild 955
MD5 01cc878ba30a6e2ad327de787e21a999 files/12_mod_auth_mysql.conf 3571
MD5 3513e598048c0060eb3758c19c4e4c60 files/digest-mod_auth_mysql-1.11 77
+MD5 a9f56734948e06d5ed5f4b7eea9f6cd5 files/digest-mod_auth_mysql-20030510 61
MD5 a9f56734948e06d5ed5f4b7eea9f6cd5 files/digest-mod_auth_mysql-20030510-r1 61
MD5 a9f56734948e06d5ed5f4b7eea9f6cd5 files/digest-mod_auth_mysql-20030510-r2 61
MD5 dd4f31c36839f4faadcf855915e348c3 files/mod_auth_mysql.patch 357
-MD5 a9f56734948e06d5ed5f4b7eea9f6cd5 files/digest-mod_auth_mysql-20030510 61
+MD5 a6cfd8f7d972e23afa55e33bb478e1bc files/digest-mod_auth_mysql-2.8.1 71
+MD5 d6baa28feeb088701ed677185d61b93d files/2.8.1/12_mod_auth_mysql.conf 3566
diff --git a/net-www/mod_auth_mysql/files/2.8.1/12_mod_auth_mysql.conf b/net-www/mod_auth_mysql/files/2.8.1/12_mod_auth_mysql.conf
new file mode 100644
index 000000000000..cd3007e46121
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/2.8.1/12_mod_auth_mysql.conf
@@ -0,0 +1,129 @@
+<IfDefine AUTH_MYSQL>
+ <IfModule !mod_auth_mysql.c>
+ LoadModule mysql_auth_module modules/mod_auth_mysql.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_auth_mysql.c>
+
+#
+# mod_auth_mysql can be used to limit access to documents by checking
+# data in a MySQL database.
+#
+
+# This will enable user-based MySQL authentication of everything
+# within /home/httpd. You'll need to do the following as the MySQL
+# root user beforehand:
+#
+# CREATE DATABASE auth;
+# USE auth;
+# CREATE TABLE users (
+# user_name CHAR(30) NOT NULL,
+# user_passwd CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name)
+# );
+# GRANT SELECT
+# ON auth.users
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+#
+# INSERT INTO users VALUES ('testuser', ENCRYPT('testpass'));
+#
+#<Directory /home/httpd>
+# AuthName "MySQL authenticated zone"
+# AuthType Basic
+#
+# AuthMySQLUser authuser
+# AuthMySQLPassword PaSsW0Rd
+# AuthMySQLDB auth
+# AuthMySQLUserTable users
+# AuthMySQLNameField user_name
+# AuthMySQLPasswordField user_passwd
+#
+# require valid-user
+#</Directory>
+
+# This will enable group-based MySQL authentication of everything
+# within /home/httpd. You'll need to do the following as the MySQL
+# root user beforehand:
+#
+# CREATE DATABASE auth;
+# USE auth;
+# CREATE TABLE users (
+# user_name CHAR(30) NOT NULL,
+# user_passwd CHAR(20) NOT NULL,
+# user_group CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name)
+# );
+# GRANT SELECT
+# ON auth.users
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+#
+# INSERT INTO users VALUES ('testuser', ENCRYPT('testpass'), 'user');
+# INSERT INTO users VALUES ('testadmin', ENCRYPT('testpass'), 'admin');
+#
+#<Directory /home/httpd>
+# AuthName "MySQL group authenticated zone"
+# AuthType Basic
+#
+# AuthMySQLUser authuser
+# AuthMySQLPassword PaSsW0Rd
+# AuthMySQLDB auth
+# AuthMySQLUserTable users
+# AuthMySQLNameField user_name
+# AuthMySQLPasswordField user_passwd
+# AuthMySQLGroupField user_group
+#
+# require group admin
+#</Directory>
+
+# Like the above this enables group-based MySQL authentication of
+# everything within /home/httpd, but this configuration allows users to
+# belong to more than one group. You'll need to do the following as
+# the MySQL root user beforehand:
+#
+# CREATE DATABASE auth;
+# USE auth;
+# CREATE TABLE users (
+# user_name CHAR(30) NOT NULL,
+# user_passwd CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name)
+# );
+# CREATE TABLE groups (
+# user_name CHAR(30) NOT NULL,
+# user_group CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name, user_group)
+# );
+# GRANT SELECT
+# ON auth.users
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+# GRANT SELECT
+# ON auth.groups
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+#
+# INSERT INTO users VALUES ('testuser', ENCRYPT('testpass'));
+# INSERT INTO groups VALUES ('testuser', 'user');
+# INSERT INTO users VALUES ('testadmin', ENCRYPT('testpass'));
+# INSERT INTO groups VALUES ('testadmin', 'admin');
+# INSERT INTO groups VALUES ('testadmin', 'user');
+#
+#<Directory /home/httpd>
+# AuthName "MySQL group authenticated zone"
+# AuthType Basic
+#
+# AuthMySQLUser authuser
+# AuthMySQLPassword PaSsW0Rd
+# AuthMySQLDB auth
+# AuthMySQLUserTable users
+# AuthMySQLNameField user_name
+# AuthMySQLPasswordField user_passwd
+# AuthMySQLGroupTable groups
+# AuthMySQLGroupField user_group
+#
+# require group user
+#</Directory>
+
+</IfModule>
diff --git a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-2.8.1 b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-2.8.1
new file mode 100644
index 000000000000..8c4387518097
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-2.8.1
@@ -0,0 +1 @@
+MD5 2f1cc1d12183c6836c6110462d28802e mod_auth_mysql-2.8.1.tar.gz 16307
diff --git a/net-www/mod_auth_mysql/metadata.xml b/net-www/mod_auth_mysql/metadata.xml
index bcaabdbbd0d3..10510cb8be95 100644
--- a/net-www/mod_auth_mysql/metadata.xml
+++ b/net-www/mod_auth_mysql/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>apache</herd>
-<longdescription>
-The Apache HTTP Server Project is an effort to develop and maintain an open-source HTTP server for modern operating systems including UNIX and Windows NT. The goal of this project is to provide a secure, efficient and extensible server that provides HTTP services in sync with the current HTTP standards.
-</longdescription>
+<maintainer>
+ <email>apache-devs@gentoo.org</email>
+</maintainer>
</pkgmetadata>
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild
new file mode 100644
index 000000000000..8a5c081d67a4
--- /dev/null
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild,v 1.1 2005/01/22 04:12:46 trapni Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database"
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/modauthmysql/${P}.tar.gz"
+DEPEND="dev-db/mysql"
+RDEPEND=""
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+SLOT="0"
+
+BASE_CONFIG_PVR="2.8.1"
+
+# Dual Apache
+DOCFILES="README"
+
+# Apache 2.0
+APXS2_S="${S}"
+APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE2_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE2_MOD_DEFINE="AUTH_MYSQL"
+
+# Apache 1.x
+APXS1_S="${S}"
+APXS1_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE1_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE1_MOD_DEFINE="AUTH_MYSQL"
+
+need_apache