summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2006-10-03 13:20:27 +0000
committerJim Ramsay <lack@gentoo.org>2006-10-03 13:20:27 +0000
commit98cfb5ca7615656c7b7437e4ab9e67b78f72ccee (patch)
treebf6b7e196d0741f14755dab3fcbc8b817582efba /rox-base/volume
parentMake sure the file is there so we don't break current stable. (diff)
downloadhistorical-98cfb5ca7615656c7b7437e4ab9e67b78f72ccee.tar.gz
historical-98cfb5ca7615656c7b7437e4ab9e67b78f72ccee.tar.bz2
historical-98cfb5ca7615656c7b7437e4ab9e67b78f72ccee.zip
Version bump to 009, imported from breakmygentoo.net (Thanks Peter Hyman!). Also accepting maintainer role and added a patch that fixes the list of soundcard channels for some cards (including SB Live).
Package-Manager: portage-2.1.2_pre1-r3
Diffstat (limited to 'rox-base/volume')
-rw-r--r--rox-base/volume/ChangeLog14
-rw-r--r--rox-base/volume/files/digest-volume-0093
-rw-r--r--rox-base/volume/files/volume-009-no_channels.patch14
-rw-r--r--rox-base/volume/metadata.xml6
-rw-r--r--rox-base/volume/volume-009.ebuild28
5 files changed, 63 insertions, 2 deletions
diff --git a/rox-base/volume/ChangeLog b/rox-base/volume/ChangeLog
index 28e94c70e848..00ee9d7ae78d 100644
--- a/rox-base/volume/ChangeLog
+++ b/rox-base/volume/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for rox-base/volume
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/volume/ChangeLog,v 1.4 2006/05/23 20:17:14 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/volume/ChangeLog,v 1.5 2006/10/03 13:20:27 lack Exp $
+
+ 03 Oct 2006; <lack@gentoo.org> +files/volume-009-no_channels.patch,
+ metadata.xml, -volume-007.ebuild, +volume-009.ebuild:
+ Added patch for soundcards which only display a small number of available
+ channels. (Patch sent upstream)
+
+*volume-009 (01 Oct 2006)
+
+ 01 Oct 2006; <lack@gentoo.org> metadata.xml, -volume-007.ebuild,
+ +volume-009.ebuild:
+ Version bump to 009 (imported from breakmygentoo.net, big thanks to Peter
+ Hyman)
23 May 2006; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove svyatogor from metadata, bug 131936.
diff --git a/rox-base/volume/files/digest-volume-009 b/rox-base/volume/files/digest-volume-009
new file mode 100644
index 000000000000..0ce2eb6593c8
--- /dev/null
+++ b/rox-base/volume/files/digest-volume-009
@@ -0,0 +1,3 @@
+MD5 eed8ff91b3a1dd1bbe37c6e1963ff141 Volume-009.tgz 29064
+RMD160 713011f40738fe20ddc885799d4fb119ac241897 Volume-009.tgz 29064
+SHA256 97c17b383594061043ff84a31de229a46e0ee9ff79e3a3a9bc600bd7ade4a233 Volume-009.tgz 29064
diff --git a/rox-base/volume/files/volume-009-no_channels.patch b/rox-base/volume/files/volume-009-no_channels.patch
new file mode 100644
index 000000000000..608ade2e2156
--- /dev/null
+++ b/rox-base/volume/files/volume-009-no_channels.patch
@@ -0,0 +1,14 @@
+--- Volume/mixer.py.orig 2006-10-02 17:52:17.000000000 -0600
++++ Volume/mixer.py 2006-10-02 17:51:53.000000000 -0600
+@@ -51,7 +51,10 @@
+ id = 0
+ while (channel,id) in ALSA_CHANNELS:
+ id += 1
+- mixer = alsaaudio.Mixer(channel, id, MIXER_DEVICE.value)
++ try:
++ mixer = alsaaudio.Mixer(channel, id, MIXER_DEVICE.value)
++ except alsaaudio.ALSAAudioError:
++ continue
+ if len(mixer.volumecap()):
+ ALSA_CHANNELS.append((channel,id))
+ except:
diff --git a/rox-base/volume/metadata.xml b/rox-base/volume/metadata.xml
index 20ce219711a2..e8761671e3a5 100644
--- a/rox-base/volume/metadata.xml
+++ b/rox-base/volume/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
</pkgmetadata>
diff --git a/rox-base/volume/volume-009.ebuild b/rox-base/volume/volume-009.ebuild
new file mode 100644
index 000000000000..8f2dd0349f0d
--- /dev/null
+++ b/rox-base/volume/volume-009.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/volume/volume-009.ebuild,v 1.1 2006/10/03 13:20:27 lack Exp $
+
+inherit rox eutils
+
+MY_PN="Volume"
+DESCRIPTION="Volume is a ROX Panel Applet that puts a popup volume control in your panel."
+HOMEPAGE="http://www.hayber.us/rox/Volume"
+SRC_URI="http://www.hayber.us/rox/applets/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pyalsaaudio-0.2"
+
+ROX_VER=2.1.0
+ROX_LIB_VER=2.0.0
+APPNAME=${MY_PN}
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-no_channels.patch
+}