summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2006-01-16 06:28:53 +0000
committerDaniel Goller <morfic@gentoo.org>2006-01-16 06:28:53 +0000
commit2f9ab74a2018a530d34eb45d4d292a941fceb25c (patch)
tree17ec3952b606830df141425a13056862ab95bb3d /sci-astronomy
parentWhitespace fix (diff)
downloadhistorical-2f9ab74a2018a530d34eb45d4d292a941fceb25c.tar.gz
historical-2f9ab74a2018a530d34eb45d4d292a941fceb25c.tar.bz2
historical-2f9ab74a2018a530d34eb45d4d292a941fceb25c.zip
Revision Bump
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog10
-rw-r--r--sci-astronomy/celestia/Manifest12
-rw-r--r--sci-astronomy/celestia/celestia-1.4.0.ebuild96
-rw-r--r--sci-astronomy/celestia/files/digest-celestia-1.4.01
4 files changed, 112 insertions, 7 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 7d217a02293d..4d684ab0ab2b 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/celestia
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.4 2005/09/03 22:46:31 eradicator Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.5 2006/01/16 06:28:52 morfic Exp $
+
+*celestia-1.4.0 (16 Jan 2006)
+
+ 16 Jan 2006; Daniel Goller <morfic@gentoo.org> +celestia-1.4.0.ebuild:
+ Revision Bump thanks to Pat Suwalski, Sebastian Fabbro, and everyone helping
+ out on Bug #116600
03 Sep 2005; Jeremy Huddleston <eradicator@gentoo.org>
celestia-1.3.2.ebuild:
diff --git a/sci-astronomy/celestia/Manifest b/sci-astronomy/celestia/Manifest
index afaed9b3402e..a574aded97da 100644
--- a/sci-astronomy/celestia/Manifest
+++ b/sci-astronomy/celestia/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 87233acdbef08c144d95e7dad998d42c ChangeLog 6039
+MD5 cda5aa7a3d316dcd097372f89f5f9a98 ChangeLog 6240
MD5 6be90f964bc6ca0195b0623338dfd1f0 celestia-1.3.2.ebuild 3063
-MD5 1b55bd73a1313e288a88762af6cd0fb7 metadata.xml 330
+MD5 9dcefda20a1a4abb32dd286e45ceb014 celestia-1.4.0.ebuild 2618
MD5 f659f2616eeaaa4d3b6422e586d2bfa2 files/celestia-1.3.2-noarts.patch 3566
MD5 d4ff8e51fb3a546279e7442cf24e07d7 files/digest-celestia-1.3.2 68
+MD5 8e1dfea9c274b2242b921a467ec1d54b files/digest-celestia-1.4.0 68
MD5 f96a6eb019a59bf1a643b96c43657af8 files/resmanager.h.patch 893
+MD5 1b55bd73a1313e288a88762af6cd0fb7 metadata.xml 330
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDGifTArHZZzCEUG0RAvRCAJ44rtFeFWYb5vm1aTW4MLvPVEwNdwCfULMt
-cU93T9mK/8nRoveNQCMwBhU=
-=fqe6
+iD8DBQFDyz09/aM9DdBw91cRAl3JAJ9U5dclBtExMzRC+tiocKpgTrlNAgCeMdNj
+naHqno0MtGA8HCCdkMZUzQE=
+=OgKn
-----END PGP SIGNATURE-----
diff --git a/sci-astronomy/celestia/celestia-1.4.0.ebuild b/sci-astronomy/celestia/celestia-1.4.0.ebuild
new file mode 100644
index 000000000000..64ea3c8fb6c9
--- /dev/null
+++ b/sci-astronomy/celestia/celestia-1.4.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.1 2006/01/16 06:28:52 morfic Exp $
+
+inherit eutils flag-o-matic gnome2 kde-functions
+
+DESCRIPTION="Free space simulation that lets you experience our universe in three dimensions"
+HOMEPAGE="http://www.shatters.net/celestia/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome gtk kde arts threads nls lua"
+
+DEPEND="virtual/glu
+ media-libs/jpeg
+ media-libs/libpng
+ gtk? ( !gnome? ( !kde? (
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0
+ ) ) )
+ gnome? ( !kde? (
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0
+ >=gnome-base/libgnomeui-2.0
+ ) )
+ kde? ( !gnome ( >=kde-base/kdelibs-3.0.5 ) )
+ !gtk? ( !gnome? ( !kde? ( virtual/glut ) ) )
+ arts? ( kde-base/arts )
+ lua? ( >=dev-lang/lua-5.0 )"
+
+pkg_setup() {
+ # Check for one for the following use flags to be set.
+ if ! use gnome && use kde; then
+ einfo "USE=\"kde\" detected."
+ mygui="kde"
+ elif ! use kde && use gnome; then
+ einfo "USE=\"gnome\" detected."
+ USE_DESTDIR="1"
+ mygui="gnome"
+ elif ! use kde && ! use gnome && use gtk; then
+ einfo "USE=\"gtk\" detected."
+ mygui="gtk"
+ elif use kde && use gnome; then
+ einfo "Both gnome and kde support requested. Defaulting to gtk"
+ mygui="gtk"
+ else
+ ewarn "If you want to use the full gui, set USE=\"{kde/gnome/gtk}\""
+ ewarn "Defaulting to glut support (no GUI)."
+ mygui="glut"
+ fi
+
+ einfo "If you experience problems building celestia with nvidia drivers,"
+ einfo "you can try:"
+ einfo "eselect opengl set xorg-x11"
+ einfo "emerge celestia"
+ einfo "eselect opengl set nvidia"
+}
+
+src_compile() {
+ filter-flags "-funroll-loops -frerun-loop-opt"
+ addwrite ${QTDIR}/etc/settings
+
+ # remove manual installation in /usr/share/${PN}/manual
+ # replaced with dohtml in src_install
+ sed -i -e "s:manual::g" Makefile.in
+
+ if [ "${mygui}" = "kde" ]; then
+ set-kdedir 3
+ set-qtdir 3
+ export kde_widgetdir="$KDEDIR/lib/kde3/plugins/designer"
+ fi
+
+ econf \
+ --with-${mygui} \
+ $(use_with arts) \
+ $(use_with lua) \
+ $(use_enable threads threading) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ if [ "${mygui}" = "gnome" ]; then
+ gnome2_src_install
+ else
+ make install DESTDIR="${D}" \
+ || die "make install failed"
+ fi
+
+ dodoc AUTHORS README TODO NEWS TRANSLATORS ChangeLog \
+ CelestiaKeyAssignments.txt KbdMouseJoyControls.txt devguide.txt
+ dohtml coding-standards.html manual/*.html manual/*.css
+}
diff --git a/sci-astronomy/celestia/files/digest-celestia-1.4.0 b/sci-astronomy/celestia/files/digest-celestia-1.4.0
new file mode 100644
index 000000000000..7b0b11dcac87
--- /dev/null
+++ b/sci-astronomy/celestia/files/digest-celestia-1.4.0
@@ -0,0 +1 @@
+MD5 d4bd0029af87fdd9cb4a0828cf62a025 celestia-1.4.0.tar.gz 25044420