summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-07-07 23:09:24 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-07-07 23:09:24 +0000
commit8c2897fcb79c8393dc536bb3bae5bedf7bd24bd4 (patch)
tree6895f41df1c7b2c2bda0660c09823f4947f42f45 /sci-biology/allpaths/allpaths-2.0.ebuild
parentNew license Whitehead-MIT for sci-biology packages (diff)
downloadhistorical-8c2897fcb79c8393dc536bb3bae5bedf7bd24bd4.tar.gz
historical-8c2897fcb79c8393dc536bb3bae5bedf7bd24bd4.tar.bz2
historical-8c2897fcb79c8393dc536bb3bae5bedf7bd24bd4.zip
New package, ebuild written by me
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/allpaths/allpaths-2.0.ebuild')
-rw-r--r--sci-biology/allpaths/allpaths-2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/allpaths/allpaths-2.0.ebuild b/sci-biology/allpaths/allpaths-2.0.ebuild
new file mode 100644
index 000000000000..c6da62f0c1eb
--- /dev/null
+++ b/sci-biology/allpaths/allpaths-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/allpaths/allpaths-2.0.ebuild,v 1.1 2009/07/07 23:09:24 weaver Exp $
+
+EAPI="2"
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broad.mit.edu/pub/crd/ALLPATHS/Release-2-0/allpaths-2.0.tar.gz
+ ftp://ftp.broad.mit.edu/pub/crd/ALLPATHS/Release-2-0/allpaths-2.0.manual.docx"
+
+LICENSE="Whitehead-MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# TODO: info message on failure instructing to run gcc-config
+DEPEND=">=sys-devel/gcc-4.3.2"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ rm -f libxerces* || die
+}
+
+src_install() {
+ rm -rf bin/auxfiles
+ dobin bin/* || die
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}/${P}.manual.docx"
+}