summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-07 07:52:29 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-07 07:52:29 +0000
commit8f51f8b71c4cebc3302746788ba408e79d7531ec (patch)
treec9ae8728a5a1060bc65b8d8e899fda9cc7a0bd75 /sci-chemistry/PyMca
parentUpdate HOMEPAGE. (diff)
downloadhistorical-8f51f8b71c4cebc3302746788ba408e79d7531ec.tar.gz
historical-8f51f8b71c4cebc3302746788ba408e79d7531ec.tar.bz2
historical-8f51f8b71c4cebc3302746788ba408e79d7531ec.zip
Initial commit, prelimary ebuild made by Nicola
Package-Manager: portage-2.2.0_alpha7/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/PyMca')
-rw-r--r--sci-chemistry/PyMca/ChangeLog10
-rw-r--r--sci-chemistry/PyMca/Manifest15
-rw-r--r--sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild41
-rw-r--r--sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch40
-rw-r--r--sci-chemistry/PyMca/metadata.xml19
5 files changed, 125 insertions, 0 deletions
diff --git a/sci-chemistry/PyMca/ChangeLog b/sci-chemistry/PyMca/ChangeLog
new file mode 100644
index 000000000000..47a3afd6317a
--- /dev/null
+++ b/sci-chemistry/PyMca/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/PyMca
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/ChangeLog,v 1.1 2010/12/07 07:52:29 jlec Exp $
+
+*PyMca-4.4.1_p1 (07 Dec 2010)
+
+ 07 Dec 2010; Justin Lecher <jlec@gentoo.org> +files/4.4.1_p1-gentoo.patch,
+ +PyMca-4.4.1_p1.ebuild, +metadata.xml:
+ Initial commit, prelimary ebuild made by Nicola
+
diff --git a/sci-chemistry/PyMca/Manifest b/sci-chemistry/PyMca/Manifest
new file mode 100644
index 000000000000..154efffeed7f
--- /dev/null
+++ b/sci-chemistry/PyMca/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 4.4.1_p1-gentoo.patch 1127 RMD160 1862f954fd384404296e057579b4cd4952ad41ef SHA1 852815aefd3e06746d2fac704bce42e240dfdfc0 SHA256 7b4dac4e2cbfb372b4990c5c6cd154a303f72371f03e196c8cbb29b963bfe48a
+DIST pymca4.4.1p1-src.tgz 9712721 RMD160 9d24861f5c95b8721858ffa0e5bca107b9c3f97c SHA1 c0d08e0e2904c1db1bb23ba828c977c1b8b8b295 SHA256 5cd1c739bc27f0b36776d8bb65f30745c670fa3a47e24b02a37f528d9c1659f8
+EBUILD PyMca-4.4.1_p1.ebuild 907 RMD160 95da157afb2799290b1672a5d81e93cba111e88c SHA1 10ab6fd88cb8ad01fc1a59230f8a490b1616ea3c SHA256 71e6e7108f9bfc313989f5e8feb53dc91bdb84ec60071367022a7badb236e260
+MISC ChangeLog 409 RMD160 bb9dc0aa5c47dd99d0ae470784eceef8c3810d2a SHA1 131bf0177f7635bbd37fe0871b78ed6f4fdce635 SHA256 340c75e0680cc23b10c7b99c18e17467abb2993292a65b21e9e21ab7b42dc0e2
+MISC metadata.xml 716 RMD160 e81aa91a0ddac4ee6e4e47a6d49f995633dc5a6d SHA1 eacb859d0e4ab55053d2eead2e054d786b4e3d97 SHA256 fb1a7c471f24ce1fe2579f32cd9620adcdf2d32b049ae352a2a27aaa10a80b80
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkz958IACgkQgAnW8HDreRaabwCcDU69+gMQ75jRxt/tU2db8rTf
+XNkAnjk86G6giTBf5FdpmNPs05yPAPHr
+=618o
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild b/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild
new file mode 100644
index 000000000000..ee5fa723cb7d
--- /dev/null
+++ b/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild,v 1.1 2010/12/07 07:52:29 jlec Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+MY_PV="${PV/_}"
+
+DESCRIPTION="X-ray Fluorescence Toolkit"
+HOMEPAGE="http://pymca.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/pymca/pymca/${PN}${PV/_p1}/pymca${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X matplotlib"
+
+DEPEND="
+ dev-python/numpy
+ dev-python/sip
+ virtual/opengl
+ X? (
+ dev-python/PyQt4
+ dev-python/pyqwt
+ )
+ matplotlib? ( dev-python/matplotlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ export SPECFILE_USE_GNU_SOURCE=1
+ distutils_src_prepare
+}
diff --git a/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch b/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch
new file mode 100644
index 000000000000..487a45963d21
--- /dev/null
+++ b/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch
@@ -0,0 +1,40 @@
+diff --git a/setup.py b/setup.py
+index 0b0fa58..a4fdab6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -41,34 +41,8 @@ for line in file(os.path.join('PyMca', 'PyMcaMain.py')).readlines():
+ print "PyMca X-Ray Fluorescence Toolkit %s" % __version__
+ print
+
+-print "Type 'L' to view the license."
+-print "Type 'yes' to accept the terms of the license."
+-print "Type 'no' to decline the terms of the license."
+-print
+-
+-while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except KeyboardInterrupt:
+- raise SystemExit
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(1)
+-
+- if resp == "l":
+- os.system("more LICENSE.GPL")
+-
+-
+ # Specify all the required PyMca data
+-data_files = [('PyMca', ['LICENSE.GPL',
+- 'PyMca/Scofield1973.dict',
++data_files = [('PyMca', ['PyMca/Scofield1973.dict',
+ 'PyMca/changelog.txt',
+ 'PyMca/McaTheory.cfg',
+ 'PyMca/PyMcaSplashImage.png',
diff --git a/sci-chemistry/PyMca/metadata.xml b/sci-chemistry/PyMca/metadata.xml
new file mode 100644
index 000000000000..587ced5941ce
--- /dev/null
+++ b/sci-chemistry/PyMca/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+The PyMca Toolkit is a collection of Python tools for visualization and
+analysis of energy-dispersive X-ray fluorescence data. It builds its graphic
+interface and plotting routines on top of the C++ libraries Qt and Qwt
+through their respective Python bindings PyQt and PyQwt. Nevertheless,
+the data analysis routines can be used independently of any graphical
+interface.
+</longdescription>
+<use>
+ <flag name='matplotlib'>Support for plotting through matplotlib</flag>
+</use>
+</pkgmetadata>