summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-18 11:43:46 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-18 11:43:46 +0000
commit8739170a854e431ec67a76af5ef8a1dac45e4613 (patch)
tree7862abf0c65e416e32e06f3858607a0b2bad9ce4 /sci-chemistry/autodock_vina
parentWith USE=test, depend on app-emacs/htmlize. Fixes bug 320361. (diff)
downloadhistorical-8739170a854e431ec67a76af5ef8a1dac45e4613.tar.gz
historical-8739170a854e431ec67a76af5ef8a1dac45e4613.tar.bz2
historical-8739170a854e431ec67a76af5ef8a1dac45e4613.zip
Initial addition of sci-chemistry/autodock_vina
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/autodock_vina')
-rw-r--r--sci-chemistry/autodock_vina/ChangeLog10
-rw-r--r--sci-chemistry/autodock_vina/Manifest15
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild43
-rw-r--r--sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch49
-rw-r--r--sci-chemistry/autodock_vina/metadata.xml28
5 files changed, 145 insertions, 0 deletions
diff --git a/sci-chemistry/autodock_vina/ChangeLog b/sci-chemistry/autodock_vina/ChangeLog
new file mode 100644
index 000000000000..d406ca5ace75
--- /dev/null
+++ b/sci-chemistry/autodock_vina/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/autodock_vina
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/ChangeLog,v 1.1 2010/05/18 11:43:46 jlec Exp $
+
+*autodock_vina-1.1.1 (18 May 2010)
+
+ 18 May 2010; Justin Lecher <jlec@gentoo.org> +files/1.1.1-gentoo.patch,
+ +autodock_vina-1.1.1.ebuild, +metadata.xml:
+ Initial addition
+
diff --git a/sci-chemistry/autodock_vina/Manifest b/sci-chemistry/autodock_vina/Manifest
new file mode 100644
index 000000000000..1fb3566452cb
--- /dev/null
+++ b/sci-chemistry/autodock_vina/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 1.1.1-gentoo.patch 1786 RMD160 3f42d18738654b75771a7737a53285e2df3d9641 SHA1 66ac15f2cec62e6298da9bfd40dcb6fedea5a193 SHA256 90f5786e8fca88b2c9ed1a7eeef58ef0c670fa154681a9b4af0b70a65f07aa94
+DIST autodock_vina_1_1_1.tgz 66972 RMD160 3e65dd8e38f9f726c9200057fc37e0fcafe7d460 SHA1 620b2f5713b7ad2f13cc90ddb837dfd9fd2b4875 SHA256 f9aaf6b2a322775e1be30f22fb69573418610300c0ab2b9345fd6accc1c1b9fd
+EBUILD autodock_vina-1.1.1.ebuild 970 RMD160 1f5e190edd4b2e7107a6b758c2aead20541108fd SHA1 4e43155469a5081aba0098d222d1f62be68c99f0 SHA256 577ec3f4d6047f4f44148a1c903d42cf80d69870e1ffe5cda2898c5c63005f21
+MISC ChangeLog 401 RMD160 cb3aeb98dce238aa343473b6e57ac986fb1e694c SHA1 8eb972f05a878d492a87e961786a23d5d4db7aea SHA256 291e40d3124d1db92ed0e165221edfe4ddad8228193c3da5688c3ea6c05f5892
+MISC metadata.xml 1114 RMD160 936aff80dc705e06c1456ad4e24fb1610dc4e378 SHA1 1e2e8b47f73f4efd7abbf8a1014487e73c3f29a8 SHA256 0ac241ba02e3e782357ea096ba1b5d7b4cef591d24552f8b404b2b5869fda12b
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkvyfXgACgkQgAnW8HDreRYpywCdFz/Am9aeQenPVZsxOViwnrqf
+kOkAnj6925e0o+fZ1NC+l/jZFY0p+bKj
+=MBCP
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild
new file mode 100644
index 000000000000..dfc1fa98263c
--- /dev/null
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock_vina/autodock_vina-1.1.1.ebuild,v 1.1 2010/05/18 11:43:46 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic versionator
+
+MY_P="${PN}_$(replace_all_version_separators _)"
+
+DESCRIPTION="Program for drug discovery, molecular docking and virtual screening"
+HOMEPAGE="http://vina.scripps.edu/"
+SRC_URI="http://vina.scripps.edu/download/${MY_P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE="debug"
+
+RDEPEND="dev-libs/boost"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}/build/linux/release
+
+src_prepare() {
+ cd "${WORKDIR}"/${MY_P} && epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_compile() {
+ local c_options
+
+ use debug || c_options="-DNDEBUG"
+
+ emake \
+ BASE="${EPREFIX}"/usr/ \
+ GPP="$(tc-getCXX)" \
+ C_OPTIONS="${c_options}" \
+ || die
+}
+
+src_install() {
+ dobin vina{,_split} || die
+}
diff --git a/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch b/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch
new file mode 100644
index 000000000000..5b24b4cbc488
--- /dev/null
+++ b/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch
@@ -0,0 +1,49 @@
+diff --git a/build/linux/debug/Makefile b/build/linux/debug/Makefile
+index d2c2d3b..d1f02e5 100644
+--- a/build/linux/debug/Makefile
++++ b/build/linux/debug/Makefile
+@@ -1,6 +1,6 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+-C_PLATFORM=-static-libgcc -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/bin/g++
+ C_OPTIONS= -g
+ BOOST_LIB_VERSION=
+diff --git a/build/linux/release/Makefile b/build/linux/release/Makefile
+index bfbcc1e..c9fd630 100644
+--- a/build/linux/release/Makefile
++++ b/build/linux/release/Makefile
+@@ -1,6 +1,6 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+-C_PLATFORM=-static-libgcc -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/bin/g++
+ C_OPTIONS= -O3 -DNDEBUG
+ BOOST_LIB_VERSION=
+diff --git a/build/makefile_common b/build/makefile_common
+index 885935c..4d5eb0f 100644
+--- a/build/makefile_common
++++ b/build/makefile_common
+@@ -1,16 +1,16 @@
+-BOOST_INCLUDE = $(BASE)/include/boost-${BOOST_VERSION}
++BOOST_INCLUDE = $(BASE)/include/boost
+
+ LIBOBJ = cache.o coords.o current_weights.o everything.o grid.o szv_grid.o manifold.o model.o monte_carlo.o mutate.o my_pid.o naive_non_cache.o non_cache.o parallel_mc.o parse_pdbqt.o pdb.o quasi_newton.o quaternion.o random.o ssd.o terms.o weighted_terms.o
+ MAINOBJ = main.o
+ SPLITOBJ = split.o
+
+-INCFLAGS = -I $(BOOST_INCLUDE)
++INCFLAGS = -I$(BOOST_INCLUDE)
+
+ CC = ${GPP} ${C_PLATFORM} -ansi -pedantic -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
+
+-LDFLAGS = -L$(BASE)/lib -L.
++LDFLAGS += -L.
+
+-LIBS = -l boost_system${BOOST_LIB_VERSION} -l boost_thread${BOOST_LIB_VERSION} -l boost_serialization${BOOST_LIB_VERSION} -l boost_filesystem${BOOST_LIB_VERSION} -l boost_program_options${BOOST_LIB_VERSION}#-l pthread
++LIBS = -lboost_system -lboost_thread -lboost_serialization -lboost_filesystem -lboost_program_options -lpthread
+
+ .SUFFIXES: .cpp .o
+
diff --git a/sci-chemistry/autodock_vina/metadata.xml b/sci-chemistry/autodock_vina/metadata.xml
new file mode 100644
index 000000000000..a5594d2c6825
--- /dev/null
+++ b/sci-chemistry/autodock_vina/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+AutoDock Vina is a new open-source program for drug discovery, molecular
+docking and virtual screening, offering multi-core capability, high
+performance and enhanced accuracy and ease of use. [1]
+AutoDock Vina has been designed and implemented by Dr. Oleg Trott
+in the Molecular Graphics Lab at The Scripps Research Institute.
+If you used AutoDock Vina in your work, please cite:
+O. Trott, A. J. Olson, AutoDock Vina: improving the speed and accuracy
+of docking with a new scoring function, efficient optimization and
+multithreading
+Journal of Computational Chemistry 31 (2010) 455-461
+</longdescription>
+<!--
+<use>
+ <flag name='flag'>Description of how USE='flag' affects this package</flag>
+ <flag name='userland_GNU'>Description of how USERLAND='GNU' affects this
+ package</flag>
+ <flag name='aspell'>Uses <pkg>app-text/aspell</pkg> for spell checking.
+ Requires an installed dictionary from <cat>app-dicts</cat></flag>
+</use>
+-->
+</pkgmetadata>