summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-20 13:33:13 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-20 13:33:13 +0000
commit53a665f57a331a24d618d7948547c80b0167f6c6 (patch)
treee268b01de5e66e85886663a2513b5888c0c5f9ad /sci-chemistry/cns/files
parentVersion Bump (diff)
downloadhistorical-53a665f57a331a24d618d7948547c80b0167f6c6.tar.gz
historical-53a665f57a331a24d618d7948547c80b0167f6c6.tar.bz2
historical-53a665f57a331a24d618d7948547c80b0167f6c6.zip
Included new version of aria
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/cns/files')
-rw-r--r--sci-chemistry/cns/files/1.2.1-aria2.3.patch22
-rw-r--r--sci-chemistry/cns/files/1.2.1-parallel.patch17
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-chemistry/cns/files/1.2.1-aria2.3.patch b/sci-chemistry/cns/files/1.2.1-aria2.3.patch
new file mode 100644
index 000000000000..8c6939d8eb92
--- /dev/null
+++ b/sci-chemistry/cns/files/1.2.1-aria2.3.patch
@@ -0,0 +1,22 @@
+diff --git a/cns/src/cns.f b/cns/src/cns.f
+index a3c2cbe..51a34f8 100644
+--- a/cns/src/cns.f
++++ b/cns/src/cns.f
+@@ -470,6 +470,7 @@ C local
+ INTEGER HNLEN, TMP, PTRSZ, STLEN
+ CHARACTER*(1) CNSPTMP
+ CHARACTER*(4) ST
++!$ integer omp_get_max_threads
+ C
+ C write header
+ WRITE(6,'(10X,A)')
+@@ -526,6 +527,9 @@ C
+ WRITE(6,'(10X,7A)')
+ & ' Running on machine: ',HOSTNM(1:HNLEN),
+ & ' (',SYSNM(1:TMP),',',ST(1:STLEN),'-bit)'
++!$ write(6,'(31x,a,i3,a)') 'with',omp_get_max_threads(),
++!$ & ' threads'
++!$C (to change use setenv OMP_NUM_THREADS x)
+ C
+ CALL GETNAM(USERNM,12,TMP)
+ WRITE(6,'(10X,2A)')
diff --git a/sci-chemistry/cns/files/1.2.1-parallel.patch b/sci-chemistry/cns/files/1.2.1-parallel.patch
new file mode 100644
index 000000000000..dfaa40021d66
--- /dev/null
+++ b/sci-chemistry/cns/files/1.2.1-parallel.patch
@@ -0,0 +1,17 @@
+diff --git a/instlib/source/Makefile.proto b/instlib/source/Makefile.proto
+index 0d0dd3e..ae9e422 100644
+--- a/instlib/source/Makefile.proto
++++ b/instlib/source/Makefile.proto
+@@ -19,9 +19,9 @@ DEPENDS = $(OBJS) dmemory.o machine_c.o
+
+ # the default is to make the cns executable
+ cns_solve:
+- @ make -k printflags F77BUG="$(debug)" DEBUG="$(debug)"
+- @ make -k ../bin/cns_solve F77BUG="$(debug)" DEBUG="$(debug)"
+- @ make -k exepurge
++ @ make printflags F77BUG="$(debug)" DEBUG="$(debug)"
++ @ make ${MAKEOPTS} ../bin/cns_solve F77BUG="$(debug)" DEBUG="$(debug)"
++ @ make exepurge
+
+ # rule for the fortran routines
+ $(OBJS):