summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-26 15:46:14 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-26 15:46:14 +0000
commit1a97cf02f110155422ab79583311858550b3900c (patch)
treef4386898789398820bdf28d59f5aea50e55478d9 /sci-chemistry/openbabel/openbabel-2.2.3.ebuild
parentsci-electronics/gnetman: Move to EAPI=4 (diff)
downloadhistorical-1a97cf02f110155422ab79583311858550b3900c.tar.gz
historical-1a97cf02f110155422ab79583311858550b3900c.tar.bz2
historical-1a97cf02f110155422ab79583311858550b3900c.zip
sci-chemistry/openbabel: Drop unnessecary die
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/openbabel/openbabel-2.2.3.ebuild')
-rw-r--r--sci-chemistry/openbabel/openbabel-2.2.3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sci-chemistry/openbabel/openbabel-2.2.3.ebuild b/sci-chemistry/openbabel/openbabel-2.2.3.ebuild
index 66bcd823981b..07717237848c 100644
--- a/sci-chemistry/openbabel/openbabel-2.2.3.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.2.3.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.2.3.ebuild,v 1.15 2011/06/16 23:56:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.2.3.ebuild,v 1.16 2012/04/26 15:46:14 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="openbabel.py pybel.py"
inherit eutils distutils
@@ -32,8 +33,6 @@ DEPEND="${RDEPEND}
python? ( swig? ( >=dev-lang/swig-1.3.38 ) )
doc? ( app-doc/doxygen )"
-RESTRICT_PYTHON_ABIS="3.*"
-
src_prepare() {
epatch "${FILESDIR}/${PN}-2.2.0-doxyfile.patch"
if use python; then
@@ -47,7 +46,7 @@ src_configure() {
if use swig; then
swigconf="--enable-maintainer-mode"
fi
- econf ${swigconf} || die "econf failed"
+ econf ${swigconf}
}
src_compile() {