summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-06 13:30:25 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-06 13:30:25 +0000
commitf52ad49c081602eae2d204ac74f730057f1c8e21 (patch)
treeb142b524f38f3fa5cb345c8aafd23a5493bc5174 /sci-chemistry/probe/files
parentFix tests (bug #326857). (diff)
downloadhistorical-f52ad49c081602eae2d204ac74f730057f1c8e21.tar.gz
historical-f52ad49c081602eae2d204ac74f730057f1c8e21.tar.bz2
historical-f52ad49c081602eae2d204ac74f730057f1c8e21.zip
As-needed fix
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/probe/files')
-rw-r--r--sci-chemistry/probe/files/as-needed.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-chemistry/probe/files/as-needed.patch b/sci-chemistry/probe/files/as-needed.patch
new file mode 100644
index 000000000000..9ddecf5f569e
--- /dev/null
+++ b/sci-chemistry/probe/files/as-needed.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 68d7469..bcb821c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ MACHINEFLAGS =
+ CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -lm $(MACHINEFLAGS)
++LFLAGS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+@@ -8,7 +8,7 @@ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ cc -c $*.c $(CFLAGS)
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ cc $(MACHINEFLAGS) -o $@ probe.o $(OBJLIST) $(LFLAGS)
+
+ clean:
+ @rm -f *.o *.ckp