summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 12:49:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 12:49:23 +0000
commitc55f2dcf9975ca8a5eb2d2bab4d0575a7d430879 (patch)
treec2e17c2be6fc53de9ee7b53cb2f330927519fcd3 /sci-chemistry/sparky/sparky-3.115.ebuild
parentDelete older ebuilds. (diff)
downloadhistorical-c55f2dcf9975ca8a5eb2d2bab4d0575a7d430879.tar.gz
historical-c55f2dcf9975ca8a5eb2d2bab4d0575a7d430879.tar.bz2
historical-c55f2dcf9975ca8a5eb2d2bab4d0575a7d430879.zip
Prefix cleaning, keyworded for *-linux, tested by me
Package-Manager: portage-2.2_rc65/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/sparky/sparky-3.115.ebuild')
-rw-r--r--sci-chemistry/sparky/sparky-3.115.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-chemistry/sparky/sparky-3.115.ebuild b/sci-chemistry/sparky/sparky-3.115.ebuild
index 81f0445d433b..17320dc90e76 100644
--- a/sci-chemistry/sparky/sparky-3.115.ebuild
+++ b/sci-chemistry/sparky/sparky-3.115.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.115.ebuild,v 1.2 2010/02/26 23:10:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.115.ebuild,v 1.3 2010/03/07 12:49:22 jlec Exp $
EAPI="3"
PYTHON_USE_WITH="tk"
+PYTHON_DEPEND="2"
inherit eutils flag-o-matic multilib prefix python toolchain-funcs
@@ -14,7 +15,7 @@ SRC_URI="http://www.cgl.ucsf.edu/home/sparky/distrib-${PV}/${PN}-source-${PV}.ta
LICENSE="sparky"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
RDEPEND="app-shells/tcsh"
@@ -25,6 +26,8 @@ RESTRICT="mirror"
S="${WORKDIR}/${PN}"
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
TKVER=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
PYVER=$(python_get_version)
}