summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-02-22 06:26:03 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-02-22 06:26:03 +0000
commit5fca83bfd9991181e45a71b8d28135fc5ef5b388 (patch)
tree9d46f46056c145c1a7c63164c3a36b094f1e167d /sci-chemistry/xdrawchem/xdrawchem-1.9.2.ebuild
parentVersion bump (diff)
downloadhistorical-5fca83bfd9991181e45a71b8d28135fc5ef5b388.tar.gz
historical-5fca83bfd9991181e45a71b8d28135fc5ef5b388.tar.bz2
historical-5fca83bfd9991181e45a71b8d28135fc5ef5b388.zip
Version bump
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sci-chemistry/xdrawchem/xdrawchem-1.9.2.ebuild')
-rw-r--r--sci-chemistry/xdrawchem/xdrawchem-1.9.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-chemistry/xdrawchem/xdrawchem-1.9.2.ebuild b/sci-chemistry/xdrawchem/xdrawchem-1.9.2.ebuild
new file mode 100644
index 000000000000..61ed2a48ec1d
--- /dev/null
+++ b/sci-chemistry/xdrawchem/xdrawchem-1.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdrawchem/xdrawchem-1.9.2.ebuild,v 1.1 2005/02/22 06:26:03 phosphan Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="a molecular structure drawing program"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3.1.0
+ >=sys-devel/gcc-3.2
+ dev-util/pkgconfig
+ >=sci-chemistry/openbabel-1.100.2*"
+
+src_compile() {
+ append-flags -O0 # incredible compile times otherwise
+ # make sure we use moc from Qt, not from eg media-sound/moc
+ PATH="${QTDIR}/bin:${PATH}"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ cd ${D}/usr/share
+ dodir /usr/share/doc
+ mv xdrawchem/doc doc/xdrawchem
+ dosym /usr/share/doc/xdrawchem /usr/share/xdrawchem/doc
+}