summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-11-22 13:36:56 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-11-22 13:36:56 +0000
commit56576599439fda68c77d0e71acca6486e0c51777 (patch)
tree2a98604c94192ffa5681b205e5f8b99e232b78a4 /sci-geosciences/osgearth/files
parentfix random style issues (diff)
downloadhistorical-56576599439fda68c77d0e71acca6486e0c51777.tar.gz
historical-56576599439fda68c77d0e71acca6486e0c51777.tar.bz2
historical-56576599439fda68c77d0e71acca6486e0c51777.zip
version bump, remove old
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0xE73C35B3
Diffstat (limited to 'sci-geosciences/osgearth/files')
-rw-r--r--sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch121
-rw-r--r--sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch35
2 files changed, 35 insertions, 121 deletions
diff --git a/sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch b/sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch
deleted file mode 100644
index 326a9b8c4cba..000000000000
--- a/sci-geosciences/osgearth/files/osgearth-2.4-FindMiniZip.cmake.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-commit 422e0901ddd760b230dc378e3b9359bd6d36200a
-Author: hasufell <hasufell@gentoo.org>
-Date: Sun Jul 21 18:59:14 2013 +0200
-
- BUILD: fix FindMiniZip.cmake module to use pkg-config
- https://github.com/gwaldron/osgearth/pull/340
-
-diff --git a/CMakeModules/FindMiniZip.cmake b/CMakeModules/FindMiniZip.cmake
-index c80ebbf..c8cae16 100644
---- a/CMakeModules/FindMiniZip.cmake
-+++ b/CMakeModules/FindMiniZip.cmake
-@@ -5,50 +5,65 @@
- # MINIZIP_INCLUDE_DIR, where to find the headers
- #
-
--FIND_PATH(MINIZIP_INCLUDE_DIR zip.h
-- ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-- $ENV{MINIZIP_DIR}/include
-- $ENV{MINIZIP_DIR}
-- $ENV{OSGDIR}/include
-- $ENV{OSGDIR}
-- $ENV{OSG_ROOT}/include
-- ~/Library/Frameworks
-- /Library/Frameworks
-- /usr/local/include
-- /usr/include
-- /sw/include # Fink
-- /opt/local/include # DarwinPorts
-- /opt/csw/include # Blastwave
-- /opt/include
-- [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/include
-- /usr/freeware/include
--)
-+# prefer pkg-config
-+IF(UNIX)
-+ INCLUDE(FindPkgConfig)
-+ IF(PKG_CONFIG_FOUND)
-+ pkg_check_modules(MINIZIP QUIET minizip)
-+ IF(MINIZIP_FOUND)
-+ # pkgconfig does not define the singular names
-+ SET(MINIZIP_LIBRARY ${MINIZIP_LIBRARIES})
-+ SET(MINIZIP_INCLUDE_DIR ${MINIZIP_INCLUDE_DIRS})
-+ ADD_DEFINITIONS(-DOSGEARTH_HAVE_MINIZIP)
-+ ENDIF(MINIZIP_FOUND)
-+ ENDIF(PKG_CONFIG_FOUND)
-+ENDIF(UNIX)
-
--FIND_LIBRARY(MINIZIP_LIBRARY
-- NAMES minizip
-- PATHS
-- ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-- $ENV{MINIZIP_DIR}/lib
-- $ENV{MINIZIP_DIR}
-- $ENV{OSGDIR}/lib
-- $ENV{OSGDIR}
-- $ENV{OSG_ROOT}/lib
-- ~/Library/Frameworks
-- /Library/Frameworks
-- /usr/local/lib
-- /usr/lib
-- /sw/lib
-- /opt/local/lib
-- /opt/csw/lib
-- /opt/lib
-- [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/lib
-- /usr/freeware/lib64
--)
--
--SET(MINIZIP_FOUND "NO")
--IF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-- SET(MINIZIP_FOUND "YES")
-- ADD_DEFINITIONS(-DOSGEARTH_HAVE_MINIZIP)
--ENDIF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-+# fallback logic
-+IF(NOT MINIZIP_FOUND)
-+ FIND_PATH(MINIZIP_INCLUDE_DIR zip.h
-+ ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-+ $ENV{MINIZIP_DIR}/include
-+ $ENV{MINIZIP_DIR}
-+ $ENV{OSGDIR}/include
-+ $ENV{OSGDIR}
-+ $ENV{OSG_ROOT}/include
-+ ~/Library/Frameworks
-+ /Library/Frameworks
-+ /usr/local/include
-+ /usr/include
-+ /sw/include # Fink
-+ /opt/local/include # DarwinPorts
-+ /opt/csw/include # Blastwave
-+ /opt/include
-+ [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/include
-+ /usr/freeware/include
-+ )
-
-+ FIND_LIBRARY(MINIZIP_LIBRARY
-+ NAMES minizip
-+ PATHS
-+ ${CMAKE_SOURCE_DIR}/src/3rdparty/minizip
-+ $ENV{MINIZIP_DIR}/lib
-+ $ENV{MINIZIP_DIR}
-+ $ENV{OSGDIR}/lib
-+ $ENV{OSGDIR}
-+ $ENV{OSG_ROOT}/lib
-+ ~/Library/Frameworks
-+ /Library/Frameworks
-+ /usr/local/lib
-+ /usr/lib
-+ /sw/lib
-+ /opt/local/lib
-+ /opt/csw/lib
-+ /opt/lib
-+ [HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Session\ Manager\\Environment;OSG_ROOT]/lib
-+ /usr/freeware/lib64
-+ )
-
-+ SET(MINIZIP_FOUND "NO")
-+ IF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-+ SET(MINIZIP_FOUND "YES")
-+ ADD_DEFINITIONS(-DOSGEARTH_HAVE_MINIZIP)
-+ ENDIF(MINIZIP_LIBRARY AND MINIZIP_INCLUDE_DIR)
-+ENDIF(NOT MINIZIP_FOUND)
diff --git a/sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch b/sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch
new file mode 100644
index 000000000000..a14ae658a7bd
--- /dev/null
+++ b/sci-geosciences/osgearth/files/osgearth-2.5-cmake-options.patch
@@ -0,0 +1,35 @@
+commit d92cee4d9870fab08fdfadf9ab0bfb4658a09aa3
+Author: hasufell <hasufell@gentoo.org>
+Date: Fri Nov 22 14:06:34 2013 +0100
+
+ add cmake options
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 34cd375..dbb4cb4 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -115,10 +115,20 @@ FIND_PACKAGE(Sqlite3)
+ FIND_PACKAGE(ZLIB)
+
+ SET(V8_DIR "" CACHE PATH "set to base V8 install path")
+-FIND_PACKAGE(V8)
+-
+-FIND_PACKAGE(JavaScriptCore)
+-FIND_PACKAGE(LibNoise)
++OPTION(OSGEARTH_USE_V8 "Enable to use V8 JavaScript engine" ON)
++IF(OSGEARTH_USE_V8)
++ FIND_PACKAGE(V8)
++ENDIF(OSGEARTH_USE_V8)
++
++OPTION(OSGEARTH_USE_JAVASCRIPTCORE "Enable use of JavaScriptCore" ON)
++OPTION(OSGEARTH_USE_LIBNOISE "Enable use of LibNoise" ON)
++
++IF (OSGEARTH_USE_JAVASCRIPTCORE)
++ FIND_PACKAGE(JavaScriptCore)
++ENDIF (OSGEARTH_USE_JAVASCRIPTCORE)
++IF (OSGEARTH_USE_LIBNOISE)
++ FIND_PACKAGE(LibNoise)
++ENDIF(OSGEARTH_USE_LIBNOISE)
+
+ FIND_PACKAGE(Qt4)
+ IF (QT4_FOUND)