summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:44:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-05 18:44:59 +0000
commit20ffc322b14b8241148e75185fb47ba101fc6fa8 (patch)
treed2041fa63bbcbe0320e1eff92f6ddaf6d3a33104 /sci-libs/ldl/ldl-2.0.1.ebuild
parentstable x86, bug 208997 (diff)
downloadhistorical-20ffc322b14b8241148e75185fb47ba101fc6fa8.tar.gz
historical-20ffc322b14b8241148e75185fb47ba101fc6fa8.tar.bz2
historical-20ffc322b14b8241148e75185fb47ba101fc6fa8.zip
Initial import, part of the suitesparse
Package-Manager: portage-2.1.4
Diffstat (limited to 'sci-libs/ldl/ldl-2.0.1.ebuild')
-rw-r--r--sci-libs/ldl/ldl-2.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/ldl/ldl-2.0.1.ebuild b/sci-libs/ldl/ldl-2.0.1.ebuild
new file mode 100644
index 000000000000..5d3de44ac393
--- /dev/null
+++ b/sci-libs/ldl/ldl-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ldl/ldl-2.0.1.ebuild,v 1.1 2008/02/05 18:39:06 bicatali Exp $
+
+inherit autotools eutils
+
+MY_PN=LDL
+DESCRIPTION="Simple but educational LDL^T matrix factorization algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ldl"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/ldl_userguide.pdf || die
+ fi
+}