summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-17 17:18:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-17 17:18:24 +0000
commite0d94ffdfcaf88e795cfa89524eef2de8788af58 (patch)
tree3645e1310b3d45dd38c476430ae496a5a4391ade /sci-libs
parentInitial addition. Ebuild written by me. (diff)
downloadhistorical-e0d94ffdfcaf88e795cfa89524eef2de8788af58.tar.gz
historical-e0d94ffdfcaf88e795cfa89524eef2de8788af58.tar.bz2
historical-e0d94ffdfcaf88e795cfa89524eef2de8788af58.zip
Initial Commit
Package-Manager: portage-2.2_rc97/cvs/Linux x86_64
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libexcelformat/ChangeLog10
-rw-r--r--sci-libs/libexcelformat/Manifest14
-rw-r--r--sci-libs/libexcelformat/libexcelformat-101016.ebuild29
-rw-r--r--sci-libs/libexcelformat/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/libexcelformat/ChangeLog b/sci-libs/libexcelformat/ChangeLog
new file mode 100644
index 000000000000..6a69d5c44668
--- /dev/null
+++ b/sci-libs/libexcelformat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/libexcelformat
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libexcelformat/ChangeLog,v 1.1 2010/10/17 17:18:24 jlec Exp $
+
+*libexcelformat-101016 (17 Oct 2010)
+
+ 17 Oct 2010; Justin Lecher <jlec@gentoo.org>
+ +libexcelformat-101016.ebuild, +metadata.xml:
+ Initial Commit
+
diff --git a/sci-libs/libexcelformat/Manifest b/sci-libs/libexcelformat/Manifest
new file mode 100644
index 000000000000..83ebc1799b56
--- /dev/null
+++ b/sci-libs/libexcelformat/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST libexcelformat-101016.tar.bz2 47980 RMD160 450f326905a307f06b09b67c41d891186c539d52 SHA1 d601958828084c8ce87a81ebaa4081f516d24923 SHA256 b1f552c4f89bb63fe7e46c04ef885a73f7bdd595116a09204a6f807100d55915
+EBUILD libexcelformat-101016.ebuild 681 RMD160 20b40cda8d3e9ab1f6c1d71e9d201bb7e3095bd8 SHA1 cc8b78cd60e66281a20578671c663202ca0c9e78 SHA256 ee5432a5f175a3fc6eeb81739b52b406d16cdbe521c9fd4ac55f64b7614c218e
+MISC ChangeLog 368 RMD160 8f12054f5a82e1355e06160f23fddd5d3462ca51 SHA1 ad8416b88b76c9f251fd2f651de9979c7caf95ec SHA256 97e7c13026b4b5e5fa8292ba6a580b78db7d60d3ce59a25f04ed85a562e7d081
+MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAky7L+UACgkQgAnW8HDreRZ4AQCgiWyP7VMXmvpm3YF6bVjfsCVf
+1GUAnjiDQeZnisApIGF+kLRpcIxuLrUt
+=jmew
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/libexcelformat/libexcelformat-101016.ebuild b/sci-libs/libexcelformat/libexcelformat-101016.ebuild
new file mode 100644
index 000000000000..81d617b7c9ef
--- /dev/null
+++ b/sci-libs/libexcelformat/libexcelformat-101016.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libexcelformat/libexcelformat-101016.ebuild,v 1.1 2010/10/17 17:18:24 jlec Exp $
+
+EAPI="3"
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="reading, writing, and editing of XLS (BIFF8 format) files using C++"
+HOMEPAGE="http://www.codeproject.com/KB/office/ExcelFormat.aspx"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="CPOL"
+IUSE=""
+
+S="${WORKDIR}"/libExcelFormat
+
+src_prepare() {
+ tc-export CXX
+}
+
+src_install() {
+ insinto /usr/include
+ doins *.h* || die
+
+ dolib.so libExcelFormat.so* || die
+}
diff --git a/sci-libs/libexcelformat/metadata.xml b/sci-libs/libexcelformat/metadata.xml
new file mode 100644
index 000000000000..efb490d78817
--- /dev/null
+++ b/sci-libs/libexcelformat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>