summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <tanderson@gentoo.org>2009-02-20 17:37:26 +0000
committerThomas Anderson <tanderson@gentoo.org>2009-02-20 17:37:26 +0000
commit2fd1b2ed597404b22067dd115f1963bf300d347d (patch)
tree5e428dd00d8a8ffabb5c9d56ae6b5dd3c226ed18 /sci-mathematics/dataplot/dataplot-20080225.ebuild
parentAdd patch for ICQ charset stuff, bug #235541 (diff)
downloadhistorical-2fd1b2ed597404b22067dd115f1963bf300d347d.tar.gz
historical-2fd1b2ed597404b22067dd115f1963bf300d347d.tar.bz2
historical-2fd1b2ed597404b22067dd115f1963bf300d347d.zip
Migrate to EAPI 2 use deps
Diffstat (limited to 'sci-mathematics/dataplot/dataplot-20080225.ebuild')
-rw-r--r--sci-mathematics/dataplot/dataplot-20080225.ebuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/sci-mathematics/dataplot/dataplot-20080225.ebuild b/sci-mathematics/dataplot/dataplot-20080225.ebuild
index 9c29323d32b9..31302ccb8c14 100644
--- a/sci-mathematics/dataplot/dataplot-20080225.ebuild
+++ b/sci-mathematics/dataplot/dataplot-20080225.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20080225.ebuild,v 1.4 2008/07/01 23:17:05 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20080225.ebuild,v 1.5 2009/02/20 17:36:44 gentoofan23 Exp $
+EAPI="2"
inherit eutils toolchain-funcs autotools fortran
# DAY MONTH YEAR
@@ -20,8 +21,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples gd gs opengl X"
COMMON_DEPEND="opengl? ( virtual/opengl )
- gd? ( media-libs/gd )
- gs? ( virtual/ghostscript media-libs/gd )"
+ gd? ( media-libs/gd[png,jpeg] )
+ gs? ( virtual/ghostscript media-libs/gd[png,jpeg] )"
DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
RDEPEND="${COMMON_DEPEND}
@@ -30,19 +31,7 @@ RDEPEND="${COMMON_DEPEND}
S="${WORKDIR}/${MY_P}"
S_AUX="${WORKDIR}/${MY_P_AUX}"
-pkg_setup() {
- #Dataplot requires media-libs/gd to be built with USE="png jpeg"
- if use gd || use gs; then
- if ! built_with_use -a media-libs/gd png jpeg; then
- eerror "media-libs/gd is not compiled with USE=\"png jpeg\""
- eerror "Please recompile media-libs/gd, ensuring USE=\"png jpeg\""
- die
- fi
- fi
- ##FIXME: Just gfortran for now, I'll get to testing g77 later
- FORTRAN="gfortran"
- fortran_pkg_setup
-}
+FORTRAN="gfortran"
src_unpack() {
# unpacking and renaming because