summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2008-03-14 10:54:33 +0000
committerChristian Heim <phreak@gentoo.org>2008-03-14 10:54:33 +0000
commitb93b0dfd0af27069f8e3d8eae10e4b15f21b6085 (patch)
tree47f52706cd45e5b716aa777a0958d205df5c287b /sci-mathematics/fann/fann-1.2.0.ebuild
parentRemoving Christian Andreetta (satya, #48841) from metadata.xml. (diff)
downloadhistorical-b93b0dfd0af27069f8e3d8eae10e4b15f21b6085.tar.gz
historical-b93b0dfd0af27069f8e3d8eae10e4b15f21b6085.tar.bz2
historical-b93b0dfd0af27069f8e3d8eae10e4b15f21b6085.zip
Fixing the minor syntax errors. Adding some style.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sci-mathematics/fann/fann-1.2.0.ebuild')
-rw-r--r--sci-mathematics/fann/fann-1.2.0.ebuild53
1 files changed, 26 insertions, 27 deletions
diff --git a/sci-mathematics/fann/fann-1.2.0.ebuild b/sci-mathematics/fann/fann-1.2.0.ebuild
index a068afed8cd5..34cfae29e23f 100644
--- a/sci-mathematics/fann/fann-1.2.0.ebuild
+++ b/sci-mathematics/fann/fann-1.2.0.ebuild
@@ -1,66 +1,65 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-1.2.0.ebuild,v 1.4 2007/07/13 05:28:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-1.2.0.ebuild,v 1.5 2008/03/14 10:54:33 phreak Exp $
inherit eutils
-#-----------------------------------------------------------------------------
+
DESCRIPTION="Fast Artificial Neural Network Library implements multilayer artificial neural networks in C"
HOMEPAGE="http://fann.sourceforge.net/"
SRC_URI="mirror://sourceforge/fann/${PF}.tar.bz2"
-#-----------------------------------------------------------------------------
+
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc python"
-#-----------------------------------------------------------------------------
+
DEPEND="sys-devel/autoconf
sys-apps/sed
doc? ( app-text/docbook-sgml-utils )
python? ( dev-lang/python dev-lang/swig )"
-#-----------------------------------------------------------------------------
+
S=${WORKDIR}/${PF}
-#=============================================================================
+
src_unpack() {
- unpack ${A} || die
- cd ${S} || die
- cp ${FILESDIR}/${PF}-setup.py ${S}/python/setup.py
+ unpack ${A}
+ cd "${S}"
+ cp "${FILESDIR}"/${PF}-setup.py "${S}"/python/setup.py
}
-#=============================================================================
+
src_compile() {
local myconf
myconf="--prefix=/usr"
- cd ${S} || die
- econf ${myconf} || die
- emake || die
+
+ cd "${S}"
+ econf ${myconf} || die "econf failed!"
+ emake || die "emake failed!"
if use python; then
- einfo "python ------------------------------"
- cd ${S}/python || die
+ cd "${S}"/python || die
mkdir fann
for f in `ls *py |grep -v setup.py`; do
mv $f fann || die
done
+ cd "${S}"
fi
}
-#=============================================================================
+
src_install() {
- cd ${S}
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die "make install failed!"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
if use doc; then
- einfo "doc ---------------------------------"
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
insinto /usr/share/doc/${PF}/benchmarks
- cp -pPR ${S}/benchmarks/* ${D}/usr/share/doc/${PF}/benchmarks
+ cp -pPR "${S}"/benchmarks/* "${D}"/usr/share/doc/${PF}/benchmarks
insinto /usr/share/doc/${PF}/examples/c
- doins ${S}/examples/*
+ doins "${S}"/examples/*
insinto /usr/share/doc/${PF}/html
- cp -pPR doc/html/* ${D}/usr/share/doc/${PF}/html
+ cp -pPR doc/html/* "${D}"/usr/share/doc/${PF}/html
insinto /usr/share/doc/${PF}/pdf
doins doc/*pdf
fi
if use python; then
- einfo "python ------------------------------"
- cd ${S}/python || die
- python setup.py install --root=${D} || die "No python"
+ cd "${S}"/python || die
+ python setup.py install --root="${D}" || die "python setup failed!"
if use doc; then
local python_doc_dir="/usr/share/doc/${PF}/examples/python"
insinto ${python_doc_dir}