summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-04-09 19:11:31 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-04-09 19:11:31 +0000
commit2a0c29a2096e3afe81dcf5d431f9ee742bf12abe (patch)
treeb78fe3bc9819c334781643554b6a1c65d45d19c6 /sci-mathematics
parentversion bump for security bug 362509 (diff)
downloadhistorical-2a0c29a2096e3afe81dcf5d431f9ee742bf12abe.tar.gz
historical-2a0c29a2096e3afe81dcf5d431f9ee742bf12abe.tar.bz2
historical-2a0c29a2096e3afe81dcf5d431f9ee742bf12abe.zip
New ebuild for minisat, a small fast SAT solver. Look it up... ;)
Package-Manager: portage-2.1.9.45/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/minisat/ChangeLog11
-rw-r--r--sci-mathematics/minisat/Manifest5
-rw-r--r--sci-mathematics/minisat/metadata.xml13
-rw-r--r--sci-mathematics/minisat/minisat-2.2.0.ebuild81
4 files changed, 110 insertions, 0 deletions
diff --git a/sci-mathematics/minisat/ChangeLog b/sci-mathematics/minisat/ChangeLog
new file mode 100644
index 000000000000..368bd6753737
--- /dev/null
+++ b/sci-mathematics/minisat/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/minisat
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/minisat/ChangeLog,v 1.1 2011/04/09 19:11:31 nerdboy Exp $
+
+*minisat-2.2.0 (09 Apr 2011)
+
+ 09 Apr 2011; Steve Arnold <nerdboy@gentoo.org> +minisat-2.2.0.ebuild,
+ +metadata.xml:
+ New ebuild for minisat, a small fast SAT solver (a tool for solving
+ the Boolean Satisfiability Problem used in model checking).
+
diff --git a/sci-mathematics/minisat/Manifest b/sci-mathematics/minisat/Manifest
new file mode 100644
index 000000000000..a406f0ee33a7
--- /dev/null
+++ b/sci-mathematics/minisat/Manifest
@@ -0,0 +1,5 @@
+DIST MiniSat.pdf 327416 RMD160 3b611bf17b2419525303527f93ef06bb3bb9d93b SHA1 8c17a48b2a93780d56bc2a3da5ddf5b9fce3572a SHA256 53197dbd783c924a2627d75e305706297988494265bd5e5ec873840e5d797ac4
+DIST minisat-2.2.0.tar.gz 43879 RMD160 169ec9116befa9067db9076d26309f7e9ab408dd SHA1 dfc25898bf40e00cf04252a42176e0c0600fbc90 SHA256 92957d851cdc3baddfe07b5fc80ed5a0237c489d0c52ae72f62844b3b46d7808
+EBUILD minisat-2.2.0.ebuild 1731 RMD160 35fb2aba41c1ba5f8abe19c33ffaa71a09c1e77e SHA1 bd2d664fb533e411e66a7dd6f6cd77d003900e67 SHA256 dc40227cf8c566a1c6c5230dd470f1a7d345483d548df17729309a5d419df281
+MISC ChangeLog 473 RMD160 b861a012b8a4fab3daac50646156596e706dde7d SHA1 d055b737f5a2e7bae9c52d8feb9110b7db20c547 SHA256 d928a5231e4b3030f586227f1fd6ae6f0fb5a0b58a397fcc568206f495087954
+MISC metadata.xml 385 RMD160 c3c54db2820acad2a21a2220d0b019609befff70 SHA1 b8aaaf15339df6a4a9ad0e5188582b7096d9ec87 SHA256 8985932b4ea92f71ffad7bde8c70dd42a7a2f49f8ed007969c08fbf420f96cc9
diff --git a/sci-mathematics/minisat/metadata.xml b/sci-mathematics/minisat/metadata.xml
new file mode 100644
index 000000000000..1c6eb08a7b39
--- /dev/null
+++ b/sci-mathematics/minisat/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>nerdboy@gentoo.org</email>
+</maintainer>
+<use>
+<flag name="extended-solver">Build extended version of SAT solver with
+ additional features.</flag>
+<flag name="prof">Build with profiling enabled.</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-mathematics/minisat/minisat-2.2.0.ebuild b/sci-mathematics/minisat/minisat-2.2.0.ebuild
new file mode 100644
index 000000000000..66e3421bac68
--- /dev/null
+++ b/sci-mathematics/minisat/minisat-2.2.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/minisat/minisat-2.2.0.ebuild,v 1.1 2011/04/09 19:11:31 nerdboy Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Small yet efficient SAT solver with reference paper."
+HOMEPAGE="http://minisat.se/Main.html"
+SRC_URI="http://minisat.se/downloads/${P}.tar.gz
+ doc? ( http://minisat.se/downloads/MiniSat.pdf )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT"
+
+IUSE="debug doc extended-solver prof"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ if use debug; then
+ myconf="d"
+ elif use prof; then
+ myconf="p"
+ else
+ myconf="r"
+ fi
+
+ sed -i -e "s|-O3|${CFLAGS} ${LDFLAGS}|" mtl/template.mk
+}
+
+src_compile() {
+ tc-export CXX
+ export MROOT="${S}"
+
+ if use extended-solver; then
+ cd simp
+ else
+ cd core
+ fi
+
+ gmake "$myconf" || die "make failed"
+ LIB="${PN}" gmake lib"$myconf" || die "make lib failed"
+ cd "${S}"
+}
+
+src_install() {
+ insinto /usr/include
+ doins utils/Options.h utils/System.h core/Solver.h core/SolverTypes.h
+
+ # somewhat brute-force, but so is the build setup...
+ if use extended-solver; then
+ cd simp
+ doins SimpSolver.h
+ else
+ cd core
+ fi
+
+ if use debug; then
+ newbin ${PN}_debug ${PN} || die
+ newlib.a lib${PN}_debug.a lib${PN}.a || die
+ elif use prof; then
+ newbin ${PN}_profile ${PN} || die
+ newlib.a lib${PN}_profile.a lib${PN}.a || die
+ else
+ newbin ${PN}_release ${PN} || die
+ newlib.a lib${PN}_release.a lib${PN}.a || die
+ fi
+ cd "${S}"
+
+ dodoc README doc/ReleaseNotes-2.2.0.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/MiniSat.pdf
+ fi
+}